aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2017-05-28 00:00:49 +0800
committerlinimon <linimon@FreeBSD.org>2017-05-28 00:00:49 +0800
commit678cc5ffcf99a20d0e62ec6b9f01fe5e0b799965 (patch)
tree7e54c3496ccc0bea5358ac0b74147c147f7b1881
parentd503867e5ad7b55ae5c95905ce34cbb6a3afcbb7 (diff)
downloadfreebsd-ports-gnome-678cc5ffcf99a20d0e62ec6b9f01fe5e0b799965.tar.gz
freebsd-ports-gnome-678cc5ffcf99a20d0e62ec6b9f01fe5e0b799965.tar.zst
freebsd-ports-gnome-678cc5ffcf99a20d0e62ec6b9f01fe5e0b799965.zip
Mark some ports failing on armv6, for errors classified as "clang_werror".
While here, pet portlint. Approved by: portmgr (tier-2 blanket)
-rw-r--r--games/cataclysm-dda/Makefile8
-rw-r--r--net-im/pidgin-sipe/Makefile3
-rw-r--r--security/sha1collisiondetection/Makefile3
-rw-r--r--sysutils/jobd/Makefile11
4 files changed, 14 insertions, 11 deletions
diff --git a/games/cataclysm-dda/Makefile b/games/cataclysm-dda/Makefile
index 26aec076a888..c5d452eeb92d 100644
--- a/games/cataclysm-dda/Makefile
+++ b/games/cataclysm-dda/Makefile
@@ -13,6 +13,10 @@ COMMENT= Fork/variant of Cataclysm Roguelike by Whales
LICENSE= CC-BY-SA-3.0
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+BROKEN_aarch64= fails to compile: comparison of integers of different signs: wchar_t and const int
+BROKEN_armv6= fails to compile: comparison of integers of different signs: wchar_t and const int
+BROKEN_powerpc64= fails to compile: overmap.cpp: 'pow' is not a member of 'std'
+
USES= alias compiler:c++11-lib execinfo gmake shebangfix
SHEBANG_FILES= lang/*.sh
bash_CMD= /bin/sh
@@ -60,10 +64,6 @@ SOUND_IMPLIES= SDL
SOUND_FILES= cataclysmthemeREV6.ogg Dark_Days_Ahead_demo_2.ogg
-BROKEN_aarch64= fails to compile: comparison of integers of different signs: wchar_t and const int
-BROKEN_armv6= fails to compile: comparison of integers of different signs: wchar_t and const int
-BROKEN_powerpc64= fails to compile: overmap.cpp: 'pow' is not a member of 'std'
-
.include <bsd.port.pre.mk>
.if ${CHOSEN_COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 36
diff --git a/net-im/pidgin-sipe/Makefile b/net-im/pidgin-sipe/Makefile
index 4ab110813dca..5d88719b3ded 100644
--- a/net-im/pidgin-sipe/Makefile
+++ b/net-im/pidgin-sipe/Makefile
@@ -19,9 +19,10 @@ LIB_DEPENDS= libnss3.so:security/nss \
libgstreamer-1.0.so:multimedia/gstreamer1 \
libnice.so:net-im/libnice \
libgmime-2.6.so:mail/gmime26
-
RUN_DEPENDS= pidgin:net-im/pidgin
+BROKEN_armv6= fails to compile: cast from 'struct sipe_core_public *' to 'struct sipe_core_private *' increases required alignment from 4 to 8
+
GNU_CONFIGURE= yes
USES= gmake libtool localbase pkgconfig tar:bzip2 ssl
USE_GNOME= gtk20 intltool libxml2
diff --git a/security/sha1collisiondetection/Makefile b/security/sha1collisiondetection/Makefile
index 4569b06fcc17..65494ecb6a08 100644
--- a/security/sha1collisiondetection/Makefile
+++ b/security/sha1collisiondetection/Makefile
@@ -11,7 +11,8 @@ COMMENT= Library and command line tool to detect SHA-1 collisions
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-BROKEN_powerpc64= fails to compile: cc1: error: unrecognized command line option -std=c90
+BROKEN_armv6= fails to compile: generic selections are a C11-specific feature [-Werror,-Wc11-extensions]
+BROKEN_powerpc64= fails to compile: cc1: unrecognized command line option -std=c90
USE_GITHUB= yes
GH_ACCOUNT= cr-marcstevens
diff --git a/sysutils/jobd/Makefile b/sysutils/jobd/Makefile
index 339d138d3621..913b3186a3ce 100644
--- a/sysutils/jobd/Makefile
+++ b/sysutils/jobd/Makefile
@@ -12,14 +12,15 @@ LICENSE= ISCL
BUILD_DEPENDS= docbook2mdoc:textproc/docbook2mdoc
-HAS_CONFIGURE= YES
-USE_GITHUB= YES
-USE_LDCONFIG= YES
-GH_ACCOUNT= mheily
-
BROKEN_aarch64= fails to compile: comparison of constant -1 with expression of type char is always true
+BROKEN_armv6= fails to compile: comparison of constant -1 with expression of type char is always true
BROKEN_mips64= fails to configure: unrecognized command line option -std=c++11
BROKEN_powerpc64= fails to configure: Unable to run configure in ./src/
BROKEN_sparc64= fails to configure: unrecognized command line option -std=c++11
+HAS_CONFIGURE= YES
+USE_GITHUB= YES
+USE_LDCONFIG= YES
+GH_ACCOUNT= mheily
+
.include <bsd.port.mk>