aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-09-03 02:41:05 +0800
committeraz <az@FreeBSD.org>2013-09-03 02:41:05 +0800
commit685919e13bb0585574c4443d01f47b1796797d82 (patch)
tree812008a6ea3d355a6dd907e5b78fcfb8c980397d
parent6fcb190e486fac9b692dd8daaaaaadbe348038f1 (diff)
downloadfreebsd-ports-gnome-685919e13bb0585574c4443d01f47b1796797d82.tar.gz
freebsd-ports-gnome-685919e13bb0585574c4443d01f47b1796797d82.tar.zst
freebsd-ports-gnome-685919e13bb0585574c4443d01f47b1796797d82.zip
- convert to the new perl5 framework
Approved by: portmgr (bapt@, blanket)
-rw-r--r--www/p5-Amon2-Plugin-LogDispatch/Makefile3
-rw-r--r--www/p5-Apache-Singleton/Makefile3
-rw-r--r--www/p5-CGI-Thin/Makefile3
-rw-r--r--www/p5-Catalyst-Plugin-Unicode-Encoding/Makefile3
-rw-r--r--www/p5-Dancer-Template-Xslate/Makefile3
-rw-r--r--www/p5-HTML-Location/Makefile3
-rw-r--r--www/p5-HTML-Template-Pro/Makefile3
-rw-r--r--www/p5-HTTP-Cookies-w3m/Makefile3
-rw-r--r--www/p5-HTTP-Parser-XS/Makefile3
-rw-r--r--www/p5-LWP-Online/Makefile3
-rw-r--r--www/p5-Mobile-UserAgent/Makefile3
-rw-r--r--www/p5-Net-FastCGI/Makefile3
-rw-r--r--www/p5-Plack-Handler-AnyEvent-HTTPD/Makefile3
-rw-r--r--www/p5-Plack-Middleware-File-Sass/Makefile3
-rw-r--r--www/p5-Plack-Middleware-SocketIO/Makefile3
-rw-r--r--www/p5-Plack-Server-Coro/Makefile3
-rw-r--r--www/p5-SCGI/Makefile3
-rw-r--r--www/p5-WWW-LongURL/Makefile3
-rw-r--r--www/wikicalc/Makefile2
19 files changed, 37 insertions, 19 deletions
diff --git a/www/p5-Amon2-Plugin-LogDispatch/Makefile b/www/p5-Amon2-Plugin-LogDispatch/Makefile
index d58919007bf4..552d87e38988 100644
--- a/www/p5-Amon2-Plugin-LogDispatch/Makefile
+++ b/www/p5-Amon2-Plugin-LogDispatch/Makefile
@@ -16,7 +16,8 @@ BUILD_DEPENDS= ${RUN_DEPENDS}
TEST_DEPENDS= \
p5-Test-Requires>0:${PORTSDIR}/devel/p5-Test-Requires
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Amon2::Plugin::LogDispatch.3 \
Amon2::Plugin::README.3
diff --git a/www/p5-Apache-Singleton/Makefile b/www/p5-Apache-Singleton/Makefile
index 34f1836b530c..42fea3b7444f 100644
--- a/www/p5-Apache-Singleton/Makefile
+++ b/www/p5-Apache-Singleton/Makefile
@@ -15,7 +15,8 @@ LICENSE_COMB= dual
RUN_DEPENDS= p5-Class-Singleton>=0:${PORTSDIR}/devel/p5-Class-Singleton
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Apache::Singleton.3 \
Apache::Singleton::Process.3 \
diff --git a/www/p5-CGI-Thin/Makefile b/www/p5-CGI-Thin/Makefile
index 5189d43a5fae..2866c352c95f 100644
--- a/www/p5-CGI-Thin/Makefile
+++ b/www/p5-CGI-Thin/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= pphillips@experts-exchange.com
COMMENT= A very lightweight Parser for CGI Forms
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= CGI::Thin.3 \
CGI::Thin::Cookies.3
diff --git a/www/p5-Catalyst-Plugin-Unicode-Encoding/Makefile b/www/p5-Catalyst-Plugin-Unicode-Encoding/Makefile
index 5e3a1552049f..7a964d169d86 100644
--- a/www/p5-Catalyst-Plugin-Unicode-Encoding/Makefile
+++ b/www/p5-Catalyst-Plugin-Unicode-Encoding/Makefile
@@ -25,7 +25,8 @@ BUILD_DEPENDS= p5-Catalyst-Runtime>=5.90015:${PORTSDIR}/www/p5-Catalyst-Runtime
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-IO-stringy>=0:${PORTSDIR}/devel/p5-IO-stringy
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Catalyst::Plugin::Unicode::Encoding.3
diff --git a/www/p5-Dancer-Template-Xslate/Makefile b/www/p5-Dancer-Template-Xslate/Makefile
index 1365cd454c20..2598e4ea2eae 100644
--- a/www/p5-Dancer-Template-Xslate/Makefile
+++ b/www/p5-Dancer-Template-Xslate/Makefile
@@ -18,7 +18,8 @@ RUN_DEPENDS= p5-Dancer>0:${PORTSDIR}/www/p5-Dancer \
p5-Text-Xslate>0:${PORTSDIR}/textproc/p5-Text-Xslate
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Dancer::Template::Xslate.3
diff --git a/www/p5-HTML-Location/Makefile b/www/p5-HTML-Location/Makefile
index cb5787ff4952..a3b53f23da10 100644
--- a/www/p5-HTML-Location/Makefile
+++ b/www/p5-HTML-Location/Makefile
@@ -16,7 +16,8 @@ BUILD_DEPENDS= p5-Clone>=0.23:${PORTSDIR}/devel/p5-Clone \
RUN_DEPENDS= p5-Clone>=0.23:${PORTSDIR}/devel/p5-Clone \
p5-URI>=1.35:${PORTSDIR}/net/p5-URI
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTML::Location.3
diff --git a/www/p5-HTML-Template-Pro/Makefile b/www/p5-HTML-Template-Pro/Makefile
index 318a2413abbe..1fbd3e1c7a6f 100644
--- a/www/p5-HTML-Template-Pro/Makefile
+++ b/www/p5-HTML-Template-Pro/Makefile
@@ -13,7 +13,8 @@ RUN_DEPENDS= \
p5-JSON>=2:${PORTSDIR}/converters/p5-JSON
BUILD_DEPENDS= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTML::Template::PerlInterface.3 \
HTML::Template::Pro.3 \
diff --git a/www/p5-HTTP-Cookies-w3m/Makefile b/www/p5-HTTP-Cookies-w3m/Makefile
index f89434137b08..62acda6b9167 100644
--- a/www/p5-HTTP-Cookies-w3m/Makefile
+++ b/www/p5-HTTP-Cookies-w3m/Makefile
@@ -20,6 +20,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= HTTP::Cookies::w3m.3
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/www/p5-HTTP-Parser-XS/Makefile b/www/p5-HTTP-Parser-XS/Makefile
index a255d8663a49..954fe3135da9 100644
--- a/www/p5-HTTP-Parser-XS/Makefile
+++ b/www/p5-HTTP-Parser-XS/Makefile
@@ -9,7 +9,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Perl extension of fast, primitive HTTP request parser
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTTP::Parser::XS.3
diff --git a/www/p5-LWP-Online/Makefile b/www/p5-LWP-Online/Makefile
index 44a1d600a394..37ee7e55f624 100644
--- a/www/p5-LWP-Online/Makefile
+++ b/www/p5-LWP-Online/Makefile
@@ -21,7 +21,8 @@ LICENSE_COMB= dual
RUN_DEPENDS+= p5-libwww>=5.805:${PORTSDIR}/www/p5-libwww \
p5-URI>=1.35:${PORTSDIR}/net/p5-URI
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= LWP::Online.3
diff --git a/www/p5-Mobile-UserAgent/Makefile b/www/p5-Mobile-UserAgent/Makefile
index 9efcb6e8f73d..6f88cfeb0d58 100644
--- a/www/p5-Mobile-UserAgent/Makefile
+++ b/www/p5-Mobile-UserAgent/Makefile
@@ -16,7 +16,8 @@ COMMENT= Parses a mobile user agent string into its basic constituent parts
RUN_DEPENDS= p5-Class-Singleton>=0:${PORTSDIR}/devel/p5-Class-Singleton
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Mobile::UserAgent.3 \
Mobile::UserAgentFactory.3
diff --git a/www/p5-Net-FastCGI/Makefile b/www/p5-Net-FastCGI/Makefile
index 8bf3c906506e..6289cb01d5df 100644
--- a/www/p5-Net-FastCGI/Makefile
+++ b/www/p5-Net-FastCGI/Makefile
@@ -13,7 +13,8 @@ COMMENT= Perl extension for FastCGI Toolkit
TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
p5-Test-HexString>=0:${PORTSDIR}/devel/p5-Test-HexString
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::FastCGI.3 \
Net::FastCGI::Constant.3 \
diff --git a/www/p5-Plack-Handler-AnyEvent-HTTPD/Makefile b/www/p5-Plack-Handler-AnyEvent-HTTPD/Makefile
index 9704e0aa7769..72a70563b402 100644
--- a/www/p5-Plack-Handler-AnyEvent-HTTPD/Makefile
+++ b/www/p5-Plack-Handler-AnyEvent-HTTPD/Makefile
@@ -22,7 +22,8 @@ RUN_DEPENDS= \
BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-Test-TCP>0:${PORTSDIR}/devel/p5-Test-TCP
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Plack::Handler::AnyEvent::HTTPD.3
diff --git a/www/p5-Plack-Middleware-File-Sass/Makefile b/www/p5-Plack-Middleware-File-Sass/Makefile
index 400f5530c398..914ea520fefe 100644
--- a/www/p5-Plack-Middleware-File-Sass/Makefile
+++ b/www/p5-Plack-Middleware-File-Sass/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS= \
BUILD_DEPENDS:= ${RUN_DEPENDS}
# Now, sass gem can be used instead of p5-Text-Sass.
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Plack::Middleware::File::Sass.3
diff --git a/www/p5-Plack-Middleware-SocketIO/Makefile b/www/p5-Plack-Middleware-SocketIO/Makefile
index 4225bf74b3c6..5f4b8db2d92c 100644
--- a/www/p5-Plack-Middleware-SocketIO/Makefile
+++ b/www/p5-Plack-Middleware-SocketIO/Makefile
@@ -22,7 +22,8 @@ RUN_DEPENDS= \
p5-Try-Tiny>0:${PORTSDIR}/lang/p5-Try-Tiny
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Plack::Middleware::SocketIO.3 \
Plack::Middleware::SocketIO::Base.3 \
diff --git a/www/p5-Plack-Server-Coro/Makefile b/www/p5-Plack-Server-Coro/Makefile
index 6f1295609398..abcb26578db6 100644
--- a/www/p5-Plack-Server-Coro/Makefile
+++ b/www/p5-Plack-Server-Coro/Makefile
@@ -23,7 +23,8 @@ BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-Test-Requires>=0:${PORTSDIR}/devel/p5-Test-Requires \
p5-Test-TCP>0:${PORTSDIR}/devel/p5-Test-TCP
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Plack::Server::Coro.3
diff --git a/www/p5-SCGI/Makefile b/www/p5-SCGI/Makefile
index c584bab3bd1d..ccebde802165 100644
--- a/www/p5-SCGI/Makefile
+++ b/www/p5-SCGI/Makefile
@@ -15,7 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= vivek@khera.org
COMMENT= SCGI server interface
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= SCGI.3 SCGI::Request.3
diff --git a/www/p5-WWW-LongURL/Makefile b/www/p5-WWW-LongURL/Makefile
index 5ba3d83b90bb..1813b99efea3 100644
--- a/www/p5-WWW-LongURL/Makefile
+++ b/www/p5-WWW-LongURL/Makefile
@@ -25,7 +25,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-LWP-Online>0:${PORTSDIR}/www/p5-LWP-Online
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WWW::LongURL.3
diff --git a/www/wikicalc/Makefile b/www/wikicalc/Makefile
index ce5322c9399b..0b87949d97d4 100644
--- a/www/wikicalc/Makefile
+++ b/www/wikicalc/Makefile
@@ -16,7 +16,7 @@ COMMENT= An Open Source Wiki-Spreadsheet
RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww
-USE_PERL5= yes
+USES= perl5
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
SUB_FILES= setup.sh