aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2013-03-25 04:09:00 +0800
committerswills <swills@FreeBSD.org>2013-03-25 04:09:00 +0800
commit68c7a2931b2def5be775b0ae724f95dfe4a7e4f6 (patch)
tree2dc75aed624f2669451d8a5ed2c58c688363b960
parent16e9155f1b6bcd4b2841060c4de844e97e106960 (diff)
downloadfreebsd-ports-gnome-68c7a2931b2def5be775b0ae724f95dfe4a7e4f6.tar.gz
freebsd-ports-gnome-68c7a2931b2def5be775b0ae724f95dfe4a7e4f6.tar.zst
freebsd-ports-gnome-68c7a2931b2def5be775b0ae724f95dfe4a7e4f6.zip
A Python interface to Last.fm (and other API compatible social networks)
WWW: http://code.google.com/p/pylast/ PR: ports/176308 Submitted by: Mark Felder <feld@feld.me>
-rw-r--r--audio/Makefile1
-rw-r--r--audio/py-pylast/Makefile22
-rw-r--r--audio/py-pylast/distinfo2
-rw-r--r--audio/py-pylast/pkg-descr3
4 files changed, 28 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index b913f324d188..611a61d0ad21 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -633,6 +633,7 @@
SUBDIR += py-mutagen
SUBDIR += py-ogg
SUBDIR += py-openal
+ SUBDIR += py-pylast
SUBDIR += py-pyliblo
SUBDIR += py-shout
SUBDIR += py-speex
diff --git a/audio/py-pylast/Makefile b/audio/py-pylast/Makefile
new file mode 100644
index 000000000000..a826f939d36a
--- /dev/null
+++ b/audio/py-pylast/Makefile
@@ -0,0 +1,22 @@
+# Created by: Mark Felder <feld@feld.me>
+# $FreeBSD$
+
+PORTNAME= pylast
+PORTVERSION= 0.5.11
+CATEGORIES= audio python
+MASTER_SITES= CHEESESHOP
+
+MAINTAINER= feld@feld.me
+COMMENT= A Python interface to Last.fm
+
+LICENSE= AL2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/pylast.py \
+ %%PYTHON_SITELIBDIR%%/pylast.pyc \
+ %%PYTHON_SITELIBDIR%%/pylast.pyo
+
+.include <bsd.port.mk>
diff --git a/audio/py-pylast/distinfo b/audio/py-pylast/distinfo
new file mode 100644
index 000000000000..23aeb56727db
--- /dev/null
+++ b/audio/py-pylast/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pylast-0.5.11.tar.gz) = bf35820be35447d55564d36072d40b09ac8a7fd41a6f1a7a9d408f4d0eaefac4
+SIZE (pylast-0.5.11.tar.gz) = 26146
diff --git a/audio/py-pylast/pkg-descr b/audio/py-pylast/pkg-descr
new file mode 100644
index 000000000000..4049f029cf7d
--- /dev/null
+++ b/audio/py-pylast/pkg-descr
@@ -0,0 +1,3 @@
+A Python interface to Last.fm (and other API compatible social networks)
+
+WWW: http://code.google.com/p/pylast/