aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbms <bms@FreeBSD.org>2009-07-05 08:31:30 +0800
committerbms <bms@FreeBSD.org>2009-07-05 08:31:30 +0800
commit69816dd31e4bdef607ec72c74e11122d6be2983a (patch)
treeffe045cee05ab8e7b9df292820dc31b58527bf67
parente8df6ac4e734336bcba6887a9bef9653b57c1d80 (diff)
downloadfreebsd-ports-gnome-69816dd31e4bdef607ec72c74e11122d6be2983a.tar.gz
freebsd-ports-gnome-69816dd31e4bdef607ec72c74e11122d6be2983a.tar.zst
freebsd-ports-gnome-69816dd31e4bdef607ec72c74e11122d6be2983a.zip
Add a stub port to install the vendor-neutral
AMQP 0.8 XML specification in a fairly central place. This is hard versioned like the autotools ports.
-rw-r--r--net/Makefile1
-rw-r--r--net/amqp08/Makefile29
-rw-r--r--net/amqp08/distinfo3
-rw-r--r--net/amqp08/pkg-descr9
-rw-r--r--net/amqp08/pkg-plist2
5 files changed, 44 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 6f14b1268883..db528c029059 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -16,6 +16,7 @@
SUBDIR += acx100
SUBDIR += adasockets
SUBDIR += aget
+ SUBDIR += amqp08
SUBDIR += apinger
SUBDIR += arp-scan
SUBDIR += arp-sk
diff --git a/net/amqp08/Makefile b/net/amqp08/Makefile
new file mode 100644
index 000000000000..05ef8a35775e
--- /dev/null
+++ b/net/amqp08/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: amqp08
+# Date Created: 2009-07-05
+# Whom: Bruce Simpson
+#
+# $FreeBSD$
+#
+
+PORTNAME= amqp08
+PORTVERSION= 20090705
+CATEGORIES= net
+MASTER_SITES= http://jira.amqp.org/confluence/download/attachments/720900/
+DISTNAME= amqp0-8.xml
+EXTRACT_SUFX=
+DIST_SUBDIR= amqp
+
+MAINTAINER= bms@FreeBSD.org
+COMMENT= Vendor neutral AMQP 0.8 XML specification
+
+NO_BUILD= defined
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/amqp
+ @${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME} \
+ ${PREFIX}/share/amqp
+
+.include <bsd.port.mk>
diff --git a/net/amqp08/distinfo b/net/amqp08/distinfo
new file mode 100644
index 000000000000..b1154416a204
--- /dev/null
+++ b/net/amqp08/distinfo
@@ -0,0 +1,3 @@
+MD5 (amqp/amqp0-8.xml) = 45110aa4637295861d34bebb802ef74b
+SHA256 (amqp/amqp0-8.xml) = 7e4af9b6b398503db1158419e6c7afecd5b90b5b894c81c329c214d919006f65
+SIZE (amqp/amqp0-8.xml) = 145900
diff --git a/net/amqp08/pkg-descr b/net/amqp08/pkg-descr
new file mode 100644
index 000000000000..a8db8501de9e
--- /dev/null
+++ b/net/amqp08/pkg-descr
@@ -0,0 +1,9 @@
+This is a simple stub port which provides the AMQP 0.8 XML schema.
+
+It is required by many AMQP applications, and installs it in a fairly
+well defined central location on a FreeBSD host, that is,
+${PREFIX}/share/amqp/amqp0-8.xml.
+
+Note that AMQP specifications are hard versioned.
+
+WWW: http://www.amqp.org/
diff --git a/net/amqp08/pkg-plist b/net/amqp08/pkg-plist
new file mode 100644
index 000000000000..1d0a88a73307
--- /dev/null
+++ b/net/amqp08/pkg-plist
@@ -0,0 +1,2 @@
+share/amqp/amqp0-8.xml
+@unexec rmdir %D/share/amqp 2>/dev/null || true