aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2004-12-23 20:41:49 +0800
committerdanfe <danfe@FreeBSD.org>2004-12-23 20:41:49 +0800
commit6988a5e3c603de29e500d2210db750de8856825b (patch)
tree7ef1c6f31993a3ee0a1c19655ef935fdf2da09da
parent0a75e6a4f711667784e7b51c222de4f58950c802 (diff)
downloadfreebsd-ports-gnome-6988a5e3c603de29e500d2210db750de8856825b.tar.gz
freebsd-ports-gnome-6988a5e3c603de29e500d2210db750de8856825b.tar.zst
freebsd-ports-gnome-6988a5e3c603de29e500d2210db750de8856825b.zip
Unbreak on i386.
Obtained from: NetBSD
-rw-r--r--emulators/ia64sim/Makefile4
-rw-r--r--emulators/ia64sim/files/patch-ia64.h26
2 files changed, 25 insertions, 5 deletions
diff --git a/emulators/ia64sim/Makefile b/emulators/ia64sim/Makefile
index 26e755c9ec13..ab469ac5d120 100644
--- a/emulators/ia64sim/Makefile
+++ b/emulators/ia64sim/Makefile
@@ -21,10 +21,6 @@ USE_ZIP= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 501103
-BROKEN+= "and does not build with latest gcc"
-.endif
-
.if ${ARCH} != "i386"
BROKEN= "Does not compile on !i386"
.endif
diff --git a/emulators/ia64sim/files/patch-ia64.h b/emulators/ia64sim/files/patch-ia64.h
index d1fc329e5b8b..761610a4626e 100644
--- a/emulators/ia64sim/files/patch-ia64.h
+++ b/emulators/ia64sim/files/patch-ia64.h
@@ -1,6 +1,30 @@
--- include/ia64.h.orig Sun May 6 11:39:29 2001
+++ include/ia64.h Sun May 6 11:35:10 2001
-@@ -31,2 +31,3 @@
+@@ -29,6 +29,7 @@
+ #include <ctype.h>
+ #include <string.h>
#include <elf.h>
+#include <sys/elf64.h>
+ #define TRUE 1
+ #define FALSE 0
+@@ -38,7 +39,7 @@
+ 0<=lo,hi<=63 and lo<=hi */
+
+ #define BITS(x,lo,hi) ( \
+- (uint32)(x##.q >> lo) & \
++ (uint32)(x.q >> lo) & \
+ ( (1<<(hi-lo+1)) - 1 ) \
+ )
+
+@@ -72,8 +73,8 @@
+ uint8 b[8];
+ } qword;
+
+-#define HI(x) (x##.d[1])
+-#define LO(x) (x##.d[0])
++#define HI(x) (x.d[1])
++#define LO(x) (x.d[0])
+
+ typedef struct {
+ qword dat;