aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-10-29 01:19:51 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-10-29 01:19:51 +0800
commit6ab3e17094bd54ddc796eef91d0b835d613a0641 (patch)
tree41c3cd861fd968b4320544314a6d8d2176971b4a
parent1fd1498dff24fb4b4cad2f7b8b50807e18ec7b07 (diff)
downloadfreebsd-ports-gnome-6ab3e17094bd54ddc796eef91d0b835d613a0641.tar.gz
freebsd-ports-gnome-6ab3e17094bd54ddc796eef91d0b835d613a0641.tar.zst
freebsd-ports-gnome-6ab3e17094bd54ddc796eef91d0b835d613a0641.zip
- Add p5-Data-Printer 0.24
Data::Printer is meant to do one thing and one thing only: display Perl variables and objects on screen, properly formatted (to be inspected by a human). Here's what Data::Printer has to offer to Perl developers, out of the box: - Very sane defaults (I hope!) - Highly customizable (in case you disagree with me :) - Colored output by default - Human-friendly output, with array index and custom separators - Full object dumps including methods, inheritance and internals - Exposes extra information such as tainted data and weak references - Ability to easily create filters for objects and regular structures - Ability to load settings from a .dataprinter file so you don't have to write anything other than "use DDP;" in your code! WWW: http://search.cpan.org/dist/Data-Printer/
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Data-Printer/Makefile46
-rw-r--r--devel/p5-Data-Printer/distinfo2
-rw-r--r--devel/p5-Data-Printer/pkg-descr16
-rw-r--r--devel/p5-Data-Printer/pkg-plist12
5 files changed, 77 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4f47e3d03ecc..a04bce9faca7 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1474,6 +1474,7 @@
SUBDIR += p5-Data-ParseBinary
SUBDIR += p5-Data-Path
SUBDIR += p5-Data-Peek
+ SUBDIR += p5-Data-Printer
SUBDIR += p5-Data-Properties
SUBDIR += p5-Data-Random
SUBDIR += p5-Data-Range-Compare
diff --git a/devel/p5-Data-Printer/Makefile b/devel/p5-Data-Printer/Makefile
new file mode 100644
index 000000000000..6f9cc85dcb27
--- /dev/null
+++ b/devel/p5-Data-Printer/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: p5-Data-Printer
+# Date created: 2011-10-24
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-Printer
+PORTVERSION= 0.24
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Colored pretty-print of Perl data structures and objects
+
+BUILD_DEPENDS= p5-Clone>=0:${PORTSDIR}/devel/p5-Clone \
+ p5-File-HomeDir>=0.91:${PORTSDIR}/devel/p5-File-HomeDir \
+ p5-Hash-FieldHash>=0:${PORTSDIR}/devel/p5-Hash-FieldHash \
+ p5-Moose>=2:${PORTSDIR}/devel/p5-Moose \
+ p5-Sort-Naturally>=0:${PORTSDIR}/textproc/p5-Sort-Naturally
+RUN_DEPENDS= p5-Clone>=0:${PORTSDIR}/devel/p5-Clone \
+ p5-File-HomeDir>=0.91:${PORTSDIR}/devel/p5-File-HomeDir \
+ p5-Hash-FieldHash>=0:${PORTSDIR}/devel/p5-Hash-FieldHash \
+ p5-Moose>=2:${PORTSDIR}/devel/p5-Moose \
+ p5-Sort-Naturally>=0:${PORTSDIR}/textproc/p5-Sort-Naturally
+
+PERL_CONFIGURE= yes
+
+MAN3= Data::Printer.3 \
+ Data::Printer::Filter.3 \
+ Data::Printer::Filter::DB.3 \
+ Data::Printer::Filter::DateTime.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.if ${PERL_LEVEL} < 501400
+BUILD_DEPENDS+= p5-Term-ANSIColor>=3:${PORTSDIR}/devel/p5-Term-ANSIColor
+RUN_DEPENDS+= p5-Term-ANSIColor>=3:${PORTSDIR}/devel/p5-Term-ANSIColor
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Data-Printer/distinfo b/devel/p5-Data-Printer/distinfo
new file mode 100644
index 000000000000..e6589160aa18
--- /dev/null
+++ b/devel/p5-Data-Printer/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Data-Printer-0.24.tar.gz) = 0a779856391433d856ed2664917d34d7bc41aebc1aa081cf54db34f49208e540
+SIZE (Data-Printer-0.24.tar.gz) = 40337
diff --git a/devel/p5-Data-Printer/pkg-descr b/devel/p5-Data-Printer/pkg-descr
new file mode 100644
index 000000000000..ca52763e73fd
--- /dev/null
+++ b/devel/p5-Data-Printer/pkg-descr
@@ -0,0 +1,16 @@
+Data::Printer is meant to do one thing and one thing only: display Perl
+variables and objects on screen, properly formatted (to be inspected by a
+human).
+
+Here's what Data::Printer has to offer to Perl developers, out of the box:
+- Very sane defaults (I hope!)
+- Highly customizable (in case you disagree with me :)
+- Colored output by default
+- Human-friendly output, with array index and custom separators
+- Full object dumps including methods, inheritance and internals
+- Exposes extra information such as tainted data and weak references
+- Ability to easily create filters for objects and regular structures
+- Ability to load settings from a .dataprinter file so you don't have to write
+ anything other than "use DDP;" in your code!
+
+WWW: http://search.cpan.org/dist/Data-Printer/
diff --git a/devel/p5-Data-Printer/pkg-plist b/devel/p5-Data-Printer/pkg-plist
new file mode 100644
index 000000000000..52ff66864718
--- /dev/null
+++ b/devel/p5-Data-Printer/pkg-plist
@@ -0,0 +1,12 @@
+%%SITE_PERL%%/DDP.pm
+%%SITE_PERL%%/Data/Printer.pm
+%%SITE_PERL%%/Data/Printer/Filter.pm
+%%SITE_PERL%%/Data/Printer/Filter/DB.pm
+%%SITE_PERL%%/Data/Printer/Filter/DateTime.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Printer/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Printer
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto
+@dirrm %%SITE_PERL%%/Data/Printer/Filter
+@dirrm %%SITE_PERL%%/Data/Printer
+@dirrmtry %%SITE_PERL%%/Data