aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjase <jase@FreeBSD.org>2014-02-13 21:23:05 +0800
committerjase <jase@FreeBSD.org>2014-02-13 21:23:05 +0800
commit6b38d2ed98498a45b81d5bc1f22ff89f14a696b1 (patch)
tree8faaa7bca7fcfd7543f6c25045fb355b92405bd9
parent488938abe5667bab890fdb7db0d54de2674c3d5e (diff)
downloadfreebsd-ports-gnome-6b38d2ed98498a45b81d5bc1f22ff89f14a696b1.tar.gz
freebsd-ports-gnome-6b38d2ed98498a45b81d5bc1f22ff89f14a696b1.tar.zst
freebsd-ports-gnome-6b38d2ed98498a45b81d5bc1f22ff89f14a696b1.zip
- Add additional primary MASTER_SITES for docs and manpages distfiles
to workaround ftp mirroring delay [1] - Consolidate all MASTER_SITES and MASTER_SITE_SUBDIR assignments Reported by: David Cecchin (via email) [1]
-rw-r--r--irc/weechat/Makefile34
1 files changed, 17 insertions, 17 deletions
diff --git a/irc/weechat/Makefile b/irc/weechat/Makefile
index 80026f3a4483..3cb12b7650a5 100644
--- a/irc/weechat/Makefile
+++ b/irc/weechat/Makefile
@@ -3,8 +3,12 @@
PORTNAME= weechat
PORTVERSION= 0.4.3
+PORTREVISION= 1
CATEGORIES= irc
-MASTER_SITES= http://weechat.org/files/src/
+MASTER_SITES= http://weechat.org/files/src/ \
+ http://perturb.me.uk/distfiles/weechat/:mandocs \
+ ${MASTER_SITE_LOCAL:S/$/:mandocs/}
+MASTER_SITE_SUBDIR= jase/weechat/:mandocs
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= jase@FreeBSD.org
@@ -118,12 +122,20 @@ CMAKE_ARGS+= -DENABLE_LUA=no
PLIST_SUB+= LUA="@comment "
.endif
+.if defined(MAINTAINER_MODE)
+BUILD_DEPENDS+= xsltproc:${PORTSDIR}/textproc/libxslt \
+ docbook-xsl>=0:${PORTSDIR}/textproc/docbook-xsl \
+ asciidoc:${PORTSDIR}/textproc/asciidoc \
+ source-highlight>=3.1.5:${PORTSDIR}/textproc/source-highlight
+CMAKE_ARGS+= -DENABLE_MAN=yes -DMANDIR=${MANPREFIX}/man -DENABLE_DOC=yes
+.else
+CMAKE_ARGS+= -DENABLE_MAN=no -DENABLE_DOC=no
+.endif
+
.if ${PORT_OPTIONS:MDOCS}
PLIST_SUB+= DOCS=""
.if !defined(MAINTAINER_MODE)
-MASTER_SITES+= ${MASTER_SITE_LOCAL:S/$/:doc/}
-MASTER_SITE_SUBDIR+= jase/weechat/:doc
-DISTFILES+= ${DISTNAME}-docs.txz:doc
+DISTFILES+= ${DISTNAME}-docs.txz:mandocs
.endif
.else
PLIST_SUB+= DOCS="@comment "
@@ -132,9 +144,7 @@ PLIST_SUB+= DOCS="@comment "
.if ${PORT_OPTIONS:MMANPAGES}
PLIST_SUB+= MANPAGES=""
.if !defined(MAINTAINER_MODE)
-MASTER_SITES+= ${MASTER_SITE_LOCAL:S/$/:man/}
-MASTER_SITE_SUBDIR+= jase/weechat/:man
-DISTFILES+= ${DISTNAME}-manpages.txz:man
+DISTFILES+= ${DISTNAME}-manpages.txz:mandocs
.endif
.else
PLIST_SUB+= MANPAGES="@comment "
@@ -150,16 +160,6 @@ PLIST_SUB+= ICON=""
PLIST_SUB+= ICON="@comment "
.endif
-.if defined(MAINTAINER_MODE)
-BUILD_DEPENDS+= xsltproc:${PORTSDIR}/textproc/libxslt \
- docbook-xsl>=0:${PORTSDIR}/textproc/docbook-xsl \
- asciidoc:${PORTSDIR}/textproc/asciidoc \
- source-highlight>=3.1.5:${PORTSDIR}/textproc/source-highlight
-CMAKE_ARGS+= -DENABLE_MAN=yes -DMANDIR=${MANPREFIX}/man -DENABLE_DOC=yes
-.else
-CMAKE_ARGS+= -DENABLE_MAN=no -DENABLE_DOC=no
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|$${LIBDIR}/../pkgconfig|$${CMAKE_INSTALL_PREFIX}/libdata/pkgconfig|' ${WRKSRC}/CMakeLists.txt
@${REINPLACE_CMD} -e 's|INSTALL|#INSTALL|' ${WRKSRC}/doc/CMakeLists.txt