aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-12-30 07:07:29 +0800
committerbapt <bapt@FreeBSD.org>2012-12-30 07:07:29 +0800
commit6c116eb1c970b2c054be4c0be1ebbb57f01a6afc (patch)
tree9f9baf559a2b9317069117692f9444e1494b1aa3
parentaa1ccad6cea6fa548cc2549dc0c9cec22579ab77 (diff)
downloadfreebsd-ports-gnome-6c116eb1c970b2c054be4c0be1ebbb57f01a6afc.tar.gz
freebsd-ports-gnome-6c116eb1c970b2c054be4c0be1ebbb57f01a6afc.tar.zst
freebsd-ports-gnome-6c116eb1c970b2c054be4c0be1ebbb57f01a6afc.zip
Convert romain's ports to new option framework
While here Trim headers Approved by: maintainer timeout (2 weeks)
-rw-r--r--audio/paprefs/Makefile13
-rw-r--r--devel/cutter/Makefile42
-rw-r--r--devel/libnfc/Makefile44
-rw-r--r--devel/nemiver/Makefile15
-rw-r--r--graphics/mscgen/Makefile11
-rw-r--r--ports-mgmt/portshaker/Makefile50
-rw-r--r--x11-themes/gtk-nodoka-engine/Makefile19
-rw-r--r--x11/xautolock/Makefile12
8 files changed, 92 insertions, 114 deletions
diff --git a/audio/paprefs/Makefile b/audio/paprefs/Makefile
index f87f30fc9ecf..e24563de6c16 100644
--- a/audio/paprefs/Makefile
+++ b/audio/paprefs/Makefile
@@ -1,9 +1,5 @@
-# Ports collection Makefile for: paprefs
-# Date created: July 21, 2007
-# Whom: Romain Tartière <romain@blogreen.org>
-#
+# Created by: Romain Tartière <romain@blogreen.org>
# $FreeBSD$
-#
PORTNAME= paprefs
PORTVERSION= 0.9.9
@@ -24,15 +20,16 @@ USE_GNOME= gnomeprefix gnomehack intltool
CONFIGURE_ARGS= --disable-lynx
-OPTIONS= PK "Force dependency on PackageKit" off
+OPTIONS_DEFINE= PK NLS
+PK_DESC= Force dependency on PackageKit
.include <bsd.port.options.mk>
-.if defined(WITH_PK)
+.if ${PORT_OPTIONS:MPK}
LIB_DEPENDS+= packagekit-glib2.14:${PORTSDIR}/ports-mgmt/packagekit
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else
diff --git a/devel/cutter/Makefile b/devel/cutter/Makefile
index 48d5234036f8..c853c50d5af8 100644
--- a/devel/cutter/Makefile
+++ b/devel/cutter/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: cutter
-# Date created: 2010-01-10
-# Whom: Romain Tartiere <romain@FreeBSD.org>
-#
+# Created by: Romain Tartiere <romain@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= cutter
PORTVERSION= 1.2.2
@@ -28,10 +24,10 @@ WANT_GSTREAMER= yes
MANLANG= "" ja
MAN1= cut-diff.1 cutter.1
-OPTIONS= GOFFICE "Enable GOffice support" yes \
- GST "Enable GStreamer support" yes \
- SOUP "Enable libsoup support" yes \
- LCOV "Force dependency on lcov" no
+OPTIONS_DEFINE= GOFFICE GSTREAMER SOUP LCOV
+GOFFICE_DESC= GOffice support
+SOUP_DESC= libsoup support
+LCOV_DESC= Force dependency on lcov
regression-test: build
@${SETENV} LC_ALL=C ${GMAKE} -C ${WRKSRC} check
@@ -41,38 +37,38 @@ post-install:
.include <bsd.port.options.mk>
-.if defined(WITHOUT_GOFFICE)
-CONFIGURE_ARGS+=--disable-goffice
-PLIST_SUB+= GOFFICE="@comment "
-.else
+.if ${PORT_OPTIONS:MGOFFICE}
CONFIGURE_ARGS+=--enable-goffice
LIB_DEPENDS+= goffice-0.6:${PORTSDIR}/devel/goffice06
PLIST_SUB+= GOFFICE=""
+.else
+CONFIGURE_ARGS+=--disable-goffice
+PLIST_SUB+= GOFFICE="@comment "
.endif
-.if defined(WITHOUT_GST)
-CONFIGURE_ARGS+=--disable-gstreamer
-PLIST_SUB+= GST="@comment "
-.else
+.if ${PORT_OPTIONS:MGSTREAMER}
CONFIGURE_ARGS+=--enable-gstreamer
USE_GSTREAMER=yes
PLIST_SUB+= GST="" GST_VERSION="${GST_VERSION}"
+.else
+CONFIGURE_ARGS+=--disable-gstreamer
+PLIST_SUB+= GST="@comment "
.endif
-.if defined(WITH_LCOV)
+.if ${PORT_OPTIONS:MLCOV}
RUN_DEPENDS+= lcov:${PORTSDIR}/devel/lcov
.endif
-.if defined(WITHOUT_SOUP)
-CONFIGURE_ARGS+=--disable-libsoup
-PLIST_SUB+= SOUP="@comment "
-.else
+.if ${PORT_OPTIONS:MSOUP}
CONFIGURE_ARGS+=--enable-libsoup
LIB_DEPENDS+= soup-2:${PORTSDIR}/devel/libsoup
PLIST_SUB+= SOUP=""
+.else
+CONFIGURE_ARGS+=--disable-libsoup
+PLIST_SUB+= SOUP="@comment "
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else
diff --git a/devel/libnfc/Makefile b/devel/libnfc/Makefile
index c9d456a51488..7a876a11fb6b 100644
--- a/devel/libnfc/Makefile
+++ b/devel/libnfc/Makefile
@@ -1,25 +1,23 @@
-# New ports collection makefile for: libnfc
-# Date created: 2009-06-17
-# Whom: Romain Tartiere <romain@blogreen.org>
-#
+# Created by: Romain Tartiere <romain@blogreen.org>
# $FreeBSD$
-#
PORTNAME= libnfc
PORTVERSION= 1.4.2
CATEGORIES= devel
MASTER_SITES= http://${PORTNAME}.googlecode.com/files/ \
- http://romain.blogreen.org/distfiles/
+ http://romain.blogreen.org/distfiles/
MAINTAINER= romain@FreeBSD.org
COMMENT= Near Field Communication (NFC) library
-OPTIONS= ACR122 "Enable ACR122 driver" on \
- ARYGON "Enable Arygon driver" off \
- PN531USB "Enable PN531 USB driver" on \
- PN532UART "Enable PN532 UART driver" on \
- PN533USB "Enable PN533 USB driver" on \
- SERIALPROBE "Enable serial auto-probe" off
+OPTIONS_DEFINE= ACR122 ARYGON PN531USB PN532UART PN533USB SERIALPROBE
+OPTIONS_DEFAULT= ACR122 PN531USB PN532UART PN533USB
+ACR122_DESC= ACR122 driver
+ARYGON_DESC= Arygon driver
+PN531USB_DESC= PN531 USB driver
+PN532UART_DESC= PN532 UART driver
+PN533USB_DESC= PN533 USB driver
+SERIALPROBE_DESC= serial auto-probe
GNU_CONFIGURE= yes
USE_GMAKE= yes
@@ -35,33 +33,33 @@ MAN1= nfc-anticol.1 nfc-dep-initiator.1 nfc-dep-target.1 \
# Restrict to stable (even) versions, indicated by the second component.
PORTSCOUT= limitw:1,even
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_ACR122)
+.if ${PORT_OPTIONS:MACR122}
ACR122_DRIVER= acr122,
.else
ACR122_DRIVER=
.endif
-.if defined(WITH_ARYGON)
+.if ${PORT_OPTIONS:MARYGON}
ARYGON_DRIVER= arygon,
.else
ARYGON_DRIVER=
.endif
-.if !defined(WITHOUT_PN531USB)
+.if ${PORT_OPTIONS:MPN531USB}
PN531USB_DRIVER=pn531_usb,
.else
PN531USB_DRIVER=
.endif
-.if !defined(WITHOUT_PN532UART)
+.if ${PORT_OPTIONS:MP532UART}
PN532UART_DRIVER=pn532_uart,
.else
PN532UART_DRIVER=
.endif
-.if !defined(WITHOUT_PN533USB)
+.if ${PORT_OPTIONS:MPN533USB}
PN533USB_DRIVER=pn533_usb,
.else
PN533USB_DRIVER=
@@ -69,18 +67,18 @@ PN533USB_DRIVER=
CONFIGURE_ARGS+=--with-drivers="${ACR122_DRIVER}${ARYGON_DRIVER}${PN531USB_DRIVER}${PN532UART_DRIVER}${PN533USB_DRIVER}"
-.if defined(WITH_SERIALPROBE)
+.if ${PORT_OPTIONS:MSERIALPROBE}
CONFIGURE_ARGS+=--enable-serial-autoprobe
.else
CONFIGURE_ARGS+=--disable-serial-autoprobe
.endif
-.if defined(WITH_ACR122)
+.if ${PORT_OPTIONS:MACR122}
LIB_DEPENDS+= pcsclite.1:${PORTSDIR}/devel/pcsc-lite
RUN_DEPENDS+= ${LOCALBASE}/lib/pcsc/drivers/ifd-ccid.bundle/Contents/FreeBSD/libccid.so:${PORTSDIR}/devel/libccid
.endif
-.if defined(WITH_PN531USB) || defined(WITH_PN533USB)
+.if ${PORT_OPTIONS:MPN531USB} || ${PORT_OPTIONS:MPN533USB}
.if ${OSVERSION} < 800069
LIB_DEPENDS+= usb-0.1:${PORTSDIR}/devel/libusb
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
@@ -89,9 +87,9 @@ LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
.endif
post-install:
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/pn53x.conf ${EXAMPLESDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/nemiver/Makefile b/devel/nemiver/Makefile
index 0a72ffce801a..dbf0f44bb06e 100644
--- a/devel/nemiver/Makefile
+++ b/devel/nemiver/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: nemiver
-# Date created: 2008-02-22
-# Whom: Romain Tartiere <romain@blogreen.org>
-#
+# Created by: Romain Tartiere <romain@blogreen.org>
# $FreeBSD$
-#
PORTNAME= nemiver
PORTVERSION= 0.8.2
@@ -24,7 +20,8 @@ LIB_DEPENDS= boost_unit_test_framework:${PORTSDIR}/devel/boost-libs \
BUILD_DEPENDS= ${LOCALBASE}/bin/gdb:${PORTSDIR}/devel/gdb
RUN_DEPENDS= ${LOCALBASE}/bin/gdb:${PORTSDIR}/devel/gdb
-OPTIONS= GHEX "Enable memory view" off
+OPTIONS_DEFINE= GHEX
+GHEX_DESC= Enable memory view
GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
@@ -38,7 +35,7 @@ INSTALLS_OMF= yes
INSTALLS_ICONS= yes
MAN1= nemiver.1
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if !exists(${LOCALBASE}/libdata/pkgconfig/gsettings-desktop-schemas.pc)
CONFIGURE_ARGS+=--enable-gsettings=no
@@ -54,7 +51,7 @@ PLIST_SUB+= GSETTINGS="" GCONF="@comment "
GLIB_SCHEMAS= org.nemiver.gschema.xml
.endif
-.if defined(WITH_GHEX) && !defined(WITHOUT_GHEX)
+.if ${PORT_OPTIONS:MGHEX}
CONFIGURE_ARGS+=--enable-memoryview
PLIST_SUB+= GHEX=""
LIB_DEPENDS+= gtkhex.0:${PORTSDIR}/editors/ghex
@@ -63,4 +60,4 @@ CONFIGURE_ARGS+=--disable-memoryview
PLIST_SUB+= GHEX="@comment "
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/mscgen/Makefile b/graphics/mscgen/Makefile
index 3ea9a8ca9285..3f34c47b7ac8 100644
--- a/graphics/mscgen/Makefile
+++ b/graphics/mscgen/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mscgen
-# Date created: 2011-01-23
-# Whom: Romain Tartiere <romain@FreeBSD.org>
-#
+# Created by: Romain Tartiere <romain@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= mscgen
PORTVERSION= 0.20
@@ -16,11 +12,12 @@ DISTNAME= ${PORTNAME}-src-${PORTVERSION}
MAINTAINER= romain@FreeBSD.org
COMMENT= A Message Sequence Chart Renderer
-OPTIONS= PNG "Enable PNG support" on
+OPTIONS_DEFINE= PNG
+OPTIONS_DEFAULT= PNG
.include <bsd.port.options.mk>
-.if !defined(WITHOUT_PNG)
+.if ${PORT_OPTIONS:MPNG}
CONFIGURE_ARGS+=--with-png
LIB_DEPENDS+= gd.4:${PORTSDIR}/graphics/gd
.else
diff --git a/ports-mgmt/portshaker/Makefile b/ports-mgmt/portshaker/Makefile
index 9d269befe98b..9bdb622dc7fd 100644
--- a/ports-mgmt/portshaker/Makefile
+++ b/ports-mgmt/portshaker/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: portshaker
-# Date created: 2008-11-01
-# Whom: Romain Tartiere <romain@blogreen.org>
-#
+# Created by: Romain Tartiere <romain@blogreen.org>
# $FreeBSD$
-#
PORTNAME?= portshaker
PORTVERSION= 1.0.6
@@ -17,58 +13,60 @@ MAINTAINER?= romain@FreeBSD.org
COMMENT?= Maintain ports tree using multiple sources
.if ${PORTNAME} == "portshaker"
-OPTIONS= RSYNC "Force dependency on rsync" on \
- SVN "Force dependency on Subversion" on \
- GIT "Force dependency on Git" off \
- HG "Force dependency on Mercurial" off \
-
+OPTIONS_DEFINE= RSYNC SVN GIT HG
+OPTIONS_DEFAULT= RSYNC SVN
+RSYNC_DESC= rsync support
+GIT_DESC= git support
+HG_DESC= mercurial support
MAN5= portshaker.conf.5 \
portshaker.d.5
MAN8= portshaker.8
.else
-OPTIONS= BSDSHARP "Enable BSD-sharp ports" on \
- ENLIGHTENMENT "Enable Enlightnement ports" off \
- HASKELL "Enable Haskell ports" off \
- MARCUSCOM "Enable GNOME development ports" off \
- TEXLIVE "Enable TeXLive ports (Experimental)" off \
- XORG "Enable Xorg development ports" off
+OPTIONS_DEFINE= BSDSHARP ENLIGHTENMENT HASKELL MARCUSCOM TEXLIVE XORG
+OPTIONS_DEFAULT= BSDSHARP
+BSDSHARP_DESC= Enable BSD-sharp ports
+ENLIGHTENMENT_DESC= Enable Enlightnement ports
+HASKELL_DESC= Enable Haskell ports
+MARCUSCOM_DESC= Enable GNOME development ports
+TEXLIVE_DESC= Enable TeXLive ports (Experimental)
+XORG_DESC Enable Xorg development ports
.endif
.include <bsd.port.options.mk>
.if ${PORTNAME} == "portshaker"
-. if defined(WITH_RSYNC)
+. if ${PORT_OPTIONS:MRSYNC}
RUN_DEPENDS+= rsync:${PORTSDIR}/net/rsync
. endif
-. if defined(WITH_SVN)
+. if ${PORT_OPTIONS:MSVN}
RUN_DEPENDS+= svn:${PORTSDIR}/devel/subversion
. endif
-. if defined(WITH_GIT)
+. if ${PORT_OPTIONS:MGIT}
RUN_DEPENDS+= git:${PORTSDIR}/devel/git
. endif
-. if defined(WITH_HG)
+. if ${PORT_OPTIONS:MHG}
RUN_DEPENDS+= hg:${PORTSDIR}/devel/mercurial
. endif
.else
-. if defined (WITH_BSDSHARP)
+. if ${PORT_OPTIONS:MBSDSHARP}
MAKE_ENV+= WITH_BSDSHARP=1
. endif
-. if defined (WITH_ENLIGHTENMENT)
+. if ${PORT_OPTIONS:MENLIGHTENMENT}
MAKE_ENV+= WITH_ENLIGHTENMENT=1
. endif
-. if defined (WITH_HASKELL)
+. if ${PORT_OPTIONS:MHASKELL}
MAKE_ENV+= WITH_HASKELL=1
. endif
-. if defined (WITH_MARCUSCOM)
+. if ${PORT_OPTIONS:MMARCUSCOM}
MAKE_ENV+= WITH_MARCUSCOM=1
. endif
-. if defined (WITH_TEXLIVE)
+. if ${PORT_OPTIONS:MTEXLIVE}
MAKE_ENV+= WITH_TEXLIVE=1
. endif
-. if defined (WITH_XORG)
+. if ${PORT_OPTIONS:MXORG}
MAKE_ENV+= WITH_XORG=1
. endif
diff --git a/x11-themes/gtk-nodoka-engine/Makefile b/x11-themes/gtk-nodoka-engine/Makefile
index 13a0d24d817f..7dee0bf79875 100644
--- a/x11-themes/gtk-nodoka-engine/Makefile
+++ b/x11-themes/gtk-nodoka-engine/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gtk-nodoka-engine
-# Date created: 2009-01-27
-# Whom: Romain Tartiere <romain@blogreen.org>
-#
+# Created by: Romain Tartiere <romain@blogreen.org>
# $FreeBSD$
-#
PORTNAME= gtk-nodoka-engine
PORTVERSION= 0.7.5
@@ -14,26 +10,27 @@ MASTER_SITES= https://fedorahosted.org/releases/n/o/nodoka/
MAINTAINER= romain@FreeBSD.org
COMMENT= GTK nodoka engine and themes
-OPTIONS= ANIMATION "Enable animation support" off \
- ANIMATIONTOLEFT "Animation from right to left" off
+OPTIONS_DEFINE= ANIMATION ANIMATIONTOLEFT
+ANIMATION_DESC= Animation support
+ANIMATIONTOLEFT_DESC= Animation from right to left
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GNOME= gtk20
USE_LDCONFIG= yes
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_ANIMATION) && !defined(WITHOUT_ANIMATION)
+.if ${PORT_OPTIONS:MANIMATION}
CONFIGURE_ARGS+= --enable-animation
.else
CONFIGURE_ARGS+= --disable-animation
.endif
-.if defined(WITH_ANIMATIONTOLEFT) && !defined(WITHOUT_ANIMATIONTOLEFT)
+.if ${PORT_OPTIONS:MANIMATIONTOLEFT}
CONFIGURE_ARGS+= --enable-animationtoleft
.else
CONFIGURE_ARGS+= --disable-animationtoleft
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11/xautolock/Makefile b/x11/xautolock/Makefile
index b3b54e9b2ffc..efdab93e50a9 100644
--- a/x11/xautolock/Makefile
+++ b/x11/xautolock/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xautolock
-# Date created: 20 Jul 1996
-# Whom: Eric Blood <eblood@cs.unr.edu>
-#
+# Created by: Eric Blood <eblood@cs.unr.edu>
# $FreeBSD$
-#
PORTNAME= xautolock
PORTVERSION= 2.2
@@ -16,11 +12,13 @@ EXTRACT_SUFX= .tgz
MAINTAINER= romain@FreeBSD.org
COMMENT= Used to activate xlock after a user defined time of inactivity
-OPTIONS= XLOCK "Force dependency on x11/xlockmore" on
+OPTIONS_DEFINE= XLOCK
+OPTIONS_DEFAULT= XLOCK
+XLOCK_DESC= Force dependency on x11/xlockmore
.include <bsd.port.options.mk>
-.if defined(WITH_XLOCK)
+.if ${PORT_OPTIONS:MXLOCK}
RUN_DEPENDS+= xlock:${PORTSDIR}/x11/xlockmore
.endif