aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-05-25 21:28:21 +0800
committermat <mat@FreeBSD.org>2016-05-25 21:28:21 +0800
commit6f8a8c0bfbc76d70286c18856310cb404b904ef3 (patch)
tree044700307196136e4d6731952eccbdc7f0b16b09
parent3e51ed5583b5f1b1d484ea09555e642b4cef3901 (diff)
downloadfreebsd-ports-gnome-6f8a8c0bfbc76d70286c18856310cb404b904ef3.tar.gz
freebsd-ports-gnome-6f8a8c0bfbc76d70286c18856310cb404b904ef3.tar.zst
freebsd-ports-gnome-6f8a8c0bfbc76d70286c18856310cb404b904ef3.zip
Add --with-dlopen=yes to the default options to allow using third
parties dlz drivers. While there: - enable the DLZ_FILESYSTEM option by default - convert to USES=mysql and USES=bdb Requested by: borius i ua Sponsored by: Absolight
-rw-r--r--dns/bind9-devel/Makefile9
-rw-r--r--dns/bind910/Makefile9
-rw-r--r--dns/bind99/Makefile9
3 files changed, 15 insertions, 12 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index 3a8eabc816ab..c5c159315552 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= bind
PORTVERSION= ${ISCVERSION:S/-P/P/:S/b/.b/}
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= dns net ipv6
MASTER_SITES= LOCAL/mat/bind
#MASTER_SITES= https://source.isc.org/cgi-bin/gitweb.cgi?p=bind9.git;a=snapshot;h=${HASH};sf=tgz;/
@@ -37,6 +37,7 @@ CONFIGURE_ARGS+= --localstatedir=/var --disable-linux-caps \
--with-randomdev=/dev/random \
--with-libxml2=${LOCALBASE} \
--with-readline=-ledit \
+ --with-dlopen=yes \
--sysconfdir=${ETCDIR}
ETCDIR= ${PREFIX}/etc/namedb
@@ -44,7 +45,7 @@ CONFLICTS+= bind9*-9.[456789].* bind9*-sdb-9.[456789].*
SUB_FILES= pkg-message
-OPTIONS_DEFAULT= SSL THREADS SIGCHASE IDN GSSAPI_NONE
+OPTIONS_DEFAULT= SSL THREADS SIGCHASE IDN GSSAPI_NONE DLZ_FILESYSTEM
OPTIONS_DEFINE= IDN LARGE_FILE PYTHON START_LATE \
FIXED_RRSET SIGCHASE IPV6 THREADS FILTER_AAAA
OPTIONS_RADIO= CRYPTO GOSTDEF
@@ -144,10 +145,10 @@ RPZ_NSDNAME_CONFIGURE_ENABLE= rpz-nsdname
RRL_CONFIGURE_ENABLE= rrl
DLZ_MYSQL_CONFIGURE_ON= --with-dlz-mysql=yes
-DLZ_MYSQL_USE= mysql=yes
+DLZ_MYSQL_USES= mysql
DLZ_BDB_CONFIGURE_ON= --with-dlz-bdb=yes
-DLZ_BDB_USE= bdb=yes
+DLZ_BDB_USES= bdb
DLZ_LDAP_CONFIGURE_ON= --with-dlz-ldap=yes
DLZ_LDAP_USE= openldap=yes
diff --git a/dns/bind910/Makefile b/dns/bind910/Makefile
index b15215128b6b..8fe89d9a395d 100644
--- a/dns/bind910/Makefile
+++ b/dns/bind910/Makefile
@@ -8,7 +8,7 @@ PORTVERSION= ${ISCVERSION:S/-P/P/:S/b/.b/}
PORTREVISION= 0
.else
# dns/bind910 here
-PORTREVISION= 0
+PORTREVISION= 1
.endif
CATEGORIES= dns net ipv6
MASTER_SITES= ISC/bind9/${ISCVERSION}
@@ -49,6 +49,7 @@ CONFIGURE_ARGS+= --localstatedir=/var --disable-linux-caps \
--with-randomdev=/dev/random \
--with-libxml2=${LOCALBASE} \
--with-readline=-ledit \
+ --with-dlopen=yes \
--sysconfdir=${ETCDIR}
.if defined(BIND_TOOLS_SLAVE)
CONFIGURE_ARGS+= --disable-shared
@@ -69,7 +70,7 @@ OPTIONS_RADIO_CRYPTO= SSL NATIVE_PKCS11
OPTIONS_RADIO_GOSTDEF= GOST GOST_ASN1
.if !defined(BIND_TOOLS_SLAVE)
-OPTIONS_DEFAULT+= RRL
+OPTIONS_DEFAULT+= RRL DLZ_FILESYSTEM
OPTIONS_DEFINE+= LINKS RPZ_NSIP RPZ_NSDNAME RRL DOCS NEWSTATS GEOIP \
MINCACHE PORTREVISION FETCHLIMIT QUERYTRACE
OPTIONS_GROUP= DLZ
@@ -167,10 +168,10 @@ RPZ_NSDNAME_CONFIGURE_ENABLE= rpz-nsdname
RRL_CONFIGURE_ENABLE= rrl
DLZ_MYSQL_CONFIGURE_ON= --with-dlz-mysql=yes
-DLZ_MYSQL_USE= mysql=yes
+DLZ_MYSQL_USES= mysql
DLZ_BDB_CONFIGURE_ON= --with-dlz-bdb=yes
-DLZ_BDB_USE= bdb=yes
+DLZ_BDB_USES= bdb
DLZ_LDAP_CONFIGURE_ON= --with-dlz-ldap=yes
DLZ_LDAP_USE= openldap=yes
diff --git a/dns/bind99/Makefile b/dns/bind99/Makefile
index ec4e320b4cc5..01423f4c7650 100644
--- a/dns/bind99/Makefile
+++ b/dns/bind99/Makefile
@@ -3,7 +3,7 @@
PORTNAME= bind
PORTVERSION= ${ISCVERSION:S/-P/P/:S/b/.b/}
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= dns net ipv6
MASTER_SITES= ISC/bind9/${ISCVERSION}
PKGNAMESUFFIX= 99
@@ -35,6 +35,7 @@ CONFIGURE_ARGS= --localstatedir=/var --disable-linux-caps \
--with-randomdev=/dev/random \
--with-libxml2=${LOCALBASE} \
--with-readline=-ledit \
+ --with-dlopen=yes \
--sysconfdir=${ETCDIR}
ETCDIR= ${PREFIX}/etc/namedb
@@ -42,7 +43,7 @@ CONFLICTS= bind9*-9.[45678].* bind9*-sdb-9.[45678].* bind-tools-9.*
SUB_FILES= pkg-message
-OPTIONS_DEFAULT= SSL THREADS SIGCHASE IDN GSSAPI_NONE RRL
+OPTIONS_DEFAULT= SSL THREADS SIGCHASE IDN GSSAPI_NONE RRL DLZ_FILESYSTEM
OPTIONS_DEFINE= SSL IDN REPLACE_BASE LARGE_FILE FIXED_RRSET SIGCHASE \
IPV6 THREADS FILTER_AAAA GOST PYTHON START_LATE MINCACHE \
LINKS RPZ_NSIP RPZ_NSDNAME RRL DOCS RPZ_PATCH NEWSTATS \
@@ -129,10 +130,10 @@ RPZ_PATCH_PATCH_SITES= http://ss.vix.su/~vjs/:vix LOCAL/mat/bind:vix
RRL_CONFIGURE_ENABLE= rrl
DLZ_MYSQL_CONFIGURE_ON= --with-dlz-mysql=yes
-DLZ_MYSQL_USE= mysql=yes
+DLZ_MYSQL_USES= mysql
DLZ_BDB_CONFIGURE_ON= --with-dlz-bdb=yes
-DLZ_BDB_USE= bdb=yes
+DLZ_BDB_USES= bdb
DLZ_LDAP_CONFIGURE_ON= --with-dlz-ldap=yes
DLZ_LDAP_USE= openldap=yes