aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-07-22 16:07:05 +0800
committermat <mat@FreeBSD.org>2016-07-22 16:07:05 +0800
commit6fd8e1a9ea364a23993ca2960c5a26b7a548849f (patch)
tree4af91b977218c1770d037c473e296282204ba5ad
parentb5b1b2e5679cc63dd7ed038e3b91357a460bcb65 (diff)
downloadfreebsd-ports-gnome-6fd8e1a9ea364a23993ca2960c5a26b7a548849f.tar.gz
freebsd-ports-gnome-6fd8e1a9ea364a23993ca2960c5a26b7a548849f.tar.zst
freebsd-ports-gnome-6fd8e1a9ea364a23993ca2960c5a26b7a548849f.zip
Stop people putting arguments to USES=ssl.
Sponsored by: Absolight
-rw-r--r--Mk/Uses/ssl.mk4
-rw-r--r--security/letskencrypt/Makefile2
-rw-r--r--www/node/Makefile2
-rw-r--r--www/node4/Makefile2
4 files changed, 7 insertions, 3 deletions
diff --git a/Mk/Uses/ssl.mk b/Mk/Uses/ssl.mk
index 5980521caf30..54777700430c 100644
--- a/Mk/Uses/ssl.mk
+++ b/Mk/Uses/ssl.mk
@@ -28,6 +28,10 @@
.if !defined(_INCLUDE_USES_SSL_MK)
_INCLUDE_USES_SSL_MK= yes
+.if !empty(ssl_ARGS)
+IGNORE= "USES=ssl does not take any argument."
+.endif
+
.include "${PORTSDIR}/Mk/bsd.default-versions.mk"
.if ${SSL_DEFAULT} == base
diff --git a/security/letskencrypt/Makefile b/security/letskencrypt/Makefile
index 2fb1f535f107..766f79d62699 100644
--- a/security/letskencrypt/Makefile
+++ b/security/letskencrypt/Makefile
@@ -13,7 +13,7 @@ COMMENT= Native C client for Let's Encrypt, designed for security
LICENSE= ISCL
-USES= gmake ssl:libressl tar:tgz
+USES= gmake ssl tar:tgz
MAKEFILE= GNUmakefile
MAKE_ARGS= PREFIX=${STAGEDIR}/${PREFIX}
diff --git a/www/node/Makefile b/www/node/Makefile
index b3a209e6ca93..2cde1edcd3ff 100644
--- a/www/node/Makefile
+++ b/www/node/Makefile
@@ -16,7 +16,7 @@ OPTIONS_DEFINE= BUNDLED_SSL DOCS NLS
OPTIONS_SUB= yes
BUNDLED_SSL_DESC= Use node.js's bundled OpenSSL implementation
-BUNDLED_SSL_USES_OFF= ssl:openssl
+BUNDLED_SSL_USES_OFF= ssl
BUNDLED_SSL_CONFIGURE_OFF+= --shared-openssl
NLS_CONFIGURE_ON= --with-intl=system-icu
diff --git a/www/node4/Makefile b/www/node4/Makefile
index 1f8c095eefc0..1da610949bda 100644
--- a/www/node4/Makefile
+++ b/www/node4/Makefile
@@ -19,7 +19,7 @@ OPTIONS_DEFINE= BUNDLED_SSL DOCS NLS
OPTIONS_SUB= yes
BUNDLED_SSL_DESC= Use node.js's bundled OpenSSL implementation
-BUNDLED_SSL_USES_OFF= ssl:openssl
+BUNDLED_SSL_USES_OFF= ssl
BUNDLED_SSL_CONFIGURE_OFF= --shared-openssl
NLS_CONFIGURE_ON= --with-intl=system-icu