aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2013-03-29 23:20:53 +0800
committernaddy <naddy@FreeBSD.org>2013-03-29 23:20:53 +0800
commit712e2eb2183ec152b31fa1191a42d3c4ceacb4ff (patch)
tree85f678acddde6ad4bcd839b2bfd328661362538a
parent65ebd55d7dea191de6cc88a8a5d75e76ba1b0a94 (diff)
downloadfreebsd-ports-gnome-712e2eb2183ec152b31fa1191a42d3c4ceacb4ff.tar.gz
freebsd-ports-gnome-712e2eb2183ec152b31fa1191a42d3c4ceacb4ff.tar.zst
freebsd-ports-gnome-712e2eb2183ec152b31fa1191a42d3c4ceacb4ff.zip
Also disable the use of SSE4/SSE4.2/AVX instructions when using the
old toolchain. Fixes the build on 8.4 i386. Submitted by: Thomas Zander <thomas.e.zander@googlemail.com> (maintainer)
-rw-r--r--multimedia/mplayer/Makefile.options3
1 files changed, 2 insertions, 1 deletions
diff --git a/multimedia/mplayer/Makefile.options b/multimedia/mplayer/Makefile.options
index 8a25ec1873e6..59dd4beeae83 100644
--- a/multimedia/mplayer/Makefile.options
+++ b/multimedia/mplayer/Makefile.options
@@ -74,7 +74,8 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-patch-clang-version
USE_GCC?= 4.6+
BUILD_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
.else
-CONFIGURE_ARGS+=--disable-ssse3 --disable-fast-cmov
+CONFIGURE_ARGS+=--disable-ssse3 --disable-sse4 --disable-sse42 \
+ --disable-avx --disable-fast-cmov
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-base_system_gcc
.if ${ARCH} == "amd64"
BUILD_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils