aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2006-08-13 23:30:22 +0800
committersat <sat@FreeBSD.org>2006-08-13 23:30:22 +0800
commit714822554d78759fa00cad296d2f3e5a6cb0ac86 (patch)
tree07f5643c6a82e329badac9cab8bc0d1d7a5518ff
parentcae355e4d71a861301499933d284b6163e4661f2 (diff)
downloadfreebsd-ports-gnome-714822554d78759fa00cad296d2f3e5a6cb0ac86.tar.gz
freebsd-ports-gnome-714822554d78759fa00cad296d2f3e5a6cb0ac86.tar.zst
freebsd-ports-gnome-714822554d78759fa00cad296d2f3e5a6cb0ac86.zip
Add port textproc/flex:
Flex is a tool for generating scanners. A scanner, sometimes called a tokenizer, is a program which recognizes lexical patterns in text. The flex program reads user-specified input files, or its standard input if no file names are given, for a description of a scanner to generate. The description is in the form of pairs of regular expressions and C code, called rules. Flex generates a C source file named, "lex.yy.c", which defines the function yylex(). The file "lex.yy.c" can be compiled and linked to produce an executable. When the executable is run, it analyzes its input for occurrences of text matching the regular expressions for each rule. Whenever it finds a match, it executes the corresponding C code. WWW: http://flex.sourceforge.net/ Note that there's flex 2.5.4 in the base system. This port provides a newer version for programs that require it, textproc/xxdiff for one.
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/flex/Makefile32
-rw-r--r--textproc/flex/distinfo3
-rw-r--r--textproc/flex/pkg-descr13
4 files changed, 49 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 27a0503e41cf..7fe2bfd9de50 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -133,6 +133,7 @@
SUBDIR += fist
SUBDIR += fixrtf
SUBDIR += fldiff
+ SUBDIR += flex
SUBDIR += flip
SUBDIR += fo-aspell
SUBDIR += foiltex
diff --git a/textproc/flex/Makefile b/textproc/flex/Makefile
new file mode 100644
index 000000000000..1f0798763e19
--- /dev/null
+++ b/textproc/flex/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: flex
+# Date created: 13 August 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= flex
+PORTVERSION= 2.5.33
+CATEGORIES= textproc
+MASTER_SITES= SF
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Fast lexical analyzer generator
+
+BUILD_DEPENDS= bison:${PORTSDIR}/devel/bison2 \
+ help2man:${PORTSDIR}/misc/help2man \
+ gm4:${PORTSDIR}/devel/m4
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-nls
+USE_GMAKE= yes
+MAN1= flex.1
+PLIST_FILES= bin/flex include/FlexLexer.h lib/libfl.a
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/install-info-recursive//g;s/info-recursive//g' \
+ -e 's/po //;s/tests//' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's/ install-info-am//' ${WRKSRC}/doc/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/textproc/flex/distinfo b/textproc/flex/distinfo
new file mode 100644
index 000000000000..f493e7e494b2
--- /dev/null
+++ b/textproc/flex/distinfo
@@ -0,0 +1,3 @@
+MD5 (flex-2.5.33.tar.bz2) = 343374a00b38d9e39d1158b71af37150
+SHA256 (flex-2.5.33.tar.bz2) = 53b56a62ea9409b99b7a0ac4a5204fac16ca7eaf39b9374164c346d6badc6914
+SIZE (flex-2.5.33.tar.bz2) = 695464
diff --git a/textproc/flex/pkg-descr b/textproc/flex/pkg-descr
new file mode 100644
index 000000000000..3b01acfbc2b5
--- /dev/null
+++ b/textproc/flex/pkg-descr
@@ -0,0 +1,13 @@
+Flex is a tool for generating scanners. A scanner, sometimes called a
+tokenizer, is a program which recognizes lexical patterns in text. The
+flex program reads user-specified input files, or its standard input
+if no file names are given, for a description of a scanner to generate.
+The description is in the form of pairs of regular expressions and C
+code, called rules. Flex generates a C source file named, "lex.yy.c",
+which defines the function yylex(). The file "lex.yy.c" can be compiled
+and linked to produce an executable. When the executable is run, it
+analyzes its input for occurrences of text matching the regular
+expressions for each rule. Whenever it finds a match, it executes the
+corresponding C code.
+
+WWW: http://flex.sourceforge.net/