aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-09-05 23:38:51 +0800
committeradamw <adamw@FreeBSD.org>2014-09-05 23:38:51 +0800
commit720a657626d17d3b3c906d197319db67f90285d1 (patch)
tree1ce75a35dfd302151af2fd341fb6be6d7b1320a9
parent1cb7db80548a45225699b622e6d7368515a24f47 (diff)
downloadfreebsd-ports-gnome-720a657626d17d3b3c906d197319db67f90285d1.tar.gz
freebsd-ports-gnome-720a657626d17d3b3c906d197319db67f90285d1.tar.zst
freebsd-ports-gnome-720a657626d17d3b3c906d197319db67f90285d1.zip
Older make (8 and 9) treats a string as one large string. Newer make (10+)
treats a string as a collection of words. Somehow a double-space was introduced into CFLAGS, which caused gdb66's configure to choke. Newer make had to be told to examine the entire line to get rid of it, but that syntax (/W) was unknown to older make. So, split the difference and just make a shell call to remove the space. The port can now build on 10 and 11.
-rw-r--r--devel/gdb66/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/devel/gdb66/Makefile b/devel/gdb66/Makefile
index 05d1b804b234..59aa1b5461cc 100644
--- a/devel/gdb66/Makefile
+++ b/devel/gdb66/Makefile
@@ -27,7 +27,8 @@ CONFIGURE_ARGS= --program-suffix=${PORTVERSION:S/.//g} \
--disable-werror \
--enable-target=all \
--enable-tui ${ICONV_CONFIGURE_ARG}
-CFLAGS:= ${CFLAGS:C/ +$//} # blanks at EOL creep in sometimes
+ # remove consecutive blanks, which causes configure to fail
+CFLAGS!= echo ${CFLAGS}|sed -e 's/ / /g'
CFLAGS+= -DRL_NO_COMPAT
EXCLUDE= dejagnu expect readline sim texinfo intl
EXTRACT_AFTER_ARGS= ${EXCLUDE:S/^/--exclude /}