aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2011-07-04 23:48:33 +0800
committerswills <swills@FreeBSD.org>2011-07-04 23:48:33 +0800
commit73038235f414ec483bb81b247118f5a1fe395135 (patch)
tree9eedbefb42d042c557031894e2bb34d249713993
parentf5013235fdf60998beded93b34adfc900bd36936 (diff)
downloadfreebsd-ports-gnome-73038235f414ec483bb81b247118f5a1fe395135.tar.gz
freebsd-ports-gnome-73038235f414ec483bb81b247118f5a1fe395135.tar.zst
freebsd-ports-gnome-73038235f414ec483bb81b247118f5a1fe395135.zip
- Mark as broken with Ruby 1.9
-rw-r--r--devel/ruby-io-reactor/Makefile6
-rw-r--r--devel/ruby-jttui/Makefile3
-rw-r--r--devel/ruby-slang/Makefile4
-rw-r--r--graphics/ruby-opengl/Makefile6
-rw-r--r--graphics/rubygem-turing/Makefile6
-rw-r--r--japanese/ruby-chasen/Makefile3
-rw-r--r--japanese/ruby-eb/Makefile4
-rw-r--r--lang/ruby-lua4/Makefile6
-rw-r--r--security/ruby-tcpwrap/Makefile6
-rw-r--r--textproc/ruby-amrita/Makefile6
-rw-r--r--textproc/ruby-xmlscan-old/Makefile6
-rw-r--r--x11-toolkits/ruby-gtk/Makefile6
-rw-r--r--x11-toolkits/ruby-wx/Makefile3
-rw-r--r--x11/ruby-gtktrayicon/Makefile6
14 files changed, 62 insertions, 9 deletions
diff --git a/devel/ruby-io-reactor/Makefile b/devel/ruby-io-reactor/Makefile
index a7e1475f5d89..297bda9e9ccd 100644
--- a/devel/ruby-io-reactor/Makefile
+++ b/devel/ruby-io-reactor/Makefile
@@ -37,4 +37,8 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not build with ruby 1.9
+.endif
+.include <bsd.port.post.mk>
diff --git a/devel/ruby-jttui/Makefile b/devel/ruby-jttui/Makefile
index 2b6b50e2553f..812d53d7a6ed 100644
--- a/devel/ruby-jttui/Makefile
+++ b/devel/ruby-jttui/Makefile
@@ -24,6 +24,9 @@ USE_RUBY_EXTCONF= yes
INSTALL_TARGET= site-install
.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not build with ruby 1.9
+.endif
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODDOCDIR}
diff --git a/devel/ruby-slang/Makefile b/devel/ruby-slang/Makefile
index e64b23494893..20a09fb8028f 100644
--- a/devel/ruby-slang/Makefile
+++ b/devel/ruby-slang/Makefile
@@ -34,6 +34,10 @@ DOCS_JA= README.euc
.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not build with ruby 1.9
+.endif
+
.if defined(PKGNAMEPREFIX)
PKGNAMEPREFIX:= ${PKGNAMEPREFIX}${RUBY_PKGNAMEPREFIX}
.else
diff --git a/graphics/ruby-opengl/Makefile b/graphics/ruby-opengl/Makefile
index cb52d38719e8..06c759be0eea 100644
--- a/graphics/ruby-opengl/Makefile
+++ b/graphics/ruby-opengl/Makefile
@@ -35,4 +35,8 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/README.EUC ${RUBY_MODDOCDIR}/ja/
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not build with ruby 1.9
+.endif
+.include <bsd.port.post.mk>
diff --git a/graphics/rubygem-turing/Makefile b/graphics/rubygem-turing/Makefile
index 4f51ea70dabd..d75a59d0e6c4 100644
--- a/graphics/rubygem-turing/Makefile
+++ b/graphics/rubygem-turing/Makefile
@@ -19,4 +19,8 @@ USE_RUBY= yes
USE_RUBYGEMS= yes
RUBYGEM_AUTOPLIST= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not build with ruby 1.9
+.endif
+.include <bsd.port.post.mk>
diff --git a/japanese/ruby-chasen/Makefile b/japanese/ruby-chasen/Makefile
index d5bdb090c91b..cd99ca47a976 100644
--- a/japanese/ruby-chasen/Makefile
+++ b/japanese/ruby-chasen/Makefile
@@ -26,6 +26,9 @@ CONFIGURE_ARGS= --with-chasen-dir="${PREFIX}"
INSTALL_TARGET= site-install
.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not build with ruby 1.9
+.endif
PKGNAMEPREFIX:= ${PKGNAMEPREFIX}${RUBY_PKGNAMEPREFIX}
diff --git a/japanese/ruby-eb/Makefile b/japanese/ruby-eb/Makefile
index ca69697c617e..5038a21af696 100644
--- a/japanese/ruby-eb/Makefile
+++ b/japanese/ruby-eb/Makefile
@@ -28,6 +28,10 @@ EXAMPLES= hook2.rb test.rb
.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not build with ruby 1.9
+.endif
+
PKGNAMEPREFIX:= ${PKGNAMEPREFIX}${RUBY_PKGNAMEPREFIX}
post-install:
diff --git a/lang/ruby-lua4/Makefile b/lang/ruby-lua4/Makefile
index 12413bdb23e1..c53a4bd4e0c4 100644
--- a/lang/ruby-lua4/Makefile
+++ b/lang/ruby-lua4/Makefile
@@ -48,4 +48,8 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/rubylua.txt ${RUBY_MODDOCDIR}/
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not build with ruby 1.9
+.endif
+.include <bsd.port.post.mk>
diff --git a/security/ruby-tcpwrap/Makefile b/security/ruby-tcpwrap/Makefile
index 664a9e3f2753..8c4023bf5ba8 100644
--- a/security/ruby-tcpwrap/Makefile
+++ b/security/ruby-tcpwrap/Makefile
@@ -44,4 +44,8 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not build with ruby 1.9
+.endif
+.include <bsd.port.post.mk>
diff --git a/textproc/ruby-amrita/Makefile b/textproc/ruby-amrita/Makefile
index 1ff6adcf3650..45295a6bf28f 100644
--- a/textproc/ruby-amrita/Makefile
+++ b/textproc/ruby-amrita/Makefile
@@ -36,4 +36,8 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not build with ruby 1.9
+.endif
+.include <bsd.port.post.mk>
diff --git a/textproc/ruby-xmlscan-old/Makefile b/textproc/ruby-xmlscan-old/Makefile
index e10232926e36..ca82d92dfdd0 100644
--- a/textproc/ruby-xmlscan-old/Makefile
+++ b/textproc/ruby-xmlscan-old/Makefile
@@ -30,4 +30,8 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README ${RUBY_MODDOCDIR}/ja/
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not build with ruby 1.9
+.endif
+.include <bsd.port.post.mk>
diff --git a/x11-toolkits/ruby-gtk/Makefile b/x11-toolkits/ruby-gtk/Makefile
index a137610f8c7e..ce315cbdfa0c 100644
--- a/x11-toolkits/ruby-gtk/Makefile
+++ b/x11-toolkits/ruby-gtk/Makefile
@@ -69,4 +69,8 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not build with ruby 1.9
+.endif
+.include <bsd.port.post.mk>
diff --git a/x11-toolkits/ruby-wx/Makefile b/x11-toolkits/ruby-wx/Makefile
index 76998057a308..8691c6df7bb9 100644
--- a/x11-toolkits/ruby-wx/Makefile
+++ b/x11-toolkits/ruby-wx/Makefile
@@ -25,6 +25,9 @@ USE_WX= 2.4
WX_COMPS= contrib
.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not build with ruby 1.9
+.endif
WRKSRC= ${WRKDIR}/${DISTNAME}/src
DOCS= README README.linux ChangeLog
diff --git a/x11/ruby-gtktrayicon/Makefile b/x11/ruby-gtktrayicon/Makefile
index ca0dc6731a54..81b3186fed98 100644
--- a/x11/ruby-gtktrayicon/Makefile
+++ b/x11/ruby-gtktrayicon/Makefile
@@ -38,4 +38,8 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not build with ruby 1.9
+.endif
+.include <bsd.port.post.mk>