aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2014-07-22 15:17:36 +0800
committerolgeni <olgeni@FreeBSD.org>2014-07-22 15:17:36 +0800
commit75564e7ec6a836740af91d7bd5ac8a9c022888e7 (patch)
tree568b77316bbac757b8576fc886c1f01d822424ee
parenta6ab0fa6d9e526e81c2c27eb160367b5db6daa41 (diff)
downloadfreebsd-ports-gnome-75564e7ec6a836740af91d7bd5ac8a9c022888e7.tar.gz
freebsd-ports-gnome-75564e7ec6a836740af91d7bd5ac8a9c022888e7.tar.zst
freebsd-ports-gnome-75564e7ec6a836740af91d7bd5ac8a9c022888e7.zip
Upgrade to version 17.1.
-rw-r--r--lang/erlang/Makefile13
-rw-r--r--lang/erlang/distinfo12
-rw-r--r--lang/erlang/files/patch-lib_et_src_et__gs__contents__viewer.erl13
-rw-r--r--lang/erlang/files/patch-lib_et_src_et__gs__viewer.erl15
-rw-r--r--lang/erlang/files/patch-lib_gs_src_tool__utils.erl87
5 files changed, 13 insertions, 127 deletions
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index 8ebd561cbc7f..2cd1d816d5f3 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= erlang
-PORTVERSION= 16.b.03.1
+PORTVERSION= 17.1
PORTEPOCH= 3
CATEGORIES= lang parallel java
MASTER_SITES= http://www.erlang.org/download/:erlangorg \
@@ -42,19 +42,19 @@ SCTP_DESC= Enable SCTP support
SMP_DESC= Enable SMP support
WX_DESC= Enable WX application
GS_DESC= Enable GS application (deprecated)
-DTRACE_DESC= Enable DTrace support (experimental)
+DTRACE_DESC= Enable DTrace support
OPTIONS_DEFAULT=SMP OPENSSL THREADS SCTP KQUEUE
-ERL_RELEASE= R${PORTVERSION:S/.//g:tu:S/1$/-1/}
+ERL_RELEASE= ${PORTVERSION}
USES= gmake perl5
USE_RC_SUBR= epmd
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
-EI_VSN= 3.7.15
-TOOLS_VSN= 2.6.13
+EI_VSN= 3.7.17
+TOOLS_VSN= 2.6.15
.include <bsd.port.options.mk>
@@ -77,9 +77,11 @@ DOC_DISTFILES= armstrong_thesis_2003.pdf:joe \
# probes fixed does not match the number of defined probes (54 != 132,
# respectively)" you probably misconfigured DTrace in some way.
+.if ${OSVERSION} < 1000000
.if ${ARCH} == "amd64" && ${PORT_OPTIONS:MDTRACE} && ! ${PORT_OPTIONS:MGCC}
IGNORE= DTRACE support on amd64 requires GCC option
.endif
+.endif
.if ${PORT_OPTIONS:MGCC}
USE_GCC?= yes
@@ -178,7 +180,6 @@ MAKE_ARGS+= ARCH=x86
post-patch:
@${ECHO_CMD} "MANPATH ${PREFIX}/lib/erlang/man" > ${WRKDIR}/erlang.conf
-
post-install:
${INSTALL_DATA} ${WRKDIR}/erlang.conf ${STAGEDIR}${PREFIX}/etc/man.d/erlang.conf
${LN} -sf ../lib/${ERLANG_LIB}/lib/erl_interface-${EI_VSN}/bin/erl_call ${STAGEDIR}${PREFIX}/bin/erl_call
diff --git a/lang/erlang/distinfo b/lang/erlang/distinfo
index add9b229cae3..95836ce57b1a 100644
--- a/lang/erlang/distinfo
+++ b/lang/erlang/distinfo
@@ -1,9 +1,9 @@
-SHA256 (erlang/otp_src_R16B03-1.tar.gz) = 17ce53459bc5ceb34fc2da412e15ac8c23835a15fbd84e62c8d1852704747ee7
-SIZE (erlang/otp_src_R16B03-1.tar.gz) = 66253556
-SHA256 (erlang/otp_doc_man_R16B03-1.tar.gz) = 0f31bc7d7215aa4b6834b1a565cd7d6e3173e3b392fb870254bae5136499c39d
-SIZE (erlang/otp_doc_man_R16B03-1.tar.gz) = 1322516
-SHA256 (erlang/otp_doc_html_R16B03-1.tar.gz) = 5381d4ffe654e3e943f004e2b91870bd83f0e46e261bb405c1cdf7de81bc0507
-SIZE (erlang/otp_doc_html_R16B03-1.tar.gz) = 33294165
+SHA256 (erlang/otp_src_17.1.tar.gz) = b806f5b2b5cc2d0c0d5dd1a65657c21c10dc3a0535ef60adecdac9cd73b9c356
+SIZE (erlang/otp_src_17.1.tar.gz) = 66912681
+SHA256 (erlang/otp_doc_man_17.1.tar.gz) = 4a230277f135e3730593e7bffdd5ca92596568340f02a5b3134f1d083b34eaab
+SIZE (erlang/otp_doc_man_17.1.tar.gz) = 1354653
+SHA256 (erlang/otp_doc_html_17.1.tar.gz) = 1f73751e32c63c86d11e0de9f8525b84287284970a73dcb9581f51e8770735be
+SIZE (erlang/otp_doc_html_17.1.tar.gz) = 33412455
SHA256 (erlang/armstrong_thesis_2003.pdf) = da585b914eb07350e2d6f727db5eb0fb1551f49fc1270f7d4dc079f2c8c1ab7a
SIZE (erlang/armstrong_thesis_2003.pdf) = 859249
SHA256 (erlang/bjarnelic.pdf) = 9544d4af5cea324e5c9cf77e670d9561ad61ddc240cdb5c2afecebc0a3d7429b
diff --git a/lang/erlang/files/patch-lib_et_src_et__gs__contents__viewer.erl b/lang/erlang/files/patch-lib_et_src_et__gs__contents__viewer.erl
deleted file mode 100644
index a747941fac91..000000000000
--- a/lang/erlang/files/patch-lib_et_src_et__gs__contents__viewer.erl
+++ /dev/null
@@ -1,13 +0,0 @@
-
-$FreeBSD$
-
---- lib/et/src/et_gs_contents_viewer.erl.orig 2010-03-11 16:24:41.000000000 +0800
-+++ lib/et/src/et_gs_contents_viewer.erl 2010-03-11 16:24:53.000000000 +0800
-@@ -347,7 +347,6 @@ handle_info({gs, _Obj, keypress, _, [Key
- 'Caps_Lock' ->
- {noreply, S};
- _ ->
-- io:format("~p: ignored: ~p~n", [?MODULE, KeySym]),
- {noreply, S}
- end;
- handle_info({gs, _Obj, configure, [], [W, H | _]}, S) ->
diff --git a/lang/erlang/files/patch-lib_et_src_et__gs__viewer.erl b/lang/erlang/files/patch-lib_et_src_et__gs__viewer.erl
deleted file mode 100644
index 8f0fe420eae5..000000000000
--- a/lang/erlang/files/patch-lib_et_src_et__gs__viewer.erl
+++ /dev/null
@@ -1,15 +0,0 @@
-
-$FreeBSD$
-
---- lib/et/src/et_gs_viewer.erl.orig 2010-03-11 16:26:59.000000000 +0800
-+++ lib/et/src/et_gs_viewer.erl 2010-03-11 16:27:16.000000000 +0800
-@@ -855,8 +855,7 @@ close_all_others(S) ->
- noreply(S).
-
- click_error(Click, S) ->
-- gs:config(S#state.canvas, beep),
-- io:format("~p: ignored: ~p~n", [?MODULE, Click]).
-+ gs:config(S#state.canvas, beep).
-
- %%%----------------------------------------------------------------------
- %%% Clone viewer
diff --git a/lang/erlang/files/patch-lib_gs_src_tool__utils.erl b/lang/erlang/files/patch-lib_gs_src_tool__utils.erl
deleted file mode 100644
index 1a44ce423f9d..000000000000
--- a/lang/erlang/files/patch-lib_gs_src_tool__utils.erl
+++ /dev/null
@@ -1,87 +0,0 @@
-
-$FreeBSD$
-
---- lib/gs/src/tool_utils.erl.orig
-+++ lib/gs/src/tool_utils.erl
-@@ -27,6 +27,9 @@
- -export([file_dialog/1]).
- -export([notify/2, confirm/2, confirm_yesno/2, request/2]).
-
-+%% Browser executable list (openURL command line protocol required)
-+-define(BROWSERS, ["netscape", "mozilla", "MozillaFirebird", "opera", "firefox", "seamonkey"]).
-+
- %%----------------------------------------------------------------------
- %% open_help(GS, File)
- %% GS = gsobj() (GS root object returned by gs:start/0,1)
-@@ -67,7 +70,7 @@
- {unix,Type} ->
- case Type of
- darwin -> "open " ++ File;
-- _Else -> "netscape -remote \"openURL(file:" ++ File ++ ")\""
-+ _Else -> unix_url_command("file:" ++ File)
- end;
- {win32,_AnyType} ->
- "start " ++ filename:nativename(File);
-@@ -82,7 +85,7 @@
- {unix,Type} ->
- case Type of
- darwin -> "open " ++ File;
-- _Else -> "netscape -remote \"openURL(file:" ++ File ++ ")\""
-+ _Else -> unix_url_command("file:" ++ File)
- end;
- {win32,_AnyType} ->
- "netscape.exe -h " ++ regexp:gsub(File,"\\\\","/");
-@@ -342,3 +345,53 @@
- [Last];
- insert_newlines(Other) ->
- Other.
-+
-+%% find_browser(BrowserList) => string() | false
-+%% BrowserList - [string()]
-+%% Given a list of basenames, find the first available executable.
-+
-+find_browser([]) ->
-+ false;
-+
-+find_browser([H | T]) ->
-+ case os:find_executable(H) of
-+ false ->
-+ find_browser(T);
-+ Browser ->
-+ Browser
-+ end.
-+
-+%% unix_url_command(URL) => string()
-+%% URL - string()
-+%% Open an URL, using a browser which supports the openURL command
-+%% line protocol. If no browser is found, the empty string will be
-+%% returned.
-+
-+unix_url_command(URL) ->
-+ Template = "BROWSER -remote \"openURL(" ++ URL ++ ")\" || BROWSER " ++ URL ++ "&",
-+
-+ case os:getenv("BROWSER") of
-+ false ->
-+ %% look for a compatible browser
-+ case find_browser(?BROWSERS) of
-+ false ->
-+ "";
-+ Browser ->
-+ case regexp:gsub(Template, "BROWSER", Browser) of
-+ {ok, Command, 0} ->
-+ %% Template does not contain "BROWSER" placeholder
-+ "";
-+ {ok, Command, _} ->
-+ Command
-+ end
-+ end;
-+
-+ Value ->
-+ case regexp:gsub(Template, "BROWSER", Value) of
-+ {ok, Command2, 0} ->
-+ %% no placeholder
-+ "";
-+ {ok, Command2, _} ->
-+ Command2
-+ end
-+ end.