aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-02-06 00:58:56 +0800
committermiwi <miwi@FreeBSD.org>2014-02-06 00:58:56 +0800
commit75c6da54748f0842c01750e834e733627eede476 (patch)
treea958e8c8c4b279ebc03a0aeecd2c067c08a974f2
parent6f74632e6985074b4002d36df6f729baabafca14 (diff)
downloadfreebsd-ports-gnome-75c6da54748f0842c01750e834e733627eede476.tar.gz
freebsd-ports-gnome-75c6da54748f0842c01750e834e733627eede476.tar.zst
freebsd-ports-gnome-75c6da54748f0842c01750e834e733627eede476.zip
- Stage support
-rw-r--r--www/yanopaste/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/www/yanopaste/Makefile b/www/yanopaste/Makefile
index 548ed58d39a9..cc8dcac614d3 100644
--- a/www/yanopaste/Makefile
+++ b/www/yanopaste/Makefile
@@ -15,18 +15,16 @@ USE_PHP= xsl session xmlwriter xmlreader
SUB_FILES= pkg-message
WWWDIR?= ${PREFIX}/www/${PORTNAME}
-NO_STAGE= yes
.include <bsd.port.pre.mk>
post-patch:
${FIND} ${WRKSRC} -name .svn -type d | ${XARGS} ${RM} -rf
do-install:
- @${MKDIR} ${WWWDIR}
- ${CP} -R ${WRKSRC}/ ${WWWDIR}
- @${TOUCH} ${WWWDIR}/config.php
- @${CHOWN} ${WWWOWN} ${WWWDIR}/config.php
- @${CAT} ${PKGMESSAGE}
+ @${MKDIR} ${STAGEDIR}${WWWDIR}
+ ${CP} -R ${WRKSRC}/ ${STAGEDIR}${WWWDIR}
+ @${TOUCH} ${STAGEDIR}${WWWDIR}/config.php
+ @${CHOWN} ${WWWOWN} ${STAGEDIR}${WWWDIR}/config.php
create-plist:
@${FIND} -s ${WRKSRC}/${file} -not -type d \