aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2015-03-20 15:25:43 +0800
committerbdrewery <bdrewery@FreeBSD.org>2015-03-20 15:25:43 +0800
commit78c5994e60d47e3f4be796b187843d5c2d773d53 (patch)
tree2072e45fb3ab3095ac4b38b515707f16a96939fe
parent75d2251a86cd8140270136878156e30993b8778d (diff)
downloadfreebsd-ports-gnome-78c5994e60d47e3f4be796b187843d5c2d773d53.tar.gz
freebsd-ports-gnome-78c5994e60d47e3f4be796b187843d5c2d773d53.tar.zst
freebsd-ports-gnome-78c5994e60d47e3f4be796b187843d5c2d773d53.zip
Default the WRKSRC to the proper extracted name for USE_GITHUB when
GH_TAGNAME is defaulted to the new DISTVERSIONPREFIX/DISTVERSION/DISTVERSIONSUFFIX change in r381689. This actually fixes the build for sysutils/zfstools, broken in r381704. With hat: portmgr
-rw-r--r--Mk/bsd.port.mk4
-rw-r--r--net/libilbc/Makefile1
-rw-r--r--net/libsrtp/Makefile1
-rw-r--r--net/syncthing/Makefile2
-rw-r--r--security/libzrtpcppcore/Makefile1
5 files changed, 4 insertions, 5 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 9020890b563d..0659f327ce97 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1554,7 +1554,11 @@ WRKDIR?= ${WRKDIRPREFIX}${.CURDIR}/work
. if defined(GH_COMMIT)
WRKSRC?= ${WRKDIR}/${GH_ACCOUNT}-${GH_PROJECT}-${GH_COMMIT}
. else
+. if defined(GH_TAGNAME)
WRKSRC?= ${WRKDIR}/${GH_PROJECT}-${GH_TAGNAME}
+. else
+WRKSRC?= ${WRKDIR}/${GH_PROJECT}-${DISTVERSION}
+. endif
. endif
.endif
.if defined(NO_WRKSUBDIR)
diff --git a/net/libilbc/Makefile b/net/libilbc/Makefile
index 9db8ecc02b3e..e9f80e7961ca 100644
--- a/net/libilbc/Makefile
+++ b/net/libilbc/Makefile
@@ -15,7 +15,6 @@ CONFLICTS= ilbc-r[0-9]*
USE_GITHUB= yes
GH_ACCOUNT= TimothyGu
-WRKSRC= ${WRKDIR}/${GH_PROJECT}-${DISTVERSION}
USES= cmake
USE_LDCONFIG= yes
diff --git a/net/libsrtp/Makefile b/net/libsrtp/Makefile
index b7da387f0932..72775f43e482 100644
--- a/net/libsrtp/Makefile
+++ b/net/libsrtp/Makefile
@@ -15,7 +15,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USE_GITHUB= yes
GH_ACCOUNT= cisco
-WRKSRC= ${WRKDIR}/${GH_PROJECT}-${DISTVERSION}
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-openssl
diff --git a/net/syncthing/Makefile b/net/syncthing/Makefile
index 71f9d221dfd9..a636c160f6fb 100644
--- a/net/syncthing/Makefile
+++ b/net/syncthing/Makefile
@@ -19,8 +19,6 @@ PORTDOCS= *
USERS= syncthing
GROUPS= syncthing
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-
STRIP= # stripping can break go binaries
post-patch:
diff --git a/security/libzrtpcppcore/Makefile b/security/libzrtpcppcore/Makefile
index 99e0d33ae6fd..e2c680b1497f 100644
--- a/security/libzrtpcppcore/Makefile
+++ b/security/libzrtpcppcore/Makefile
@@ -15,7 +15,6 @@ LICENSE_FILE= ${WRKSRC}/COPYING
USE_GITHUB= yes
GH_ACCOUNT= wernerd
GH_PROJECT= ZRTPCPP
-WRKSRC= ${WRKDIR}/${GH_PROJECT}-${DISTVERSION}
USES= cmake:outsource
CMAKE_ARGS= -DCORE_LIB=true