aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-07-06 04:15:48 +0800
committerbapt <bapt@FreeBSD.org>2013-07-06 04:15:48 +0800
commit79986f19f3fa34838fdc231b948336a4de202c63 (patch)
treeb00717e4db857f593e77d1c5e05df4d91498212c
parent4ce99044c94e67979bc2d49515289646c690b44e (diff)
downloadfreebsd-ports-gnome-79986f19f3fa34838fdc231b948336a4de202c63.tar.gz
freebsd-ports-gnome-79986f19f3fa34838fdc231b948336a4de202c63.tar.zst
freebsd-ports-gnome-79986f19f3fa34838fdc231b948336a4de202c63.zip
Move PKGORIGIN definition a bit later so that PKGCATEGORY defined in Makefile.local or Makefile.inc works again
Reported by: dinoex Tested by: dinoex
-rw-r--r--Mk/bsd.port.mk14
1 files changed, 7 insertions, 7 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index bb4cc800d4b7..d9e6c9f711e6 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1212,13 +1212,6 @@ WITH_PKGNG?= yes
# Only define tools here (for transition period with between pkg tools)
.include "${PORTSDIR}/Mk/bsd.commands.mk"
-.for _CATEGORY in ${CATEGORIES}
-PKGCATEGORY?= ${_CATEGORY}
-.endfor
-_PORTDIRNAME= ${.CURDIR:T}
-PORTDIRNAME?= ${_PORTDIRNAME}
-PKGORIGIN?= ${PKGCATEGORY}/${PORTDIRNAME}
-
MASTERDIR?= ${.CURDIR}
.if ${MASTERDIR} != ${.CURDIR}
@@ -1258,6 +1251,13 @@ USE_SUBMAKE= yes
USE_SUBMAKE= yes
.endif
+.for _CATEGORY in ${CATEGORIES}
+PKGCATEGORY?= ${_CATEGORY}
+.endfor
+_PORTDIRNAME= ${.CURDIR:T}
+PORTDIRNAME?= ${_PORTDIRNAME}
+PKGORIGIN?= ${PKGCATEGORY}/${PORTDIRNAME}
+
# where 'make config' records user configuration options
PORT_DBDIR?= /var/db/ports