aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2004-08-20 02:27:12 +0800
committersem <sem@FreeBSD.org>2004-08-20 02:27:12 +0800
commit7bebb26213086da27ea018fb7b859fe68c4a1d45 (patch)
treedeeb6b085e271ea6388786ab380becf8b5fb5c88
parent3ceeb14ea267d430ec10792e94d9b0d3e516d87b (diff)
downloadfreebsd-ports-gnome-7bebb26213086da27ea018fb7b859fe68c4a1d45.tar.gz
freebsd-ports-gnome-7bebb26213086da27ea018fb7b859fe68c4a1d45.tar.zst
freebsd-ports-gnome-7bebb26213086da27ea018fb7b859fe68c4a1d45.zip
ACE builds fine with gcc 3.4. So build only ACE, not TAO.
Noticed by: Barney Wolff <barney@databus.com>
-rw-r--r--devel/ace+tao/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/devel/ace+tao/Makefile b/devel/ace+tao/Makefile
index 995397d900c6..6c1dd31b2c40 100644
--- a/devel/ace+tao/Makefile
+++ b/devel/ace+tao/Makefile
@@ -44,15 +44,20 @@ TAO_ROOT= ${ACE_ROOT}/TAO
PLIST_SUB+= TAO=${TAO} TESTS=${TESTS} \
ACE_VERSION=${ACE_VERSION} TAO_VERSION=${TAO_VERSION}
-.if defined(WITHOUT_TAO)
-TAO= "@comment "
-PKGNAMESUFFIX?= -notao
-.endif
-
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 502125
-BROKEN= Does not build with gcc 3.4
+WITHOUT_TAO= yes
+pre-extract:
+ @${ECHO_MSG} "****************************************************"; \
+ ${ECHO_MSG} "* TAO is not build with gcc 3.4 *"; \
+ ${ECHO_MSG} "* so only ACE will build and install *"; \
+ ${ECHO_MSG} "****************************************************"
+.endif
+
+.if defined(WITHOUT_TAO)
+TAO= "@comment "
+PKGNAMESUFFIX?= -notao
.endif
post-patch: