aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoranders <anders@FreeBSD.org>2002-03-18 05:41:24 +0800
committeranders <anders@FreeBSD.org>2002-03-18 05:41:24 +0800
commit7d9d0294b526cd1f9543b2515a729c9b458f4c77 (patch)
tree4153538dbecdc695e6c5b9b5fa5add9cad62e9b9
parent3ef47ac0e5b5555883dd8458841c511599a22a89 (diff)
downloadfreebsd-ports-gnome-7d9d0294b526cd1f9543b2515a729c9b458f4c77.tar.gz
freebsd-ports-gnome-7d9d0294b526cd1f9543b2515a729c9b458f4c77.tar.zst
freebsd-ports-gnome-7d9d0294b526cd1f9543b2515a729c9b458f4c77.zip
Add Math::TrulyRandom, a Perl interface to a truly random number
generator function.
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Math-TrulyRandom/Makefile30
-rw-r--r--math/p5-Math-TrulyRandom/distinfo1
-rw-r--r--math/p5-Math-TrulyRandom/pkg-comment1
-rw-r--r--math/p5-Math-TrulyRandom/pkg-descr5
-rw-r--r--math/p5-Math-TrulyRandom/pkg-plist12
6 files changed, 50 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index ba4ae5665ab4..ff73a73251f4 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -87,6 +87,7 @@
SUBDIR += p5-Math-Pari
SUBDIR += p5-Math-Random
SUBDIR += p5-Math-Random-MT
+ SUBDIR += p5-Math-TrulyRandom
SUBDIR += p5-MatrixReal
SUBDIR += p5-Set-IntSpan
SUBDIR += p5-Set-Window
diff --git a/math/p5-Math-TrulyRandom/Makefile b/math/p5-Math-TrulyRandom/Makefile
new file mode 100644
index 000000000000..18349f4c1210
--- /dev/null
+++ b/math/p5-Math-TrulyRandom/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: Math::TrulyRandom
+# Date created: 17 March 2002
+# Whom: Anders Nordby <anders@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-TrulyRandom
+PORTVERSION= 1.0
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= anders@FreeBSD.org
+
+PERL_CONFIGURE= yes
+
+MAN3= Math::TrulyRandom.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${INSTALL} -d -m 0755 ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/COPYRIGHT ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/truerand.c ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/truerand.h ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-TrulyRandom/distinfo b/math/p5-Math-TrulyRandom/distinfo
new file mode 100644
index 000000000000..64d75fff92d2
--- /dev/null
+++ b/math/p5-Math-TrulyRandom/distinfo
@@ -0,0 +1 @@
+MD5 (Math-TrulyRandom-1.0.tar.gz) = 32e2273ee192203837cb1a21756a27a0
diff --git a/math/p5-Math-TrulyRandom/pkg-comment b/math/p5-Math-TrulyRandom/pkg-comment
new file mode 100644
index 000000000000..7deb38d95527
--- /dev/null
+++ b/math/p5-Math-TrulyRandom/pkg-comment
@@ -0,0 +1 @@
+Perl interface to a truly random number generator function
diff --git a/math/p5-Math-TrulyRandom/pkg-descr b/math/p5-Math-TrulyRandom/pkg-descr
new file mode 100644
index 000000000000..34d01c7da26c
--- /dev/null
+++ b/math/p5-Math-TrulyRandom/pkg-descr
@@ -0,0 +1,5 @@
+The Math::TrulyRandom module provides an ability to generate truly random
+numbers from within Perl programs. The source of the randomness is from
+interrupt timing discrepancies.
+
+- Anders Nordby <anders@FreeBSD.org>
diff --git a/math/p5-Math-TrulyRandom/pkg-plist b/math/p5-Math-TrulyRandom/pkg-plist
new file mode 100644
index 000000000000..97d979d1a2d7
--- /dev/null
+++ b/math/p5-Math-TrulyRandom/pkg-plist
@@ -0,0 +1,12 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math/TrulyRandom/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Math/TrulyRandom.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Math/TrulyRandom.pod
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math/TrulyRandom/TrulyRandom.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math/TrulyRandom/TrulyRandom.so
+%%PORTDOCS%%share/doc/Math-TrulyRandom/COPYRIGHT
+%%PORTDOCS%%share/doc/Math-TrulyRandom/truerand.c
+%%PORTDOCS%%share/doc/Math-TrulyRandom/truerand.h
+%%PORTDOCS%%@dirrm share/doc/Math-TrulyRandom
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math/TrulyRandom 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Math 2>/dev/null || true