aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-11-01 20:42:02 +0800
committerjylefort <jylefort@FreeBSD.org>2005-11-01 20:42:02 +0800
commit7ef01600e4ced11830d3f7a778297276f4ba5878 (patch)
tree1f9de2f337e66efa76e9661025398768cb548720
parentd20b798fe42ae91f7dbc939859124bfd195cbb7d (diff)
downloadfreebsd-ports-gnome-7ef01600e4ced11830d3f7a778297276f4ba5878.tar.gz
freebsd-ports-gnome-7ef01600e4ced11830d3f7a778297276f4ba5878.tar.zst
freebsd-ports-gnome-7ef01600e4ced11830d3f7a778297276f4ba5878.zip
Add mbox2mdir.
mbox2mdir is a small program to convert mail stored in UNIX mbox format to qmail's Maildir format. It can (optionally) also truncate the source mbox file upon successful conversion. I use it to move mail delivered by /bin/mail or sendmail to qmail Maildir folders, but of course there are many other possible uses for it. WWW: http://sageshome.net/oss/mbox2mdir.php PR: ports/88245 Submitted by: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
-rw-r--r--mail/Makefile1
-rw-r--r--mail/mbox2mdir/Makefile26
-rw-r--r--mail/mbox2mdir/distinfo2
-rw-r--r--mail/mbox2mdir/pkg-descr7
4 files changed, 36 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index b7e28b65f041..dfeb7aeb5b67 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -192,6 +192,7 @@
SUBDIR += masqmail-devel
SUBDIR += mavbiff
SUBDIR += mb2md
+ SUBDIR += mbox2mdir
SUBDIR += mboxcheck-applet
SUBDIR += mboxgrep
SUBDIR += mboxstats
diff --git a/mail/mbox2mdir/Makefile b/mail/mbox2mdir/Makefile
new file mode 100644
index 000000000000..ee559bf30c01
--- /dev/null
+++ b/mail/mbox2mdir/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: mbox2mdir
+# Date created: 2005-10-30
+# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mbox2mdir
+PORTVERSION= 1.3
+CATEGORIES= mail
+MASTER_SITES= http://sageshome.net/downloads/oss/
+
+MAINTAINER= acardenas@bsd.org.pe
+COMMENT= A mbox to qmail's Maildir converter written in C++
+
+USE_BZIP2= yes
+
+PLIST_FILES= bin/mbox2mdir
+
+do-build:
+ ${CXX} ${CXXFLAGS} ${WRKSRC}/mbox2mdir.cpp -o ${WRKSRC}/mbox2mdir
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/mbox2mdir ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/mail/mbox2mdir/distinfo b/mail/mbox2mdir/distinfo
new file mode 100644
index 000000000000..7dc676846f42
--- /dev/null
+++ b/mail/mbox2mdir/distinfo
@@ -0,0 +1,2 @@
+MD5 (mbox2mdir-1.3.tar.bz2) = 7dda0022100de6d044765951d11bce18
+SIZE (mbox2mdir-1.3.tar.bz2) = 9066
diff --git a/mail/mbox2mdir/pkg-descr b/mail/mbox2mdir/pkg-descr
new file mode 100644
index 000000000000..71a31b4d7ed5
--- /dev/null
+++ b/mail/mbox2mdir/pkg-descr
@@ -0,0 +1,7 @@
+mbox2mdir is a small program to convert mail stored in UNIX mbox format to
+qmail's Maildir format. It can (optionally) also truncate the source mbox file
+upon successful conversion. I use it to move mail delivered by /bin/mail or
+sendmail to qmail Maildir folders, but of course there are many other possible
+uses for it.
+
+WWW: http://sageshome.net/oss/mbox2mdir.php