aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2006-09-18 06:06:47 +0800
committermarcus <marcus@FreeBSD.org>2006-09-18 06:06:47 +0800
commit7f09ed7346e8749f2243b5a610711e23605a7462 (patch)
tree63c5a33b3e0660abce9f768785e5202182c993eb
parent7fae3bdc2716480149f43a1cb4a53940263fc9c0 (diff)
downloadfreebsd-ports-gnome-7f09ed7346e8749f2243b5a610711e23605a7462.tar.gz
freebsd-ports-gnome-7f09ed7346e8749f2243b5a610711e23605a7462.tar.zst
freebsd-ports-gnome-7f09ed7346e8749f2243b5a610711e23605a7462.zip
Update to 1.71.
PR: 102438 Submitted by: Andris Raugulis <endrju@null.lv>
-rw-r--r--editors/scite/Makefile17
-rw-r--r--editors/scite/distinfo6
-rw-r--r--editors/scite/pkg-plist6
-rw-r--r--x11-toolkits/scintilla/Makefile6
-rw-r--r--x11-toolkits/scintilla/distinfo6
5 files changed, 21 insertions, 20 deletions
diff --git a/editors/scite/Makefile b/editors/scite/Makefile
index ede2873ce48f..ff6ba114b93d 100644
--- a/editors/scite/Makefile
+++ b/editors/scite/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= scite
-PORTVERSION= 1.70
+PORTVERSION= 1.71
CATEGORIES= editors gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.scintilla.org/
@@ -29,15 +29,12 @@ MAKE_ENV= CC="${CXX}"
EXTRA_PATCH_FILES= lua/include/lauxlib.h \
lua/include/lua.h \
lua/src/lobject.h \
- lua/src/lzio.h \
- lua/src/ltm.h \
lua/src/lopcodes.c \
lua/src/lopcodes.h \
lua/src/lstate.c \
lua/src/lstate.h \
lua/src/ldo.h \
lua/src/lmem.h \
- lua/src/lgc.h \
lua/src/lgc.c \
lua/src/lvm.h \
lua/src/lstring.h \
@@ -48,13 +45,13 @@ EXTRA_PATCH_FILES= lua/include/lauxlib.h \
lua/src/lparser.c \
lua/src/lib/lauxlib.c
-OPTIONS= GTK2 "Turns on GTK-2.x support (Default is GTK-1)" off
+OPTIONS= GTK2 "Turns on GTK+ 2.x support (Default is GTK+ 1)" off
.include <bsd.port.pre.mk>
.if defined(WITH_GTK2)
USE_GNOME+= gtk20
-PKGNAMESUFFIX= -gtk2
+PKGNAMESUFFIX:= -gtk2
.else
USE_GNOME+= gtk12
MAKE_ARGS= GTK1=yes
@@ -70,15 +67,17 @@ post-patch:
.for file in ${EXTRA_PATCH_FILES}
@${CP} ${WRKSRC}/../${file} \
${WRKSRC}/../${file}.orig
- @/usr/bin/col < ${WRKSRC}/../${file}.orig \
+ @col < ${WRKSRC}/../${file}.orig \
> ${WRKSRC}/../${file}
.endfor
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/../bin/SciTE ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/../doc/scite.1 ${MANPREFIX}/man/man1
- ${INSTALL_DATA} ${WRKSRC}/SciTE.desktop ${PREFIX}/share/gnome/applications
- ${INSTALL_DATA} ${WRKSRC}/Sci48M.png ${PREFIX}/share/gnome/pixmaps
+ @${MKDIR} ${PREFIX}/share/applications
+ @${MKDIR} ${PREFIX}/share/pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/SciTE.desktop ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/Sci48M.png ${PREFIX}/share/pixmaps
@${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/../doc/*.html ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/../doc/*.jpg ${DATADIR}
diff --git a/editors/scite/distinfo b/editors/scite/distinfo
index 37a1f2ae24ea..a53ce13ba425 100644
--- a/editors/scite/distinfo
+++ b/editors/scite/distinfo
@@ -1,3 +1,3 @@
-MD5 (scite170.tgz) = bf7509820b23438e272d7526e1058bff
-SHA256 (scite170.tgz) = 7c786ddc00799e6f4f30a2b475a776fc49563087853f585f986f098e07797bf5
-SIZE (scite170.tgz) = 1298313
+MD5 (scite171.tgz) = b62946c770686909a4d4d0e42de3754c
+SHA256 (scite171.tgz) = c84ba2fc252345e3d36d36f14b3ab43c6f20e0e7ee5c30d8560f938d505116e3
+SIZE (scite171.tgz) = 1300416
diff --git a/editors/scite/pkg-plist b/editors/scite/pkg-plist
index 661cef0e6f74..cf500a8d1eb0 100644
--- a/editors/scite/pkg-plist
+++ b/editors/scite/pkg-plist
@@ -1,6 +1,6 @@
bin/SciTE
-share/gnome/applications/SciTE.desktop
-share/gnome/pixmaps/Sci48M.png
+share/applications/SciTE.desktop
+share/pixmaps/Sci48M.png
share/scite/Embedded.properties
share/scite/PrintHi.png
share/scite/SciBreak2.jpg
@@ -77,3 +77,5 @@ share/scite/verilog.properties
share/scite/vhdl.properties
share/scite/yaml.properties
@dirrm share/scite
+@dirrmtry share/pixmaps
+@dirrmtry share/applications
diff --git a/x11-toolkits/scintilla/Makefile b/x11-toolkits/scintilla/Makefile
index ff3ff53bb78b..f200738b9b82 100644
--- a/x11-toolkits/scintilla/Makefile
+++ b/x11-toolkits/scintilla/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= scintilla
-PORTVERSION= 1.70
+PORTVERSION= 1.71
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.scintilla.org/
@@ -23,11 +23,11 @@ USE_X_PREFIX= yes
USE_GMAKE= yes
USE_ICONV= yes
MAKEFILE= makefile
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
.if defined(WITH_GTK2)
USE_GNOME= gtk20
-PKGNAMESUFFIX= -gtk2
+PKGNAMESUFFIX:= -gtk2
.else
USE_GNOME= gtk12
MAKE_ARGS+= GTK1=yes
diff --git a/x11-toolkits/scintilla/distinfo b/x11-toolkits/scintilla/distinfo
index 37a1f2ae24ea..a53ce13ba425 100644
--- a/x11-toolkits/scintilla/distinfo
+++ b/x11-toolkits/scintilla/distinfo
@@ -1,3 +1,3 @@
-MD5 (scite170.tgz) = bf7509820b23438e272d7526e1058bff
-SHA256 (scite170.tgz) = 7c786ddc00799e6f4f30a2b475a776fc49563087853f585f986f098e07797bf5
-SIZE (scite170.tgz) = 1298313
+MD5 (scite171.tgz) = b62946c770686909a4d4d0e42de3754c
+SHA256 (scite171.tgz) = c84ba2fc252345e3d36d36f14b3ab43c6f20e0e7ee5c30d8560f938d505116e3
+SIZE (scite171.tgz) = 1300416