aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2004-01-06 12:42:35 +0800
committerlinimon <linimon@FreeBSD.org>2004-01-06 12:42:35 +0800
commit7fab88387b2b95ef4f69c7995501c7ea3dc9b100 (patch)
tree2d9bacf3320d16d389ee9b28ffd7c0f32625f6b3
parentaef207ce82594a69ac3af165919be6b72627c47e (diff)
downloadfreebsd-ports-gnome-7fab88387b2b95ef4f69c7995501c7ea3dc9b100.tar.gz
freebsd-ports-gnome-7fab88387b2b95ef4f69c7995501c7ea3dc9b100.tar.zst
freebsd-ports-gnome-7fab88387b2b95ef4f69c7995501c7ea3dc9b100.zip
Add math/itl, the Iterative Template Library. It carries solver and
preconditioners for solving equations. It is required by some FEM packages on the net like Felyx and IMOOSE. ITL is said to work especially fast with gcc-3.3. PR: ports/55717 Submitted by: Pedro F. Giffuni <giffunip@yahoo.com>
-rw-r--r--math/itl/Makefile35
-rw-r--r--math/itl/distinfo1
-rw-r--r--math/itl/files/patch-test+iohb_c10
-rw-r--r--math/itl/files/patch-test+mmio_c11
-rw-r--r--math/itl/pkg-descr15
-rw-r--r--math/itl/pkg-plist12
6 files changed, 84 insertions, 0 deletions
diff --git a/math/itl/Makefile b/math/itl/Makefile
new file mode 100644
index 000000000000..81d69208ec41
--- /dev/null
+++ b/math/itl/Makefile
@@ -0,0 +1,35 @@
+# Ports collection makefile for: itl
+# Date created: Mar 15, 2003
+# Whom: Pedro F. Giffuni <giffunip@asme.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= itl
+PORTVERSION= 4.0.0.1
+CATEGORIES= math devel
+MASTER_SITES= http://www.osl.iu.edu/download/research/itl/
+DISTNAME= ${PORTNAME}-4.0.0-1
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Iterative Template Library (based on MTL)
+
+BUILD_DEPENDS= ${LOCALBASE}/include/mtl/mtl.h:${PORTSDIR}/math/mtl \
+ ${LOCALBASE}/include/blitz/blitz.h:${PORTSDIR}/math/blitz++
+RUN_DEPENDS= ${LOCALBASE}/include/mtl/mtl.h:${PORTSDIR}/math/mtl \
+ ${LOCALBASE}/lib/libblitz.a:${PORTSDIR}/math/blitz++
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-mtl=${LOCALBASE}/include \
+ --with-blitz=${LOCALBASE}/include
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if defined(WANT_MPI) || exists(${LOCALBASE}/bin/hcp)
+BUILD_DEPENDS+= ${LOCALBASE}/bin/hcp:${PORTSDIR}/parallel/lam
+RUN_DEPENDS+= ${LOCALBASE}/bin/hcp:${PORTSDIR}/parallel/lam
+CONFIGURE_ARGS+= --with-mpi=lam
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/itl/distinfo b/math/itl/distinfo
new file mode 100644
index 000000000000..ca4ad3883989
--- /dev/null
+++ b/math/itl/distinfo
@@ -0,0 +1 @@
+MD5 (itl-4.0.0-1.tar.gz) = cb8b11de45e5b1bb80b17123adc93190
diff --git a/math/itl/files/patch-test+iohb_c b/math/itl/files/patch-test+iohb_c
new file mode 100644
index 000000000000..1b72702a66bd
--- /dev/null
+++ b/math/itl/files/patch-test+iohb_c
@@ -0,0 +1,10 @@
+--- test/iohb.c.orig Mon Aug 18 22:04:00 2003
++++ test/iohb.c Mon Aug 18 22:04:22 2003
+@@ -219,7 +219,6 @@
+ #include<stdlib.h>
+ #include<string.h>
+ #include<math.h>
+-#include<malloc.h>
+
+ char* substr(const char* S, const int pos, const int len);
+ void upcase(char* S);
diff --git a/math/itl/files/patch-test+mmio_c b/math/itl/files/patch-test+mmio_c
new file mode 100644
index 000000000000..6b6723532abe
--- /dev/null
+++ b/math/itl/files/patch-test+mmio_c
@@ -0,0 +1,11 @@
+--- test/mmio.c.orig Mon Aug 18 22:04:50 2003
++++ test/mmio.c Mon Aug 18 22:05:10 2003
+@@ -9,7 +9,7 @@
+
+ #include <stdio.h>
+ #include <string.h>
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <ctype.h>
+
+ #include "mmio.h"
diff --git a/math/itl/pkg-descr b/math/itl/pkg-descr
new file mode 100644
index 000000000000..d64b6cfd5e10
--- /dev/null
+++ b/math/itl/pkg-descr
@@ -0,0 +1,15 @@
+ The Iterative Template Library Alpha Release
+
+The Iterative Template Library (ITL) has two parts, iterative solvers
+and preconditioners. ITL provides a collection of sophisticated Krylov
+subspace iterative solvers that use basic linear algebra packages such
+as the Matrix Template Library or Blitz++ for its basic linear algebra
+operations. The ITL has extended many of the ideas of the Iterative
+Methods Library (IML++), to make the library more flexible. The
+"interface" is to specify basic linear algebra operations. See next
+bullet for details. On the other hand, ITL also provides a set of
+preconditioners which are designed for Matrix Template Library.
+
+The latest documentation for ITL can be found on our website:
+
+WWW: http://www.osl.iu.edu/research/itl
diff --git a/math/itl/pkg-plist b/math/itl/pkg-plist
new file mode 100644
index 000000000000..a3c16d8d738c
--- /dev/null
+++ b/math/itl/pkg-plist
@@ -0,0 +1,12 @@
+include/itl/Iteration_concept.h
+include/itl/Preconditioner_concept.h
+include/itl/Matrix_concept.h
+include/itl/givens_rotation.h
+include/itl/itl.h
+include/itl/itl_utils.h
+include/itl/itl_tags.h
+include/itl/modified_gram_schmidt.h
+include/itl/matrix_free_operator.h
+include/itl/number_traits.h
+@dirrm include/itl
+