aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2008-04-07 10:50:39 +0800
committermnag <mnag@FreeBSD.org>2008-04-07 10:50:39 +0800
commit7fc824772a817cb2ac482127cc2871f8246e1d26 (patch)
tree1d4980b2f024b69e93946884cd19869752dcd817
parent99cf96ee692d7e89053727137baadf0f1d5889a3 (diff)
downloadfreebsd-ports-gnome-7fc824772a817cb2ac482127cc2871f8246e1d26.tar.gz
freebsd-ports-gnome-7fc824772a817cb2ac482127cc2871f8246e1d26.tar.zst
freebsd-ports-gnome-7fc824772a817cb2ac482127cc2871f8246e1d26.zip
- Use pkg-config to determinate if sqlite3 are compiled with threads
- Add USE_GNOME=pkgconfig Reported by: pav
-rw-r--r--textproc/soothsayer/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/textproc/soothsayer/Makefile b/textproc/soothsayer/Makefile
index 808afa573a05..a4d400c4ed98 100644
--- a/textproc/soothsayer/Makefile
+++ b/textproc/soothsayer/Makefile
@@ -17,6 +17,7 @@ BUILD_DEPENDS= swig>=1.3.31:${PORTSDIR}/devel/swig13
USE_LDCONFIG= yes
USE_SQLITE= 3
+USE_GNOME= pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-static --localstatedir=${PREFIX}/var/${PORTNAME}
CPPFLAGS+= -I${LOCALBASE}/include
@@ -29,5 +30,8 @@ post-patch:
@${REINPLACE_CMD} -e 's|\$$\^|$${.ALLSRC}|' ${WRKSRC}/resources/Makefile.in
@${REINPLACE_CMD} -e '1s|/.*|/bin/sh|'\
${WRKSRC}/resources/profiles/generate_soothsayer_config.sh
+ @${REINPLACE_CMD} -E -e "s|(LIBS=.*)-lsqlite3(.*)|\1\`pkg-config --static --libs sqlite3\`\2|" \
+ -e "s|(.*SQLITE_LIBS=.*)-lsqlite3(.*)|\1\`pkg-config --static --libs sqlite3\`\2|" \
+ ${WRKSRC}/configure
.include <bsd.port.mk>