aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2011-12-02 21:06:26 +0800
committerzi <zi@FreeBSD.org>2011-12-02 21:06:26 +0800
commit8170b68f141105badd7a71e34411780cb3165747 (patch)
treeba1177ba6622c238f7f95f48265d8a7616e8130d
parent9b5e20d43198c775e84497b21ad5c05a30c34383 (diff)
downloadfreebsd-ports-gnome-8170b68f141105badd7a71e34411780cb3165747.tar.gz
freebsd-ports-gnome-8170b68f141105badd7a71e34411780cb3165747.tar.zst
freebsd-ports-gnome-8170b68f141105badd7a71e34411780cb3165747.zip
- Fix libtool typo in ltmain.sh
- Fix linking issue with libnetsnmpmibs.so and libperl.so - Bump PORTREVISION PR: ports/163005 Submitted by: William Elasio Moreno Albarracin <wmoreno3@yahoo.com> Approved by: maintainer (implicit) Feature safe: yes
-rw-r--r--net-mgmt/net-snmp/Makefile1
-rw-r--r--net-mgmt/net-snmp/files/patch-agent__Makefile.in11
-rw-r--r--net-mgmt/net-snmp/files/patch-ltmain.sh11
3 files changed, 23 insertions, 0 deletions
diff --git a/net-mgmt/net-snmp/Makefile b/net-mgmt/net-snmp/Makefile
index 87da20f3d8ee..e83aa5f50e81 100644
--- a/net-mgmt/net-snmp/Makefile
+++ b/net-mgmt/net-snmp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= snmp
PORTVERSION= 5.7.1
+PORTREVISION= 1
CATEGORIES= net-mgmt ipv6
MASTER_SITES= SF/net-${PORTNAME}/net-${PORTNAME}/${PORTVERSION}
PKGNAMEPREFIX= net-
diff --git a/net-mgmt/net-snmp/files/patch-agent__Makefile.in b/net-mgmt/net-snmp/files/patch-agent__Makefile.in
new file mode 100644
index 000000000000..ea77d690e368
--- /dev/null
+++ b/net-mgmt/net-snmp/files/patch-agent__Makefile.in
@@ -0,0 +1,11 @@
+--- ./agent/Makefile.in.orig 2011-12-02 07:44:29.000000000 -0500
++++ ./agent/Makefile.in 2011-12-02 07:45:06.000000000 -0500
+@@ -302,7 +302,7 @@
+ $(RANLIB) $(AGENTLIB)
+
+ libnetsnmpmibs.$(LIB_EXTENSION)$(LIB_VERSION): ${LMIBOBJS} $(AGENTLIB) $(USELIBS)
+- $(LIB_LD_CMD) $(MIBLIB) ${LMIBOBJS} $(AGENTLIB) $(USELIBS) @LD_NO_UNDEFINED@ $(LDFLAGS) ${LMIBLIBS} $(LIB_LD_LIBS) @AGENTLIBS@
++ $(LIB_LD_CMD) $(MIBLIB) ${LMIBOBJS} $(AGENTLIB) $(USELIBS) @LD_NO_UNDEFINED@ $(LDFLAGS) $(PERLLDOPTS_FOR_LIBS) ${LMIBLIBS} $(LIB_LD_LIBS) @AGENTLIBS@
+ $(RANLIB) $(MIBLIB)
+
+ agentlib: $(AGENTLIB)
diff --git a/net-mgmt/net-snmp/files/patch-ltmain.sh b/net-mgmt/net-snmp/files/patch-ltmain.sh
new file mode 100644
index 000000000000..99dc29dc4729
--- /dev/null
+++ b/net-mgmt/net-snmp/files/patch-ltmain.sh
@@ -0,0 +1,11 @@
+--- ./ltmain.sh.orig 2011-12-02 07:35:01.000000000 -0500
++++ ./ltmain.sh 2011-12-02 07:35:23.000000000 -0500
+@@ -8051,7 +8051,7 @@
+ elif test -n "$runpath_var"; then
+ case "$perm_rpath " in
+ *" $libdir "*) ;;
+- *) func_apped perm_rpath " $libdir" ;;
++ *) func_append perm_rpath " $libdir" ;;
+ esac
+ fi
+ done