aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-07-13 05:23:17 +0800
committeryuri <yuri@FreeBSD.org>2018-07-13 05:23:17 +0800
commit81b89c405cfbcc93bc82dc494cb6ccb65766dfed (patch)
treea1818e172b55e916be2dfe44e472a5b143c55699
parentdae22d1061fc345c16b1af2a90b6bbbd4cade48e (diff)
downloadfreebsd-ports-gnome-81b89c405cfbcc93bc82dc494cb6ccb65766dfed.tar.gz
freebsd-ports-gnome-81b89c405cfbcc93bc82dc494cb6ccb65766dfed.tar.zst
freebsd-ports-gnome-81b89c405cfbcc93bc82dc494cb6ccb65766dfed.zip
New port: lang/nyan: Data description language designed for openage
PR: 229743 Submitted by: Martin Filla <martinfilla@post.cz>
-rw-r--r--lang/Makefile1
-rw-r--r--lang/nyan/Makefile24
-rw-r--r--lang/nyan/distinfo3
-rw-r--r--lang/nyan/files/patch-nyan_CMakeLists.txt31
-rw-r--r--lang/nyan/pkg-descr6
-rw-r--r--lang/nyan/pkg-plist58
6 files changed, 123 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 39e78f23d9ab..defc3c0c5d11 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -214,6 +214,7 @@
SUBDIR += nqc
SUBDIR += nwcc
SUBDIR += nx
+ SUBDIR += nyan
SUBDIR += ocaml
SUBDIR += ocaml-autoconf
SUBDIR += ocaml-nox11
diff --git a/lang/nyan/Makefile b/lang/nyan/Makefile
new file mode 100644
index 000000000000..7fcb3a47025e
--- /dev/null
+++ b/lang/nyan/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= nyan
+PORTVERSION= g20180708
+CATEGORIES= lang
+PKGNAMESUFFIX= -lang
+
+MAINTAINER= martinfilla@post.cz
+COMMENT= Data description language designed for openage
+
+LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/legal/LGPLv3
+
+BROKEN_FreeBSD_10= conflicting types for '__hash_table<_Tp, _Hash, _Equal, _Alloc>'
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/flex:textproc/flex
+
+USES= cmake:outsource compiler:c++17-lang
+USE_GITHUB= yes
+GH_ACCOUNT= SFTtech
+GH_TAGNAME= 3c263e2
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/lang/nyan/distinfo b/lang/nyan/distinfo
new file mode 100644
index 000000000000..8d02c775199c
--- /dev/null
+++ b/lang/nyan/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1531429889
+SHA256 (SFTtech-nyan-g20180708-3c263e2_GH0.tar.gz) = 9a65183c500527f9998eab7a9093a9461e1e34dd604f72d2ef2bbd473b3b0d79
+SIZE (SFTtech-nyan-g20180708-3c263e2_GH0.tar.gz) = 126134
diff --git a/lang/nyan/files/patch-nyan_CMakeLists.txt b/lang/nyan/files/patch-nyan_CMakeLists.txt
new file mode 100644
index 000000000000..391f70ea4061
--- /dev/null
+++ b/lang/nyan/files/patch-nyan_CMakeLists.txt
@@ -0,0 +1,31 @@
+--- nyan/CMakeLists.txt.orig 2018-07-12 20:09:17 UTC
++++ nyan/CMakeLists.txt
+@@ -11,7 +11,7 @@ if (APPLE)
+ endif ()
+ endif ()
+
+-find_package(FLEX 2.6 REQUIRED)
++find_package(FLEX 2.5 REQUIRED)
+
+ set(nyanl_cpp "${CMAKE_CURRENT_BINARY_DIR}/flex.gen.cpp")
+ set(nyanl_h "${CMAKE_CURRENT_BINARY_DIR}/flex.gen.h")
+@@ -77,10 +77,15 @@ add_library(nyan SHARED
+ add_library(nyan::nyan ALIAS nyan)
+
+ if(UNIX)
+- target_link_libraries(nyan
+- ${CMAKE_DL_LIBS}
+- )
+-
++ if("${CMAKE_SYSTEM_NAME}" MATCHES "(Free|Net|Open)BSD")
++ find_library(EXECINFO_LIBRARY execinfo)
++ target_link_libraries(nyan ${CMAKE_DL_LIBS} ${EXECINFO_LIBRARY})
++ elseif("${CMAKE_SYSTEM_NAME}" MATCHES "DragonFly")
++ find_library(EXECINFO_LIBRARY execinfo)
++ target_link_libraries(nyan ${CMAKE_DL_LIBS} ${EXECINFO_LIBRARY})
++ else()
++ target_link_libraries(nyan ${CMAKE_DL_LIBS})
++ endif()
+ if(NOT APPLE)
+ # for ld on macOS: "The default is to treat undefined symbols as errors."
+ set_target_properties(nyan PROPERTIES LINK_FLAGS "-Wl,--no-undefined")
diff --git a/lang/nyan/pkg-descr b/lang/nyan/pkg-descr
new file mode 100644
index 000000000000..deecaf845d28
--- /dev/null
+++ b/lang/nyan/pkg-descr
@@ -0,0 +1,6 @@
+nyan is a data description language, It is a mixture of python, json, patch,
+wml, yaml and some new ideas. It stores hierarchical objects with key-value
+pairs in a database with the key idea that changes in a parent affect all
+children.
+
+WWW: https://github.com/SFTtech/nyan
diff --git a/lang/nyan/pkg-plist b/lang/nyan/pkg-plist
new file mode 100644
index 000000000000..f081e573ad4f
--- /dev/null
+++ b/lang/nyan/pkg-plist
@@ -0,0 +1,58 @@
+bin/nyancat
+include/nyan/ast.h
+include/nyan/basic_type.h
+include/nyan/c3.h
+include/nyan/change_tracker.h
+include/nyan/compiler.h
+include/nyan/config.h
+include/nyan/curve.h
+include/nyan/database.h
+include/nyan/datastructure/orderedset.h
+include/nyan/error.h
+include/nyan/file.h
+include/nyan/id_token.h
+include/nyan/inheritance_change.h
+include/nyan/lexer/bracket.h
+include/nyan/lexer/impl.h
+include/nyan/lexer/lexer.h
+include/nyan/location.h
+include/nyan/member.h
+include/nyan/member_info.h
+include/nyan/meta_info.h
+include/nyan/namespace.h
+include/nyan/namespace_finder.h
+include/nyan/nyan.h
+include/nyan/nyan_tool.h
+include/nyan/object.h
+include/nyan/object_history.h
+include/nyan/object_info.h
+include/nyan/object_state.h
+include/nyan/ops.h
+include/nyan/parser.h
+include/nyan/patch_info.h
+include/nyan/state.h
+include/nyan/state_history.h
+include/nyan/token.h
+include/nyan/token_stream.h
+include/nyan/transaction.h
+include/nyan/type.h
+include/nyan/util.h
+include/nyan/value/boolean.h
+include/nyan/value/container.h
+include/nyan/value/file.h
+include/nyan/value/number.h
+include/nyan/value/object.h
+include/nyan/value/orderedset.h
+include/nyan/value/set.h
+include/nyan/value/set_base.h
+include/nyan/value/text.h
+include/nyan/value/value.h
+include/nyan/value/value_holder.h
+include/nyan/view.h
+lib/cmake/nyan/nyanConfig.cmake
+lib/cmake/nyan/nyanConfigVersion.cmake
+lib/cmake/nyan/nyanTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/nyan/nyanTargets.cmake
+lib/libnyan.so
+lib/libnyan.so.1
+lib/libnyan.so.1.0