aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-02-27 17:15:03 +0800
committermiwi <miwi@FreeBSD.org>2014-02-27 17:15:03 +0800
commit823a12cc311ad2239511fcb3c3aae3fe72bea955 (patch)
tree607176a14edc13b39199f8ca54982682d725aacf
parent0adf5f5704041b41561ed5154cafd7f9903411e9 (diff)
downloadfreebsd-ports-gnome-823a12cc311ad2239511fcb3c3aae3fe72bea955.tar.gz
freebsd-ports-gnome-823a12cc311ad2239511fcb3c3aae3fe72bea955.tar.zst
freebsd-ports-gnome-823a12cc311ad2239511fcb3c3aae3fe72bea955.zip
- Update to 1.7.0
PR: 186737
-rw-r--r--audio/sooperlooper/Makefile54
-rw-r--r--audio/sooperlooper/distinfo4
-rw-r--r--audio/sooperlooper/files/patch-configure158
-rw-r--r--audio/sooperlooper/files/patch-libs-midi-configure157
-rw-r--r--audio/sooperlooper/files/patch-libs__pbd__pathscanner.cpp10
-rw-r--r--audio/sooperlooper/files/patch-libs__pbd__pbd__stl_delete.h20
-rw-r--r--audio/sooperlooper/files/patch-src-plugin.cc16
-rw-r--r--audio/sooperlooper/pkg-descr10
-rw-r--r--audio/sooperlooper/pkg-plist15
9 files changed, 82 insertions, 362 deletions
diff --git a/audio/sooperlooper/Makefile b/audio/sooperlooper/Makefile
index 1acff635ad2a..7a9f916ca2ea 100644
--- a/audio/sooperlooper/Makefile
+++ b/audio/sooperlooper/Makefile
@@ -2,40 +2,60 @@
# $FreeBSD$
PORTNAME= sooperlooper
-PORTVERSION= 1.6.18
-PORTREVISION= 2
+PORTVERSION= 1.7.0
CATEGORIES= audio
MASTER_SITES= http://essej.net/sooperlooper/
MAINTAINER= ports@FreeBSD.org
-COMMENT= Vamp audio analysis plugin SDK
+COMMENT= Live audio looping sampler
LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
-LIB_DEPENDS= libfftw3.so:${PORTSDIR}/math/fftw3 \
- libjack.so:${PORTSDIR}/audio/jack \
+BUILD_DEPENDS= ladspa>0:${PORTSDIR}/audio/ladspa
+LIB_DEPENDS= libjack.so:${PORTSDIR}/audio/jack \
liblo.so:${PORTSDIR}/audio/liblo \
- librubberband.so:${PORTSDIR}/audio/rubberband \
libsamplerate.so:${PORTSDIR}/audio/libsamplerate \
libsigc-1.2.so:${PORTSDIR}/devel/libsigc++12 \
libsndfile.so:${PORTSDIR}/audio/libsndfile \
- libvamp-sdk.so:${PORTSDIR}/audio/vamp-plugin-sdk
-RUN_DEPENDS= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
+ librubberband.so:${PORTSDIR}/audio/rubberband \
+ libvamp-sdk.so:${PORTSDIR}/audio/vamp-plugin-sdk \
+ libfftw3.so:${PORTSDIR}/math/fftw3
+RUN_DEPENDS= ladspa>0:${PORTSDIR}/audio/ladspa
+USES= compiler:c++0x gmake ncurses pkgconfig
+USE_GNOME= libxml2
GNU_CONFIGURE= yes
-USES= gmake pkgconfig
-NO_STAGE= yes
-USE_WX= 2.6+
-WX_UNICODE= yes
-CONFIGURE_ARGS= -with-wxconfig-path=${WX_CONFIG}
USE_LDCONFIG= yes
-CFLAGS+= -I${LOCALBASE}/include
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USE_GNOME= libxml2
+OPTIONS_DEFINE= ALSA WXGTK
+OPTIONS_DEFAULT= WXGTK
+OPTIONS_SUB= yes
+
+ALSA_LIB_DEPENDS= libasound.so:${PORTSDIR}/audio/alsa-lib
+ALSA_CONFIGURE_ENV_OFF= ac_cv_header_alsa_asoundlib_h=no
+WXGTK_USE= WX=2.6+
+WXGTK_CONFIGURE_ON= --with-wxconfig-path=${WX_CONFIG}
+WXGTK_CONFIGURE_OFF= --without-gui
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MWXGTK}
+WX_UNICODE= yes
+DESKTOP_ENTRIES="SooperLooper" "" "${DATADIR}/sl_logo.xpm" "slgui" \
+ "AudioVideo;Audio;Player;GTK;" ""
+.endif
+
+post-patch:
+ @${FIND} ${WRKSRC} -name "configure" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|$$OPT_FLAGS||'
+
+post-install:
+.if ${PORT_OPTIONS:MWXGTK}
+ (cd ${WRKSRC}/src/gui/pixmaps && ${INSTALL_DATA} sl_logo.xpm \
+ ${STAGEDIR}${DATADIR})
+.endif
.include <bsd.port.mk>
diff --git a/audio/sooperlooper/distinfo b/audio/sooperlooper/distinfo
index 52c8bca7825d..bde98374508a 100644
--- a/audio/sooperlooper/distinfo
+++ b/audio/sooperlooper/distinfo
@@ -1,2 +1,2 @@
-SHA256 (sooperlooper-1.6.18.tar.gz) = 087a52186fefb138ac16deebc1ed4b9ff4945ffb4fe3e2170f60fcf97a3a8c38
-SIZE (sooperlooper-1.6.18.tar.gz) = 705462
+SHA256 (sooperlooper-1.7.0.tar.gz) = 99a2ed88b270183e090698ee354c484b971c77494547b5520afa6430e0eb571d
+SIZE (sooperlooper-1.7.0.tar.gz) = 728999
diff --git a/audio/sooperlooper/files/patch-configure b/audio/sooperlooper/files/patch-configure
deleted file mode 100644
index 993ca660ad80..000000000000
--- a/audio/sooperlooper/files/patch-configure
+++ /dev/null
@@ -1,158 +0,0 @@
---- configure-dist 2012-01-18 23:51:22.886747138 +0100
-+++ configure 2012-01-18 23:51:03.153741729 +0100
-@@ -6869,152 +6869,9 @@
- ac_link='$CXX -o conftest$ac_exeext $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
-
--
--if test "${ac_cv_header_alsa_asoundlib_h+set}" = set; then
-- { echo "$as_me:$LINENO: checking for alsa/asoundlib.h" >&5
--echo $ECHO_N "checking for alsa/asoundlib.h... $ECHO_C" >&6; }
--if test "${ac_cv_header_alsa_asoundlib_h+set}" = set; then
-- echo $ECHO_N "(cached) $ECHO_C" >&6
--fi
--{ echo "$as_me:$LINENO: result: $ac_cv_header_alsa_asoundlib_h" >&5
--echo "${ECHO_T}$ac_cv_header_alsa_asoundlib_h" >&6; }
--else
-- # Is the header compilable?
--{ echo "$as_me:$LINENO: checking alsa/asoundlib.h usability" >&5
--echo $ECHO_N "checking alsa/asoundlib.h usability... $ECHO_C" >&6; }
--cat >conftest.$ac_ext <<_ACEOF
--/* confdefs.h. */
--_ACEOF
--cat confdefs.h >>conftest.$ac_ext
--cat >>conftest.$ac_ext <<_ACEOF
--/* end confdefs.h. */
--$ac_includes_default
--#include <alsa/asoundlib.h>
--_ACEOF
--rm -f conftest.$ac_objext
--if { (ac_try="$ac_compile"
--case "(($ac_try" in
-- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
-- *) ac_try_echo=$ac_try;;
--esac
--eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
-- (eval "$ac_compile") 2>conftest.er1
-- ac_status=$?
-- grep -v '^ *+' conftest.er1 >conftest.err
-- rm -f conftest.er1
-- cat conftest.err >&5
-- echo "$as_me:$LINENO: \$? = $ac_status" >&5
-- (exit $ac_status); } && {
-- test -z "$ac_cxx_werror_flag" ||
-- test ! -s conftest.err
-- } && test -s conftest.$ac_objext; then
-- ac_header_compiler=yes
--else
-- echo "$as_me: failed program was:" >&5
--sed 's/^/| /' conftest.$ac_ext >&5
--
-- ac_header_compiler=no
--fi
--
--rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
--{ echo "$as_me:$LINENO: result: $ac_header_compiler" >&5
--echo "${ECHO_T}$ac_header_compiler" >&6; }
--
--# Is the header present?
--{ echo "$as_me:$LINENO: checking alsa/asoundlib.h presence" >&5
--echo $ECHO_N "checking alsa/asoundlib.h presence... $ECHO_C" >&6; }
--cat >conftest.$ac_ext <<_ACEOF
--/* confdefs.h. */
--_ACEOF
--cat confdefs.h >>conftest.$ac_ext
--cat >>conftest.$ac_ext <<_ACEOF
--/* end confdefs.h. */
--#include <alsa/asoundlib.h>
--_ACEOF
--if { (ac_try="$ac_cpp conftest.$ac_ext"
--case "(($ac_try" in
-- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
-- *) ac_try_echo=$ac_try;;
--esac
--eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
-- (eval "$ac_cpp conftest.$ac_ext") 2>conftest.er1
-- ac_status=$?
-- grep -v '^ *+' conftest.er1 >conftest.err
-- rm -f conftest.er1
-- cat conftest.err >&5
-- echo "$as_me:$LINENO: \$? = $ac_status" >&5
-- (exit $ac_status); } >/dev/null && {
-- test -z "$ac_cxx_preproc_warn_flag$ac_cxx_werror_flag" ||
-- test ! -s conftest.err
-- }; then
-- ac_header_preproc=yes
--else
-- echo "$as_me: failed program was:" >&5
--sed 's/^/| /' conftest.$ac_ext >&5
--
-- ac_header_preproc=no
--fi
--
--rm -f conftest.err conftest.$ac_ext
--{ echo "$as_me:$LINENO: result: $ac_header_preproc" >&5
--echo "${ECHO_T}$ac_header_preproc" >&6; }
--
--# So? What about this header?
--case $ac_header_compiler:$ac_header_preproc:$ac_cxx_preproc_warn_flag in
-- yes:no: )
-- { echo "$as_me:$LINENO: WARNING: alsa/asoundlib.h: accepted by the compiler, rejected by the preprocessor!" >&5
--echo "$as_me: WARNING: alsa/asoundlib.h: accepted by the compiler, rejected by the preprocessor!" >&2;}
-- { echo "$as_me:$LINENO: WARNING: alsa/asoundlib.h: proceeding with the compiler's result" >&5
--echo "$as_me: WARNING: alsa/asoundlib.h: proceeding with the compiler's result" >&2;}
-- ac_header_preproc=yes
-- ;;
-- no:yes:* )
-- { echo "$as_me:$LINENO: WARNING: alsa/asoundlib.h: present but cannot be compiled" >&5
--echo "$as_me: WARNING: alsa/asoundlib.h: present but cannot be compiled" >&2;}
-- { echo "$as_me:$LINENO: WARNING: alsa/asoundlib.h: check for missing prerequisite headers?" >&5
--echo "$as_me: WARNING: alsa/asoundlib.h: check for missing prerequisite headers?" >&2;}
-- { echo "$as_me:$LINENO: WARNING: alsa/asoundlib.h: see the Autoconf documentation" >&5
--echo "$as_me: WARNING: alsa/asoundlib.h: see the Autoconf documentation" >&2;}
-- { echo "$as_me:$LINENO: WARNING: alsa/asoundlib.h: section \"Present But Cannot Be Compiled\"" >&5
--echo "$as_me: WARNING: alsa/asoundlib.h: section \"Present But Cannot Be Compiled\"" >&2;}
-- { echo "$as_me:$LINENO: WARNING: alsa/asoundlib.h: proceeding with the preprocessor's result" >&5
--echo "$as_me: WARNING: alsa/asoundlib.h: proceeding with the preprocessor's result" >&2;}
-- { echo "$as_me:$LINENO: WARNING: alsa/asoundlib.h: in the future, the compiler will take precedence" >&5
--echo "$as_me: WARNING: alsa/asoundlib.h: in the future, the compiler will take precedence" >&2;}
--
-- ;;
--esac
--{ echo "$as_me:$LINENO: checking for alsa/asoundlib.h" >&5
--echo $ECHO_N "checking for alsa/asoundlib.h... $ECHO_C" >&6; }
--if test "${ac_cv_header_alsa_asoundlib_h+set}" = set; then
-- echo $ECHO_N "(cached) $ECHO_C" >&6
--else
-- ac_cv_header_alsa_asoundlib_h=$ac_header_preproc
--fi
--{ echo "$as_me:$LINENO: result: $ac_cv_header_alsa_asoundlib_h" >&5
--echo "${ECHO_T}$ac_cv_header_alsa_asoundlib_h" >&6; }
--
--fi
--if test $ac_cv_header_alsa_asoundlib_h = yes; then
-- use_alsa_midi=yes
-- AUDIO_LIBS=-lasound
--
--cat >>confdefs.h <<\_ACEOF
--#define WITH_ALSA 1
--_ACEOF
--
--else
-- use_alsa_midi=no
--fi
--
--
-- if test x$use_alsa_midi = xyes; then
-- WITH_ALSA_TRUE=
-- WITH_ALSA_FALSE='#'
--else
-- WITH_ALSA_TRUE='#'
-- WITH_ALSA_FALSE=
--fi
-+# FreeBSD: unset alsa
-+WITH_ALSA_TRUE='#'
-+WITH_ALSA_FALSE=
-
-
- { echo "$as_me:$LINENO: checking for /System/Library/Frameworks/CoreMIDI.framework/Headers/CoreMIDI.h" >&5
diff --git a/audio/sooperlooper/files/patch-libs-midi-configure b/audio/sooperlooper/files/patch-libs-midi-configure
deleted file mode 100644
index 3fda2778d0eb..000000000000
--- a/audio/sooperlooper/files/patch-libs-midi-configure
+++ /dev/null
@@ -1,157 +0,0 @@
---- libs/midi++/configure-dist 2012-01-18 23:48:59.738744056 +0100
-+++ libs/midi++/configure 2012-01-18 23:49:55.386738098 +0100
-@@ -5100,151 +5100,9 @@
- done
-
-
--if test "${ac_cv_header_alsa_asoundlib_h+set}" = set; then
-- { echo "$as_me:$LINENO: checking for alsa/asoundlib.h" >&5
--echo $ECHO_N "checking for alsa/asoundlib.h... $ECHO_C" >&6; }
--if test "${ac_cv_header_alsa_asoundlib_h+set}" = set; then
-- echo $ECHO_N "(cached) $ECHO_C" >&6
--fi
--{ echo "$as_me:$LINENO: result: $ac_cv_header_alsa_asoundlib_h" >&5
--echo "${ECHO_T}$ac_cv_header_alsa_asoundlib_h" >&6; }
--else
-- # Is the header compilable?
--{ echo "$as_me:$LINENO: checking alsa/asoundlib.h usability" >&5
--echo $ECHO_N "checking alsa/asoundlib.h usability... $ECHO_C" >&6; }
--cat >conftest.$ac_ext <<_ACEOF
--/* confdefs.h. */
--_ACEOF
--cat confdefs.h >>conftest.$ac_ext
--cat >>conftest.$ac_ext <<_ACEOF
--/* end confdefs.h. */
--$ac_includes_default
--#include <alsa/asoundlib.h>
--_ACEOF
--rm -f conftest.$ac_objext
--if { (ac_try="$ac_compile"
--case "(($ac_try" in
-- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
-- *) ac_try_echo=$ac_try;;
--esac
--eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
-- (eval "$ac_compile") 2>conftest.er1
-- ac_status=$?
-- grep -v '^ *+' conftest.er1 >conftest.err
-- rm -f conftest.er1
-- cat conftest.err >&5
-- echo "$as_me:$LINENO: \$? = $ac_status" >&5
-- (exit $ac_status); } && {
-- test -z "$ac_cxx_werror_flag" ||
-- test ! -s conftest.err
-- } && test -s conftest.$ac_objext; then
-- ac_header_compiler=yes
--else
-- echo "$as_me: failed program was:" >&5
--sed 's/^/| /' conftest.$ac_ext >&5
--
-- ac_header_compiler=no
--fi
--
--rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
--{ echo "$as_me:$LINENO: result: $ac_header_compiler" >&5
--echo "${ECHO_T}$ac_header_compiler" >&6; }
--
--# Is the header present?
--{ echo "$as_me:$LINENO: checking alsa/asoundlib.h presence" >&5
--echo $ECHO_N "checking alsa/asoundlib.h presence... $ECHO_C" >&6; }
--cat >conftest.$ac_ext <<_ACEOF
--/* confdefs.h. */
--_ACEOF
--cat confdefs.h >>conftest.$ac_ext
--cat >>conftest.$ac_ext <<_ACEOF
--/* end confdefs.h. */
--#include <alsa/asoundlib.h>
--_ACEOF
--if { (ac_try="$ac_cpp conftest.$ac_ext"
--case "(($ac_try" in
-- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
-- *) ac_try_echo=$ac_try;;
--esac
--eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
-- (eval "$ac_cpp conftest.$ac_ext") 2>conftest.er1
-- ac_status=$?
-- grep -v '^ *+' conftest.er1 >conftest.err
-- rm -f conftest.er1
-- cat conftest.err >&5
-- echo "$as_me:$LINENO: \$? = $ac_status" >&5
-- (exit $ac_status); } >/dev/null && {
-- test -z "$ac_cxx_preproc_warn_flag$ac_cxx_werror_flag" ||
-- test ! -s conftest.err
-- }; then
-- ac_header_preproc=yes
--else
-- echo "$as_me: failed program was:" >&5
--sed 's/^/| /' conftest.$ac_ext >&5
--
-- ac_header_preproc=no
--fi
--
--rm -f conftest.err conftest.$ac_ext
--{ echo "$as_me:$LINENO: result: $ac_header_preproc" >&5
--echo "${ECHO_T}$ac_header_preproc" >&6; }
--
--# So? What about this header?
--case $ac_header_compiler:$ac_header_preproc:$ac_cxx_preproc_warn_flag in
-- yes:no: )
-- { echo "$as_me:$LINENO: WARNING: alsa/asoundlib.h: accepted by the compiler, rejected by the preprocessor!" >&5
--echo "$as_me: WARNING: alsa/asoundlib.h: accepted by the compiler, rejected by the preprocessor!" >&2;}
-- { echo "$as_me:$LINENO: WARNING: alsa/asoundlib.h: proceeding with the compiler's result" >&5
--echo "$as_me: WARNING: alsa/asoundlib.h: proceeding with the compiler's result" >&2;}
-- ac_header_preproc=yes
-- ;;
-- no:yes:* )
-- { echo "$as_me:$LINENO: WARNING: alsa/asoundlib.h: present but cannot be compiled" >&5
--echo "$as_me: WARNING: alsa/asoundlib.h: present but cannot be compiled" >&2;}
-- { echo "$as_me:$LINENO: WARNING: alsa/asoundlib.h: check for missing prerequisite headers?" >&5
--echo "$as_me: WARNING: alsa/asoundlib.h: check for missing prerequisite headers?" >&2;}
-- { echo "$as_me:$LINENO: WARNING: alsa/asoundlib.h: see the Autoconf documentation" >&5
--echo "$as_me: WARNING: alsa/asoundlib.h: see the Autoconf documentation" >&2;}
-- { echo "$as_me:$LINENO: WARNING: alsa/asoundlib.h: section \"Present But Cannot Be Compiled\"" >&5
--echo "$as_me: WARNING: alsa/asoundlib.h: section \"Present But Cannot Be Compiled\"" >&2;}
-- { echo "$as_me:$LINENO: WARNING: alsa/asoundlib.h: proceeding with the preprocessor's result" >&5
--echo "$as_me: WARNING: alsa/asoundlib.h: proceeding with the preprocessor's result" >&2;}
-- { echo "$as_me:$LINENO: WARNING: alsa/asoundlib.h: in the future, the compiler will take precedence" >&5
--echo "$as_me: WARNING: alsa/asoundlib.h: in the future, the compiler will take precedence" >&2;}
--
-- ;;
--esac
--{ echo "$as_me:$LINENO: checking for alsa/asoundlib.h" >&5
--echo $ECHO_N "checking for alsa/asoundlib.h... $ECHO_C" >&6; }
--if test "${ac_cv_header_alsa_asoundlib_h+set}" = set; then
-- echo $ECHO_N "(cached) $ECHO_C" >&6
--else
-- ac_cv_header_alsa_asoundlib_h=$ac_header_preproc
--fi
--{ echo "$as_me:$LINENO: result: $ac_cv_header_alsa_asoundlib_h" >&5
--echo "${ECHO_T}$ac_cv_header_alsa_asoundlib_h" >&6; }
--
--fi
--if test $ac_cv_header_alsa_asoundlib_h = yes; then
-- use_alsa_midi=yes
-- AUDIO_LIBS=-lasound
--
--cat >>confdefs.h <<\_ACEOF
--#define WITH_ALSA 1
--_ACEOF
--
--else
-- use_alsa_midi=no
--fi
--
--
-- if test x$use_alsa_midi = xyes; then
-- WITH_ALSA_TRUE=
-- WITH_ALSA_FALSE='#'
--else
-- WITH_ALSA_TRUE='#'
-- WITH_ALSA_FALSE=
--fi
-+# FreeBSD: unset alsa
-+WITH_ALSA_TRUE='#'
-+WITH_ALSA_FALSE=
-
-
- { echo "$as_me:$LINENO: checking for /System/Library/Frameworks/CoreMIDI.framework/Headers/CoreMIDI.h" >&5
diff --git a/audio/sooperlooper/files/patch-libs__pbd__pathscanner.cpp b/audio/sooperlooper/files/patch-libs__pbd__pathscanner.cpp
new file mode 100644
index 000000000000..d1b942423bc5
--- /dev/null
+++ b/audio/sooperlooper/files/patch-libs__pbd__pathscanner.cpp
@@ -0,0 +1,10 @@
+--- libs/pbd/pathscanner.cc.orig
++++ libs/pbd/pathscanner.cc
+@@ -21,6 +21,7 @@
+ #include <cstdlib>
+ #include <cstdio>
+ #include <cstring>
++#include <climits>
+ #include <vector>
+ #include <dirent.h>
+
diff --git a/audio/sooperlooper/files/patch-libs__pbd__pbd__stl_delete.h b/audio/sooperlooper/files/patch-libs__pbd__pbd__stl_delete.h
new file mode 100644
index 000000000000..77ed78616582
--- /dev/null
+++ b/audio/sooperlooper/files/patch-libs__pbd__pbd__stl_delete.h
@@ -0,0 +1,20 @@
+--- libs/pbd/pbd/stl_delete.h.orig
++++ libs/pbd/pbd/stl_delete.h
+@@ -24,7 +24,7 @@
+ /* To actually use any of these deletion functions, you need to
+ first include the revelant container type header.
+ */
+-#if defined(_CPP_VECTOR) || defined(_GLIBCXX_VECTOR) || defined(__SGI_STL_VECTOR)
++#if defined(_LIBCPP_VECTOR) || defined(_GLIBCXX_VECTOR) || defined(__SGI_STL_VECTOR)
+ template<class T> void vector_delete (std::vector<T *> *vec)
+ {
+ typename std::vector<T *>::iterator i;
+@@ -34,7 +34,7 @@
+ }
+ vec->clear ();
+ }
+-#endif // _CPP_VECTOR || _GLIBCXX_VECTOR || __SGI_STL_VECTOR
++#endif // _LIBCPP_VECTOR || _GLIBCXX_VECTOR || __SGI_STL_VECTOR
+
+ #if defined(_CPP_MAP) || defined(_GLIBCXX_MAP) || defined(__SGI_STL_MAP)
+ template<class K, class T> void map_delete (std::map<K, T *> *m)
diff --git a/audio/sooperlooper/files/patch-src-plugin.cc b/audio/sooperlooper/files/patch-src-plugin.cc
deleted file mode 100644
index 03493d22350d..000000000000
--- a/audio/sooperlooper/files/patch-src-plugin.cc
+++ /dev/null
@@ -1,16 +0,0 @@
---- src/plugin.cc-dist 2012-01-18 12:40:15.870419356 +0100
-+++ src/plugin.cc 2012-01-18 13:28:16.760422152 +0100
-@@ -44,6 +44,13 @@
-
- using namespace SooperLooper;
-
-+#if __FreeBSD__ >= 2
-+#include <osreldate.h>
-+# if __FreeBSD_version < 900500
-+ /* not defined before FreeBSD 9 */
-+# define log2(x) (log(x) / M_LN2)
-+# endif /* __FreeBSD_version < 900500 */
-+#endif /* __FreeBSD__ */
-
- /*****************************************************************************/
- //#define LOOPDEBUG
diff --git a/audio/sooperlooper/pkg-descr b/audio/sooperlooper/pkg-descr
index ab4b98cd0ac0..c2f283e74a62 100644
--- a/audio/sooperlooper/pkg-descr
+++ b/audio/sooperlooper/pkg-descr
@@ -1,6 +1,6 @@
-SooperLooper is a live looping sampler capable of immediate loop recording,
-overdubbing, multiplying, reversing and more. It allows for multiple
-simultaneous multi-channel loops limited only by your computer's available
-memory.
+SooperLooper is a live looping sampler capable of immediate loop
+recording, overdubbing, multiplying, reversing and more. It allows for
+multiple simultaneous multi-channel loops limited only by your computer's
+available memory.
-WWW: http://essej.net/sooperlooper/
+WWW: http://essej.net/sooperlooper/
diff --git a/audio/sooperlooper/pkg-plist b/audio/sooperlooper/pkg-plist
index 1e4e56005a79..40ff9636a771 100644
--- a/audio/sooperlooper/pkg-plist
+++ b/audio/sooperlooper/pkg-plist
@@ -1,10 +1,11 @@
bin/slconsole
-bin/slgui
+%%WXGTK%%bin/slgui
bin/slregister
bin/sooperlooper
-share/sooperlooper/presets/bcf2000.slb
-share/sooperlooper/presets/edp4.slb
-share/sooperlooper/presets/midiwizard.slb
-share/sooperlooper/presets/oxy8.slb
-@dirrm share/sooperlooper/presets
-@dirrm share/sooperlooper
+%%DATADIR%%/presets/bcf2000.slb
+%%DATADIR%%/presets/edp4.slb
+%%DATADIR%%/presets/midiwizard.slb
+%%DATADIR%%/presets/oxy8.slb
+%%WXGTK%%%%DATADIR%%/sl_logo.xpm
+@dirrm %%DATADIR%%/presets
+@dirrm %%DATADIR%%