aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorcs <cs@FreeBSD.org>2013-03-27 04:31:07 +0800
committercs <cs@FreeBSD.org>2013-03-27 04:31:07 +0800
commit83f64bd3f8e22e68816d4b7aef403b03de5db650 (patch)
treed74817caccaa5efad9b5c16649856f28050f6f4a
parent9caae6422be6b09b6ac03f68a8649ef59d02d69c (diff)
downloadfreebsd-ports-gnome-83f64bd3f8e22e68816d4b7aef403b03de5db650.tar.gz
freebsd-ports-gnome-83f64bd3f8e22e68816d4b7aef403b03de5db650.tar.zst
freebsd-ports-gnome-83f64bd3f8e22e68816d4b7aef403b03de5db650.zip
Rssroll is a collector of RSS feeds.
Written in C it uses libxml2 to store feeds into sqlite3 database. rssroll.cgi allows web browsing of stored feeds. WWW: http://chaosophia.net/rssroll/ PR: ports/177070
-rw-r--r--www/Makefile1
-rw-r--r--www/rssroll/Makefile27
-rw-r--r--www/rssroll/distinfo2
-rw-r--r--www/rssroll/pkg-descr5
-rw-r--r--www/rssroll/pkg-plist14
5 files changed, 49 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index e43ce08fb7ab..b4ce446b90f5 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1685,6 +1685,7 @@
SUBDIR += roundup
SUBDIR += rsskit
SUBDIR += rssowl
+ SUBDIR += rssroll
SUBDIR += rsstail
SUBDIR += rsstool
SUBDIR += rt38
diff --git a/www/rssroll/Makefile b/www/rssroll/Makefile
new file mode 100644
index 000000000000..a772c41a4db5
--- /dev/null
+++ b/www/rssroll/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= rssroll
+PORTVERSION= 0.2
+CATEGORIES= www
+MASTER_SITES= http://chaosophia.net/downloads/rssroll/ \
+ http://ns1.chaosophia.net/downloads/rssroll/
+
+MAINTAINER= koue@chaosophia.net
+COMMENT= RSS collector in C
+
+LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
+ xml2:${PORTSDIR}/textproc/libxml2 \
+ sqlite3:${PORTSDIR}/databases/sqlite3
+
+CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libxml2
+LDFLAGS+= -L${LOCALBASE}/lib
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/rssroll ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/www/data/rssroll ${PREFIX}/www/cgi-bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/index.cgi ${PREFIX}/www/cgi-bin/rssroll.cgi
+ ${INSTALL_DATA} ${WRKSRC}/rssrollrc ${PREFIX}/etc/rssrollrc.sample
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} "html css" ${PREFIX}/www/data/rssroll/)
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/www/cgi-bin/rssroll.cgi ${PREFIX}/www/data/rssroll/
+
+.include <bsd.port.mk>
diff --git a/www/rssroll/distinfo b/www/rssroll/distinfo
new file mode 100644
index 000000000000..f92447899d7d
--- /dev/null
+++ b/www/rssroll/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rssroll-0.2.tar.gz) = f34e89b66bcc975a4cfa033e1fa4bf1827cda96467836fa991e0f5e6a0232d4a
+SIZE (rssroll-0.2.tar.gz) = 17199
diff --git a/www/rssroll/pkg-descr b/www/rssroll/pkg-descr
new file mode 100644
index 000000000000..9826aeed2d92
--- /dev/null
+++ b/www/rssroll/pkg-descr
@@ -0,0 +1,5 @@
+Rssroll is a collector of RSS feeds.
+Written in C it uses libxml2 to store feeds into sqlite3
+database. rssroll.cgi allows web browsing of stored feeds.
+
+WWW: http://chaosophia.net/rssroll/
diff --git a/www/rssroll/pkg-plist b/www/rssroll/pkg-plist
new file mode 100644
index 000000000000..92e6b5150e7a
--- /dev/null
+++ b/www/rssroll/pkg-plist
@@ -0,0 +1,14 @@
+bin/rssroll
+www/cgi-bin/rssroll.cgi
+etc/rssrollrc.sample
+www/data/rssroll/css/common.css
+www/data/rssroll/css/default.css
+www/data/rssroll/html/header.html
+www/data/rssroll/html/main.html
+www/data/rssroll/html/feed.html
+www/data/rssroll/html/footer.html
+@dirrm www/data/rssroll/html
+@dirrm www/data/rssroll/css
+@dirrm www/data/rssroll
+@dirrmtry www/data
+@dirrmtry www/cgi-bin