aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-07-26 10:40:15 +0800
committeryuri <yuri@FreeBSD.org>2018-07-26 10:40:15 +0800
commit84270ac8e1f7af793ccb4a06bb38cb2f6c7807b4 (patch)
tree04f41de2541af9946da12baea0fe6b2d7ec28277
parentc9136078dbd74e6470dda460620198daaf549bc5 (diff)
downloadfreebsd-ports-gnome-84270ac8e1f7af793ccb4a06bb38cb2f6c7807b4.tar.gz
freebsd-ports-gnome-84270ac8e1f7af793ccb4a06bb38cb2f6c7807b4.tar.zst
freebsd-ports-gnome-84270ac8e1f7af793ccb4a06bb38cb2f6c7807b4.zip
New port: astro/sofa: Set of algorithms and procedures used in fundamental astronomy
-rw-r--r--astro/Makefile1
-rw-r--r--astro/sofa/Makefile28
-rw-r--r--astro/sofa/distinfo3
-rw-r--r--astro/sofa/files/patch-makefile20
-rw-r--r--astro/sofa/pkg-descr17
5 files changed, 69 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index d328fa874c52..37064bcf5d57 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -103,6 +103,7 @@
SUBDIR += saoimage
SUBDIR += sextractor
SUBDIR += siril
+ SUBDIR += sofa
SUBDIR += sscalc
SUBDIR += stardates
SUBDIR += starplot
diff --git a/astro/sofa/Makefile b/astro/sofa/Makefile
new file mode 100644
index 000000000000..97b800f59b9e
--- /dev/null
+++ b/astro/sofa/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= sofa
+DISTVERSION= 20180130
+CATEGORIES= astro devel
+MASTER_SITES= http://www.iausofa.org/${DISTVERSION:C/(....)(....)/\\1_\\2/}_C/
+DISTNAME= ${PORTNAME}_c-${DISTVERSION}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Set of algorithms and procedures used in fundamental astronomy
+
+LICENSE= SOFA
+LICENSE_NAME= SOFA Software License
+LICENSE_FILE= ${WRKDIR}/sofa/20180130/c/doc/copyr.lis
+LICENSE_PERMS= dist-mirror no-dist-sell pkg-mirror no-pkg-sell auto-accept
+
+MAKEFILE= makefile
+USE_LDCONFIG= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}/${DISTVERSION}/c/src
+BINARY_ALIAS= gcc=cc
+MAKE_ARGS= CFLAGF="-c ${CFLAGS} -fPIC" INSTALL_DIR=${STAGEDIR}${PREFIX}
+
+PLIST_FILES= include/sofa.h \
+ include/sofam.h \
+ lib/libsofa_c.so
+
+.include <bsd.port.mk>
diff --git a/astro/sofa/distinfo b/astro/sofa/distinfo
new file mode 100644
index 000000000000..d02fed366c78
--- /dev/null
+++ b/astro/sofa/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1532570296
+SHA256 (sofa_c-20180130.tar.gz) = de09807198c977e1c58ea1d0c79c40bdafef84f2072eab586a7ac246334796db
+SIZE (sofa_c-20180130.tar.gz) = 1820345
diff --git a/astro/sofa/files/patch-makefile b/astro/sofa/files/patch-makefile
new file mode 100644
index 000000000000..228d7faf5869
--- /dev/null
+++ b/astro/sofa/files/patch-makefile
@@ -0,0 +1,20 @@
+--- makefile.orig 2018-07-26 02:04:00 UTC
++++ makefile
+@@ -77,7 +77,7 @@ INSTALL_DIRS = $(SOFA_LIB_DIR) $(SOFA_IN
+
+ # Name the SOFA/C library in its source and target locations.
+
+-SOFA_LIB_NAME = libsofa_c.a
++SOFA_LIB_NAME = libsofa_c.so
+ SOFA_LIB = $(SOFA_LIB_DIR)$(SOFA_LIB_NAME)
+
+ # Name the SOFA/C testbed in its source and target locations.
+@@ -380,7 +380,7 @@ $(INSTALL_DIRS):
+
+ # Build the library.
+ $(SOFA_LIB_NAME): $(SOFA_OBS)
+- ar ru $(SOFA_LIB_NAME) $?
++ $(CC) -shared $(LDFLAGS) -o $(SOFA_LIB_NAME) $?
+
+ # Install the header files.
+ $(SOFA_INC) : $(INSTALL_DIRS) $(SOFA_INC_NAMES)
diff --git a/astro/sofa/pkg-descr b/astro/sofa/pkg-descr
new file mode 100644
index 000000000000..74b974e347b9
--- /dev/null
+++ b/astro/sofa/pkg-descr
@@ -0,0 +1,17 @@
+The SOFA Collection consists of libraries of routines in ANSI C. There is a
+suite of vector/matrix routines and various utilities that underpin the
+astronomy algorithms, which include routines for the following:
+
+* Astrometry
+* Calendars
+* Time Scales
+* Ecliptic Coordinates
+* Earth Rotation and Sidereal Time
+* Ephemerides (medium precision)
+* Fundamental Arguments
+* Galactic Coordinates
+* Geocentric/Geodetic Transformations
+* Precession, Nutation and Polar Motion
+* Star Catalog Conversion
+
+WWW: http://www.iausofa.org