aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2014-08-15 19:23:14 +0800
committerriggs <riggs@FreeBSD.org>2014-08-15 19:23:14 +0800
commit846e2418d0b8742efed1fd7f450a71eb6a0c502d (patch)
tree23338af0c4aff517a39cb993f675da578ab67dd7
parent28e8f579e6662ff4d872f8154089a2dfc7f3d9e5 (diff)
downloadfreebsd-ports-gnome-846e2418d0b8742efed1fd7f450a71eb6a0c502d.tar.gz
freebsd-ports-gnome-846e2418d0b8742efed1fd7f450a71eb6a0c502d.tar.zst
freebsd-ports-gnome-846e2418d0b8742efed1fd7f450a71eb6a0c502d.zip
- Update to upstream release 1.20
- Add LICENSE Approved by: mentors (implicit)
-rw-r--r--www/mini_httpd/Makefile5
-rw-r--r--www/mini_httpd/distinfo4
-rw-r--r--www/mini_httpd/files/patch-Makefile26
-rw-r--r--www/mini_httpd/files/patch-mini_httpd.c11
4 files changed, 16 insertions, 30 deletions
diff --git a/www/mini_httpd/Makefile b/www/mini_httpd/Makefile
index 8cef3e8f7576..0858d08fc211 100644
--- a/www/mini_httpd/Makefile
+++ b/www/mini_httpd/Makefile
@@ -2,14 +2,15 @@
# $FreeBSD$
PORTNAME= mini_httpd
-PORTVERSION= 1.19
-PORTREVISION= 2
+PORTVERSION= 1.20
CATEGORIES= www ipv6
MASTER_SITES= http://www.acme.com/software/mini_httpd/
MAINTAINER= ports@FreeBSD.org
COMMENT= Small HTTP server with support for GET, HEAD, POST, CGI, SSL, IPv6
+LICENSE= BSD2CLAUSE
+
OPTIONS_DEFINE= SSL
SSL_MAKE_ARGS= -DUSE_OPENSSL
diff --git a/www/mini_httpd/distinfo b/www/mini_httpd/distinfo
index bbaafb61c17e..b8ba0508015d 100644
--- a/www/mini_httpd/distinfo
+++ b/www/mini_httpd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mini_httpd-1.19.tar.gz) = f7f36533b1338ea16d916ea525ea7006ab38fdd3544ac7df93a4688a8e270241
-SIZE (mini_httpd-1.19.tar.gz) = 42063
+SHA256 (mini_httpd-1.20.tar.gz) = 60dfb045c07c993f811eb1024e040b0a2cb392e882c8092905bf719003912730
+SIZE (mini_httpd-1.20.tar.gz) = 43109
diff --git a/www/mini_httpd/files/patch-Makefile b/www/mini_httpd/files/patch-Makefile
index fb107a270d58..14cc02e02f92 100644
--- a/www/mini_httpd/files/patch-Makefile
+++ b/www/mini_httpd/files/patch-Makefile
@@ -1,26 +1,22 @@
---- Makefile.orig 2002-11-01 23:02:57.000000000 +0000
-+++ Makefile 2010-12-23 14:02:54.000000000 +0000
-@@ -14,17 +14,20 @@
- # http://www.openssl.org/ Make sure the SSL_TREE definition points to the
+--- Makefile.orig 2014-08-11 21:13:49.000000000 +0200
++++ Makefile 2014-08-15 13:12:30.099236617 +0200
+@@ -15,16 +15,16 @@
# tree with your OpenSSL installation - depending on how you installed it,
# it may be in /usr/local instead of /usr/local/ssl.
-+.ifdef USE_OPENSSL
#SSL_TREE = /usr/local/ssl
-#SSL_DEFS = -DUSE_SSL
+SSL_DEFS = -DUSE_SSL
- #SSL_INC = -I${SSL_TREE}/include
- #SSL_LIBS = -L${SSL_TREE}/lib -lssl -lcrypto
+ #SSL_INC = -I$(SSL_TREE)/include
+-#SSL_LIBS = -L$(SSL_TREE)/lib -lssl -lcrypto
+SSL_LIBS = -lssl -lcrypto
-+.endif
BINDIR = /usr/local/sbin
MANDIR = /usr/local/man
--CC = gcc
-+#CC = gcc
- CDEFS = ${SSL_DEFS} ${SSL_INC}
--CFLAGS = -O ${CDEFS}
-+CFLAGS += ${CDEFS}
- #CFLAGS = -g ${CDEFS}
+ CC = cc
+ CDEFS = $(SSL_DEFS) $(SSL_INC)
+-CFLAGS = -O $(CDEFS) -ansi -pedantic -U__STRICT_ANSI__ -Wall -Wpointer-arith -Wshadow -Wcast-qual -Wcast-align -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wredundant-decls -Wno-long-long
++CFLAGS += $(CDEFS) -ansi -pedantic -U__STRICT_ANSI__ -Wall -Wpointer-arith -Wshadow -Wcast-qual -Wcast-align -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wredundant-decls -Wno-long-long
LDFLAGS = -s
- #LDFLAGS = -g
+ LDLIBS = $(CRYPT_LIB) $(SSL_LIBS) $(SYSV_LIBS)
+
diff --git a/www/mini_httpd/files/patch-mini_httpd.c b/www/mini_httpd/files/patch-mini_httpd.c
deleted file mode 100644
index 15ac02b4d671..000000000000
--- a/www/mini_httpd/files/patch-mini_httpd.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- mini_httpd.c.orig Wed Dec 3 19:27:22 2003
-+++ mini_httpd.c Thu May 6 23:36:20 2004
-@@ -816,7 +816,7 @@
- }
- if ( conn_fd < 0 )
- {
-- if ( errno == EINTR || errno == EAGAIN )
-+ if ( errno == EINTR || errno == EAGAIN || errno == ECONNABORTED )
- continue; /* try again */
- #ifdef EPROTO
- if ( errno == EPROTO )