aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2012-12-16 20:03:39 +0800
committerrm <rm@FreeBSD.org>2012-12-16 20:03:39 +0800
commit84e56893752a913ae12017c2ed5705f0bc58e24d (patch)
treeed1c8d270213cfacc2cba7e381cee87d712527c6
parenta24ab003f86eae23024305ac616a07453fb64124 (diff)
downloadfreebsd-ports-gnome-84e56893752a913ae12017c2ed5705f0bc58e24d.tar.gz
freebsd-ports-gnome-84e56893752a913ae12017c2ed5705f0bc58e24d.tar.zst
freebsd-ports-gnome-84e56893752a913ae12017c2ed5705f0bc58e24d.zip
- update to 0.8.7
- fix options dialog issue (add OPTIONSFILE) - install docs included while here: - limit to python 2.x (the code is not python 3.x-aware yet) - tab -> space change in pkg-descr:WWW - use PYTHON_CMD instead of ``/usr/bin/env python'' to make sure it will be runned with the same python branch, that it was built with PR: 173531 Submitted by: Marco Broder <marco.broeder@gmx.eu> (maintainer)
-rw-r--r--devel/dulwich/Makefile28
-rw-r--r--devel/dulwich/distinfo4
-rw-r--r--devel/dulwich/pkg-descr2
3 files changed, 18 insertions, 16 deletions
diff --git a/devel/dulwich/Makefile b/devel/dulwich/Makefile
index dd15b23ddeb9..6fe820b2e2b1 100644
--- a/devel/dulwich/Makefile
+++ b/devel/dulwich/Makefile
@@ -1,12 +1,8 @@
-# Ports collection makefile for: dulwich
-# Date created: 2009-10-24
-# Whom: Marco Broeder <marco.broeder@gmx.eu>
-#
+# Created by: Marco Broeder <marco.broeder@gmx.eu>
# $FreeBSD$
-#
PORTNAME= dulwich
-PORTVERSION= 0.8.5
+PORTVERSION= 0.8.7
CATEGORIES= devel python
MASTER_SITES= http://samba.org/~jelmer/${PORTNAME}/ \
http://launchpad.net/${PORTNAME}/trunk/${PORTVERSION}/+download/
@@ -20,23 +16,29 @@ LICENSE_COMB= dual
MAKE_JOBS_SAFE= yes
-USE_PYTHON= yes
+PORTDOCS= AUTHORS HACKING NEWS README introduction.txt \
+ object-store.txt protocol.txt remote.txt repo.txt
+
+USE_PYTHON= -2.7
USE_PYDISTUTILS=yes
FETCH_ARGS= -Fpr # default '-AFpr' prevents 302 redirects by launchpad
-.ifndef (NOPORTDOCS)
-PORTDOCS= AUTHORS COPYING HACKING NEWS README
-.endif
+OPTIONSFILE= ${PORT_DBDIR}/${PORTNAME}/options
+OPTIONS_DEFINE= DOCS
+OPTIONS_DEFAULT=DOCS
+
+.include <bsd.port.options.mk>
post-patch:
- ${REINPLACE_CMD} -e 's|PYTHON = python|PYTHON = /usr/bin/env python|g' \
+ ${REINPLACE_CMD} -e 's|PYTHON = python|PYTHON = ${PYTHON_CMD}|g' \
${WRKSRC}/Makefile
- ${REINPLACE_CMD} -e 's|/usr/bin/python|/usr/bin/env python|g' \
+ ${REINPLACE_CMD} -e 's|/usr/bin/python|${PYTHON_CMD}|g' \
${WRKSRC}/setup.py
post-install:
-.ifndef (NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
+ ${CP} ${WRKSRC}/docs/*.txt ${WRKSRC}/docs/tutorial/*.txt ${WRKSRC}
${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
diff --git a/devel/dulwich/distinfo b/devel/dulwich/distinfo
index a7983b7878b9..71837310f070 100644
--- a/devel/dulwich/distinfo
+++ b/devel/dulwich/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dulwich-0.8.5.tar.gz) = 546d2840199500dc270da5bda456df68de4d1733f8b184bf425c5e560f988b6a
-SIZE (dulwich-0.8.5.tar.gz) = 203727
+SHA256 (dulwich-0.8.7.tar.gz) = 7ba336d0100b90baf843b20d71fedc8a92e36de41c1acdebe4cba12e76b93810
+SIZE (dulwich-0.8.7.tar.gz) = 208639
diff --git a/devel/dulwich/pkg-descr b/devel/dulwich/pkg-descr
index f23c77a71b8c..7acabe297597 100644
--- a/devel/dulwich/pkg-descr
+++ b/devel/dulwich/pkg-descr
@@ -4,4 +4,4 @@ It aims to give an interface to git repos that doesn't call out to git directly
but instead uses pure Python. It is based on the Python-Git module released by
James Westby.
-WWW: http://samba.org/~jelmer/dulwich/
+WWW: http://samba.org/~jelmer/dulwich/