aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2010-07-03 03:16:43 +0800
committerarved <arved@FreeBSD.org>2010-07-03 03:16:43 +0800
commit8507f234a70a28e57c291935b17f30d08084e54c (patch)
tree906fef0bb3d27d8f94e3535cb30b6cbdb6a444e8
parentd39d5260bd61080fabd64f1e81031f24ca71a91e (diff)
downloadfreebsd-ports-gnome-8507f234a70a28e57c291935b17f30d08084e54c.tar.gz
freebsd-ports-gnome-8507f234a70a28e57c291935b17f30d08084e54c.tar.zst
freebsd-ports-gnome-8507f234a70a28e57c291935b17f30d08084e54c.zip
Fix build after scandir prototype change
Feature safe: yes
-rw-r--r--audio/terminatorx/Makefile8
-rw-r--r--audio/terminatorx/files/patch-src::tX_dialog.cc11
2 files changed, 4 insertions, 15 deletions
diff --git a/audio/terminatorx/Makefile b/audio/terminatorx/Makefile
index 7cb6001cc6e4..5a4e2e310744 100644
--- a/audio/terminatorx/Makefile
+++ b/audio/terminatorx/Makefile
@@ -43,10 +43,6 @@ OPTIONS= MPG123 "mpg123 support" on \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 800501
-BROKEN= does not build
-.endif
-
.if !defined(WITHOUT_MPG123)
BUILD_DEPENDS+= mpg123:${PORTSDIR}/audio/mpg123
.else
@@ -77,6 +73,10 @@ post-patch:
's|malloc\.h|stdlib.h|g'
@${GREP} -lR "%%LOCALBASE%%" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
's|%%LOCALBASE%%|${LOCALBASE}|g'
+.if ${OSVERSION} <= 800501
+ ${REINPLACE_CMD} -e "s,only(struct dirent,only(const struct dirent," \
+ ${WRKSRC}/src/tX_dialog.cc
+.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/terminatorX ${PREFIX}/bin
diff --git a/audio/terminatorx/files/patch-src::tX_dialog.cc b/audio/terminatorx/files/patch-src::tX_dialog.cc
deleted file mode 100644
index 580957977068..000000000000
--- a/audio/terminatorx/files/patch-src::tX_dialog.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/tX_dialog.cc.orig Thu Jun 5 14:08:16 2003
-+++ src/tX_dialog.cc Thu Jun 5 14:08:40 2003
-@@ -184,7 +184,7 @@
- #ifdef USE_OSS
- static GList *oss_devices=NULL;
-
--int oss_select_dsp_only(const struct dirent *entry){
-+int oss_select_dsp_only(struct dirent *entry){
- return (strstr(entry->d_name, "dsp")!=0);
- }
-