aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorchinsan <chinsan@FreeBSD.org>2008-01-26 16:48:58 +0800
committerchinsan <chinsan@FreeBSD.org>2008-01-26 16:48:58 +0800
commit852beda794712174815e2b1f1c553c0f053c3b7a (patch)
treec84cd8f60b53942ad905f59c5fa9542d5f1e7116
parent9224c4698270197a78d4673e8f0e84038ce61c4a (diff)
downloadfreebsd-ports-gnome-852beda794712174815e2b1f1c553c0f053c3b7a.tar.gz
freebsd-ports-gnome-852beda794712174815e2b1f1c553c0f053c3b7a.tar.zst
freebsd-ports-gnome-852beda794712174815e2b1f1c553c0f053c3b7a.zip
paexec -- Parallel executor, distributes tasks over network.
paexec distributes performing the given tasks across several CPUs or machines on a network and collects the results from those CPUs/machines WWW: http://sourceforge.net/projects/paexec
-rw-r--r--devel/Makefile1
-rw-r--r--devel/paexec/Makefile44
-rw-r--r--devel/paexec/distinfo3
-rw-r--r--devel/paexec/pkg-descr5
-rw-r--r--devel/paexec/pkg-plist18
5 files changed, 71 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 5bd8db13b133..0527aaf8d52a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1736,6 +1736,7 @@
SUBDIR += p5-usb
SUBDIR += p5-version
SUBDIR += p65
+ SUBDIR += paexec
SUBDIR += papi
SUBDIR += pas2dox
SUBDIR += patch
diff --git a/devel/paexec/Makefile b/devel/paexec/Makefile
new file mode 100644
index 000000000000..68b6c77ab282
--- /dev/null
+++ b/devel/paexec/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: paexec
+# Date created: 2008/01/26
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= paexec
+PORTVERSION= 0.6.0
+CATEGORIES= devel
+MASTER_SITES= SF
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= Parallel executor, distributes tasks over network
+
+LIB_DEPENDS= maa:${PORTSDIR}/devel/libmaa
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+DOCS= ChangeLog NEWS README
+MAN1= paexec.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,2048,4096,; s,x.y.z,${PORTVERSION},' \
+ ${WRKSRC}/paexec.c
+
+do-build:
+ @cd ${WRKSRC} && ${CC} ${CFLAGS} ${LDFLAGS} \
+ *.c -o ${PORTNAME} -lmaa
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/paexec ${DESTDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/paexec.1 ${MAN1PREFIX}/man/man1
+ @${MKDIR} ${EXAMPLESDIR}
+ @${CP} -R ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/paexec/distinfo b/devel/paexec/distinfo
new file mode 100644
index 000000000000..c014e123c04e
--- /dev/null
+++ b/devel/paexec/distinfo
@@ -0,0 +1,3 @@
+MD5 (paexec-0.6.0.tar.gz) = d6e9bf5f06eb13591098a5d77339abd2
+SHA256 (paexec-0.6.0.tar.gz) = 41d7d5e6ea63176749d9dbcf8814651c81e8f267de3111c5c4ea214cbad0d50c
+SIZE (paexec-0.6.0.tar.gz) = 16804
diff --git a/devel/paexec/pkg-descr b/devel/paexec/pkg-descr
new file mode 100644
index 000000000000..510275220847
--- /dev/null
+++ b/devel/paexec/pkg-descr
@@ -0,0 +1,5 @@
+paexec distributes performing the given tasks across several CPUs or
+machines on a network and collects the results from those
+CPUs/machines
+
+WWW: http://sourceforge.net/projects/paexec
diff --git a/devel/paexec/pkg-plist b/devel/paexec/pkg-plist
new file mode 100644
index 000000000000..8a082d266bf4
--- /dev/null
+++ b/devel/paexec/pkg-plist
@@ -0,0 +1,18 @@
+bin/paexec
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%EXAMPLESDIR%%/toupper/toupper_cmd
+%%EXAMPLESDIR%%/toupper/toupper_run
+%%EXAMPLESDIR%%/cc_wrapper/cc_wrapper_cmd
+%%EXAMPLESDIR%%/cc_wrapper/cc_wrapper_run
+%%EXAMPLESDIR%%/cc_wrapper/func1.c
+%%EXAMPLESDIR%%/cc_wrapper/func2.c
+%%EXAMPLESDIR%%/cc_wrapper/func3.c
+%%EXAMPLESDIR%%/all_substr/all_substr_cmd
+%%EXAMPLESDIR%%/all_substr/all_substr_run
+@dirrm %%EXAMPLESDIR%%/all_substr
+@dirrm %%EXAMPLESDIR%%/cc_wrapper
+@dirrm %%EXAMPLESDIR%%/toupper
+@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%