aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2015-04-14 19:58:42 +0800
committerkwm <kwm@FreeBSD.org>2015-04-14 19:58:42 +0800
commit85817cae89033702a099e319048e88f672b4b772 (patch)
tree6d15d8e5673f01c92b62897517646373426ad7b4
parenta300f27d5c3d1530892640ae3f193e00a559f086 (diff)
downloadfreebsd-ports-gnome-85817cae89033702a099e319048e88f672b4b772.tar.gz
freebsd-ports-gnome-85817cae89033702a099e319048e88f672b4b772.tar.zst
freebsd-ports-gnome-85817cae89033702a099e319048e88f672b4b772.zip
Fix some glib schema issues.
The schemas should be listed in GLIB_SCHEMAS instead of in the plist so the glib schema database can be updated on installed/removal of the package. This updating is done by the GLIB_SCHEMAS macro. Make shotwell not run glib-compile-schemas in the stagedir, this has no effect. Additional this generates the share/glib-2.0/schemas/gschemas.compiled file. This file is managed by the glib20 port. And has a changing checksum because it recompiled every time a GLIB_SCHEMAS enabled port is installed or removed.
-rw-r--r--audio/goobox/Makefile4
-rw-r--r--audio/goobox/pkg-plist1
-rw-r--r--deskutils/caja-extensions/Makefile5
-rw-r--r--deskutils/caja-extensions/pkg-plist2
-rw-r--r--games/hitori/Makefile3
-rw-r--r--games/hitori/pkg-plist1
-rw-r--r--graphics/shotwell/Makefile1
-rw-r--r--graphics/shotwell/files/patch-Makefile12
-rw-r--r--graphics/shotwell/pkg-plist1
-rw-r--r--www/gnome-user-share/Makefile3
-rw-r--r--www/gnome-user-share/pkg-plist1
-rw-r--r--x11-fm/sushi/Makefile3
-rw-r--r--x11-fm/sushi/pkg-plist1
13 files changed, 25 insertions, 13 deletions
diff --git a/audio/goobox/Makefile b/audio/goobox/Makefile
index 5e178be1c47c..1815e60246ba 100644
--- a/audio/goobox/Makefile
+++ b/audio/goobox/Makefile
@@ -4,7 +4,7 @@
PORTNAME= goobox
PORTVERSION= 3.3.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -29,6 +29,8 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
+GLIB_SCHEMAS= org.gnome.Goobox.gschema.xml
+
OPTIONS_DEFINE= NOTIFY
OPTIONS_DEFAULT=NOTIFY
diff --git a/audio/goobox/pkg-plist b/audio/goobox/pkg-plist
index 918aed40fb7c..42b4ae0fe9f8 100644
--- a/audio/goobox/pkg-plist
+++ b/audio/goobox/pkg-plist
@@ -2,7 +2,6 @@ bin/goobox
share/GConf/gsettings/goobox.convert
share/appdata/goobox.appdata.xml
share/applications/goobox.desktop
-share/glib-2.0/schemas/org.gnome.Goobox.gschema.xml
share/help/C/goobox/index.page
share/help/C/goobox/legal.xml
share/help/C/goobox/preferences.page
diff --git a/deskutils/caja-extensions/Makefile b/deskutils/caja-extensions/Makefile
index 50c16d8c26a5..11b9cdc93d22 100644
--- a/deskutils/caja-extensions/Makefile
+++ b/deskutils/caja-extensions/Makefile
@@ -3,7 +3,7 @@
PORTNAME= caja-extensions
PORTVERSION= 1.8.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils mate
MASTER_SITES= MATE
DIST_SUBDIR= mate
@@ -24,4 +24,7 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
+GLIB_SCHEMAS= org.mate.Caja.Sendto.gschema.xml \
+ org.mate.caja-open-terminal.gschema.xml
+
.include <bsd.port.mk>
diff --git a/deskutils/caja-extensions/pkg-plist b/deskutils/caja-extensions/pkg-plist
index fa7b114e7f37..5fe6787f8187 100644
--- a/deskutils/caja-extensions/pkg-plist
+++ b/deskutils/caja-extensions/pkg-plist
@@ -19,8 +19,6 @@ share/MateConf/gsettings/caja-sendto-convert
%%DATADIR%%/caja-image-rotate.ui
%%DATADIR%%/caja-sendto.ui
%%DATADIR%%/share-dialog.ui
-share/glib-2.0/schemas/org.mate.Caja.Sendto.gschema.xml
-share/glib-2.0/schemas/org.mate.caja-open-terminal.gschema.xml
share/gtk-doc/html/caja-sendto/api-index-full.html
share/gtk-doc/html/caja-sendto/caja-sendto-caja-sendto-plugin.html
share/gtk-doc/html/caja-sendto/caja-sendto.devhelp2
diff --git a/games/hitori/Makefile b/games/hitori/Makefile
index cded5929413c..fcd526bcde6e 100644
--- a/games/hitori/Makefile
+++ b/games/hitori/Makefile
@@ -4,6 +4,7 @@
PORTNAME= hitori
PORTVERSION= 3.14.3
+PORTREVISION= 1
CATEGORIES= games gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -20,4 +21,6 @@ GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+GLIB_SCHEMAS= org.gnome.hitori.gschema.xml
+
.include <bsd.port.mk>
diff --git a/games/hitori/pkg-plist b/games/hitori/pkg-plist
index 21be6bdf735e..6e2ecc17a029 100644
--- a/games/hitori/pkg-plist
+++ b/games/hitori/pkg-plist
@@ -1,7 +1,6 @@
bin/hitori
share/appdata/hitori.appdata.xml
share/applications/hitori.desktop
-share/glib-2.0/schemas/org.gnome.hitori.gschema.xml
share/help/C/hitori/customization.page
share/help/C/hitori/figures/hitori_main_window.png
share/help/C/hitori/game.page
diff --git a/graphics/shotwell/Makefile b/graphics/shotwell/Makefile
index 420fce235cc4..431c5e4f989b 100644
--- a/graphics/shotwell/Makefile
+++ b/graphics/shotwell/Makefile
@@ -3,6 +3,7 @@
PORTNAME= shotwell
PORTVERSION= 0.22.0
+PORTREVISION= 1
CATEGORIES= graphics gnome
MASTER_SITES= GNOME/sources/shotwell/${PORTVERSION:R}
diff --git a/graphics/shotwell/files/patch-Makefile b/graphics/shotwell/files/patch-Makefile
index 73e949120629..c461aba0cfdd 100644
--- a/graphics/shotwell/files/patch-Makefile
+++ b/graphics/shotwell/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig 2015-03-28 15:11:25.000000000 +0100
-+++ Makefile 2015-03-28 15:14:57.000000000 +0100
+--- Makefile.orig 2015-03-24 01:38:31.000000000 +0100
++++ Makefile 2015-04-14 13:06:36.396704000 +0200
@@ -13,7 +13,7 @@
VALAC := $(shell which $(VALAC))
endif
@@ -25,8 +25,12 @@
libexif >= 0.6.16 \
libgphoto2 >= 2.4.2 \
libraw >= 0.13.2 \
-@@ -544,8 +542,8 @@
- glib-compile-schemas $(DESTDIR)$(PREFIX)/share/glib-2.0/schemas
+@@ -541,11 +539,11 @@
+ $(INSTALL_DATA) misc/org.yorba.shotwell.gschema.xml $(DESTDIR)$(PREFIX)/share/glib-2.0/schemas
+ $(INSTALL_DATA) misc/org.yorba.shotwell-extras.gschema.xml $(DESTDIR)$(PREFIX)/share/glib-2.0/schemas
+ ifndef DISABLE_SCHEMAS_COMPILE
+- glib-compile-schemas $(DESTDIR)$(PREFIX)/share/glib-2.0/schemas
++# glib-compile-schemas $(DESTDIR)$(PREFIX)/share/glib-2.0/schemas
endif
ifndef DISABLE_GSETTINGS_CONVERT_INSTALL
- mkdir -p $(DESTDIR)/usr/share/GConf/gsettings
diff --git a/graphics/shotwell/pkg-plist b/graphics/shotwell/pkg-plist
index 0b6e9d2ad090..eca9cb3e682b 100644
--- a/graphics/shotwell/pkg-plist
+++ b/graphics/shotwell/pkg-plist
@@ -33,7 +33,6 @@ share/GConf/gsettings/shotwell.convert
share/appdata/shotwell.appdata.xml
share/applications/shotwell-viewer.desktop
share/applications/shotwell.desktop
-share/glib-2.0/schemas/gschemas.compiled
share/gnome/help/shotwell/C/edit-adjustments.page
share/gnome/help/shotwell/C/edit-crop.page
share/gnome/help/shotwell/C/edit-enhance.page
diff --git a/www/gnome-user-share/Makefile b/www/gnome-user-share/Makefile
index a7572979add2..001e1e1e59f3 100644
--- a/www/gnome-user-share/Makefile
+++ b/www/gnome-user-share/Makefile
@@ -4,6 +4,7 @@
PORTNAME= gnome-user-share
PORTVERSION= 3.14.0
+PORTREVISION= 1
CATEGORIES= www deskutils gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -31,6 +32,8 @@ CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
+GLIB_SCHEMAS= org.gnome.desktop.file-sharing.gschema.xml
+
post-patch:
@${REINPLACE_CMD} -e 's|/etc/httpd/modules|${LOCALBASE}/${APACHEMODDIR}|g' \
${WRKSRC}/data/dav_user_*.conf
diff --git a/www/gnome-user-share/pkg-plist b/www/gnome-user-share/pkg-plist
index 5daf279d3f8d..ccfc16a02c46 100644
--- a/www/gnome-user-share/pkg-plist
+++ b/www/gnome-user-share/pkg-plist
@@ -3,7 +3,6 @@ libexec/gnome-user-share-webdav
lib/nautilus/extensions-3.0/libnautilus-share-extension.so
share/GConf/gsettings/gnome-user-share.convert
share/applications/gnome-user-share-webdav.desktop
-share/glib-2.0/schemas/org.gnome.desktop.file-sharing.gschema.xml
share/gnome-user-share/dav_groupfile
share/gnome-user-share/dav_user_2.0.conf
share/gnome-user-share/dav_user_2.2.conf
diff --git a/x11-fm/sushi/Makefile b/x11-fm/sushi/Makefile
index 76dcc5b75b66..8a641d33fc77 100644
--- a/x11-fm/sushi/Makefile
+++ b/x11-fm/sushi/Makefile
@@ -4,6 +4,7 @@
PORTNAME= sushi
PORTVERSION= 3.12.0
+PORTREVISION= 1
CATEGORIES= x11-fm gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -29,4 +30,6 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
+GLIB_SCHEMAS= org.gnome.sushi.gschema.xml
+
.include <bsd.port.mk>
diff --git a/x11-fm/sushi/pkg-plist b/x11-fm/sushi/pkg-plist
index d372db411841..a2008dab1017 100644
--- a/x11-fm/sushi/pkg-plist
+++ b/x11-fm/sushi/pkg-plist
@@ -3,7 +3,6 @@ lib/sushi/girepository-1.0/Sushi-1.0.typelib
lib/sushi/libsushi-1.0.so
libexec/sushi-start
share/dbus-1/services/org.gnome.Sushi.service
-share/glib-2.0/schemas/org.gnome.sushi.gschema.xml
share/locale/an/LC_MESSAGES/sushi.mo
share/locale/ar/LC_MESSAGES/sushi.mo
share/locale/as/LC_MESSAGES/sushi.mo