aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormharo <mharo@FreeBSD.org>2001-04-06 09:37:57 +0800
committermharo <mharo@FreeBSD.org>2001-04-06 09:37:57 +0800
commit86112b42bbfd1aaadd04f5f0ecd6d5a7bd41de94 (patch)
tree8b160b7ddba1c4efe4eb2b4efb1f69ea60d53f74
parentc3e9614ca616ac7d8f97456c4ffcdbb3034d93f6 (diff)
downloadfreebsd-ports-gnome-86112b42bbfd1aaadd04f5f0ecd6d5a7bd41de94.tar.gz
freebsd-ports-gnome-86112b42bbfd1aaadd04f5f0ecd6d5a7bd41de94.tar.zst
freebsd-ports-gnome-86112b42bbfd1aaadd04f5f0ecd6d5a7bd41de94.zip
Update devel/commoncpp to 1.4.1
Update lang/ccscript to 1.4.1 PR: 26370 Submitted by: maintainer
-rw-r--r--devel/commoncpp/Makefile26
-rw-r--r--devel/commoncpp/distinfo2
-rw-r--r--devel/commoncpp/pkg-descr4
-rw-r--r--devel/commoncpp/pkg-plist486
-rw-r--r--lang/ccscript/Makefile19
-rw-r--r--lang/ccscript/distinfo2
-rw-r--r--lang/ccscript/pkg-plist52
7 files changed, 414 insertions, 177 deletions
diff --git a/devel/commoncpp/Makefile b/devel/commoncpp/Makefile
index edfed2aadb1d..12eb3c50ace8 100644
--- a/devel/commoncpp/Makefile
+++ b/devel/commoncpp/Makefile
@@ -4,31 +4,39 @@
#
# $FreeBSD$
#
+# Copyright (c) 1999-2001 by Open Source Telecom Corporation.
+# Verbatim copying and distribution of this entire file is permitted
+# in any medium, provided this notice is preserved.
PORTNAME= CommonC++
-PORTVERSION= 1.2.5.1
+PORTVERSION= 1.4.1
CATEGORIES= devel
-MASTER_SITES= ftp://www.voxilla.org/pub/ape/ \
+MASTER_SITES= ftp://www.voxilla.org/pub/freebsd/tarball/ \
${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= cplusplus
MAINTAINER= dyfet@gnu.org
+LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
+ xml2.5:${PORTSDIR}/textproc/libxml2
+
USE_GMAKE= yes
USE_LIBTOOL= yes
+USE_AUTOCONF= yes
INSTALLS_SHLIB= yes
-pre-patch:
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|-release \$$\(LT_RELEASE\)||g'
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|l\$$ost_cv_thread_library|\$$ost_cv_thread_library|g ; \
- s|=c_r|=pthread|g' ${WRKSRC}/configure
+CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
+
+#post-extract:
+# cd ${WRKSRC} ; ./configure
+# @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+# 's|-release \$$\(LT_RELEASE\)||g'
post-install:
+ (cd ${WRKSRC} ; make man)
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/commoncpp
- ${INSTALL_MAN} ${WRKSRC}/doc/*.html ${PREFIX}/share/doc/commoncpp
+ ${INSTALL_MAN} ${WRKSRC}/doc/html/* ${PREFIX}/share/doc/commoncpp
.endif
.include <bsd.port.mk>
diff --git a/devel/commoncpp/distinfo b/devel/commoncpp/distinfo
index 4849f5b168ac..d56d958ba6e6 100644
--- a/devel/commoncpp/distinfo
+++ b/devel/commoncpp/distinfo
@@ -1 +1 @@
-MD5 (CommonC++-1.2.5.1.tar.gz) = 2c5774ce4aa50deb0ea66d64d665e4cd
+MD5 (CommonC++-1.4.1.tar.gz) = 0896ecda3a3f027b917c04644f30973c
diff --git a/devel/commoncpp/pkg-descr b/devel/commoncpp/pkg-descr
index e4b591b85c2f..d94b34ce119f 100644
--- a/devel/commoncpp/pkg-descr
+++ b/devel/commoncpp/pkg-descr
@@ -1,6 +1,6 @@
Common C++ offers a portable highly portable C++ application development
-framework. Common C++ provides classes for threads, sockets, daemon
-management, system logging, object synchronization, realtime network
+framework. Common C++ provides classes for threads, sockets, daemon
+management, system logging, object synchronization, realtime network
development, persistant object management, and file access.
WWW: http://cplusplus.sourceforge.net/
diff --git a/devel/commoncpp/pkg-plist b/devel/commoncpp/pkg-plist
index 4ddb7d99af3b..b414001aaa76 100644
--- a/devel/commoncpp/pkg-plist
+++ b/devel/commoncpp/pkg-plist
@@ -1,5 +1,7 @@
+include/cc++/cmdoptns.h
include/cc++/config.def
include/cc++/config.h
+include/cc++/digest.h
include/cc++/file.h
include/cc++/html.h
include/cc++/macros.h
@@ -10,173 +12,345 @@ include/cc++/serial.h
include/cc++/slog.h
include/cc++/socket.h
include/cc++/thread.h
+include/cc++/url.h
+include/cc++/xml.h
lib/libccio.a
lib/libccio.so
-lib/libccio.so.0
+lib/libccio-1.4.so.0
lib/libccstd.a
lib/libccstd.so
-lib/libccstd.so.0
+lib/libccstd-1.4.so.0
lib/libccxx.a
lib/libccxx.so
-lib/libccxx.so.0
-share/doc/commoncpp/AtomicCounter.html
-share/doc/commoncpp/BaseObject.html
-share/doc/commoncpp/Body.html
-share/doc/commoncpp/BroadcastAddress.html
-share/doc/commoncpp/Buffer.html
-share/doc/commoncpp/DSO.html
-share/doc/commoncpp/Dir.html
-share/doc/commoncpp/Engine.html
-share/doc/commoncpp/Engine::Exception.html
-share/doc/commoncpp/Entity.html
-share/doc/commoncpp/Event.html
-share/doc/commoncpp/FIFOSession.html
-share/doc/commoncpp/File.html
-share/doc/commoncpp/FixedBuffer.html
-share/doc/commoncpp/Frameset.html
-share/doc/commoncpp/HTMLDocument.html
-share/doc/commoncpp/Head.html
-share/doc/commoncpp/InetAddress.html
-share/doc/commoncpp/InetHostAddress.html
-share/doc/commoncpp/InetMaskAddress.html
-share/doc/commoncpp/Keydata.html
-share/doc/commoncpp/LockedFile.html
-share/doc/commoncpp/MappedFile.html
-share/doc/commoncpp/MemPager.html
-share/doc/commoncpp/Mutex.html
-share/doc/commoncpp/MutexCounter.html
-share/doc/commoncpp/NamedPipe.html
-share/doc/commoncpp/NewFile.html
-share/doc/commoncpp/PersistException.html
-share/doc/commoncpp/Pipe.html
-share/doc/commoncpp/Poller.html
-share/doc/commoncpp/RandomFile.html
-share/doc/commoncpp/ScriptCommand.html
-share/doc/commoncpp/ScriptImage.html
-share/doc/commoncpp/ScriptInterp.html
-share/doc/commoncpp/ScriptSymbol.html
-share/doc/commoncpp/Semaphore.html
-share/doc/commoncpp/Serial.html
-share/doc/commoncpp/SerialPort.html
-share/doc/commoncpp/SerialService.html
-share/doc/commoncpp/SharedFile.html
-share/doc/commoncpp/SharedMemPager.html
-share/doc/commoncpp/Slog.html
-share/doc/commoncpp/Socket.html
-share/doc/commoncpp/SocketPort.html
-share/doc/commoncpp/SocketService.html
-share/doc/commoncpp/StringTokenizer.html
-share/doc/commoncpp/StringTokenizer::NoSuchElementException.html
-share/doc/commoncpp/TCPSession.html
-share/doc/commoncpp/TCPSocket.html
-share/doc/commoncpp/TCPStream.html
-share/doc/commoncpp/TTYSession.html
-share/doc/commoncpp/TTYStream.html
-share/doc/commoncpp/Thread.html
-share/doc/commoncpp/ThreadFile.html
-share/doc/commoncpp/ThreadKey.html
-share/doc/commoncpp/ThreadLock.html
-share/doc/commoncpp/TimerPort.html
-share/doc/commoncpp/TypeManager.html
-share/doc/commoncpp/TypeManager::Registration.html
-share/doc/commoncpp/UDPBroadcast.html
-share/doc/commoncpp/UDPDuplex.html
-share/doc/commoncpp/UDPReceive.html
-share/doc/commoncpp/UDPSocket.html
-share/doc/commoncpp/UDPTransmit.html
-share/doc/commoncpp/Vector2D.html
-share/doc/commoncpp/Writer.html
-share/doc/commoncpp/__EXPORT.html
-share/doc/commoncpp/__________extras___math___math_h.html
-share/doc/commoncpp/__________extras___script___script_h.html
-share/doc/commoncpp/_____common___html_h.html
-share/doc/commoncpp/_____common___math_h.html
-share/doc/commoncpp/_____common___misc_h.html
-share/doc/commoncpp/_____common___persist_h.html
-share/doc/commoncpp/_____common___script_h.html
-share/doc/commoncpp/all-globals.html
-share/doc/commoncpp/fifostream.html
+lib/libccxx-1.4.so.0
+bin/ccgnu-config
+man/man3/AtomicCounter.3cc
+man/man3/BaseObject.3cc
+man/man3/Body.3cc
+man/man3/BroadcastAddress.3cc
+man/man3/Buffer.3cc
+man/man3/CRC16Digest.3cc
+man/man3/ChecksumDigest.3cc
+man/man3/CommandOption.3cc
+man/man3/CommandOptionArg.3cc
+man/man3/CommandOptionCollect.3cc
+man/man3/CommandOptionNoArg.3cc
+man/man3/CommandOptionParse.3cc
+man/man3/CommandOptionRest.3cc
+man/man3/CommandOptionWithArg.3cc
+man/man3/DSO.3cc
+man/man3/Digest.3cc
+man/man3/Dir.3cc
+man/man3/Engine.3cc
+man/man3/Engine__Exception.3cc
+man/man3/Entity.3cc
+man/man3/Event.3cc
+man/man3/FIFOSession.3cc
+man/man3/FixedBuffer.3cc
+man/man3/Frameset.3cc
+man/man3/HTMLDocument.3cc
+man/man3/Head.3cc
+man/man3/InetAddress.3cc
+man/man3/InetHostAddress.3cc
+man/man3/InetMaskAddress.3cc
+man/man3/Keydata.3cc
+man/man3/MappedFile.3cc
+man/man3/MemPager.3cc
+man/man3/Mutex.3cc
+man/man3/MutexCounter.3cc
+man/man3/Pipe.3cc
+man/man3/Poller.3cc
+man/man3/RandomFile.3cc
+man/man3/Semaphore.3cc
+man/man3/Serial.3cc
+man/man3/SerialPort.3cc
+man/man3/SerialService.3cc
+man/man3/SharedFile.3cc
+man/man3/SharedMemPager.3cc
+man/man3/Slog.3cc
+man/man3/Socket.3cc
+man/man3/SocketPort.3cc
+man/man3/SocketService.3cc
+man/man3/StringTokenizer.3cc
+man/man3/StringTokenizer__NoSuchElementException.3cc
+man/man3/StringTokenizer__iterator.3cc
+man/man3/TCPSession.3cc
+man/man3/TCPSocket.3cc
+man/man3/TCPStream.3cc
+man/man3/TTYSession.3cc
+man/man3/TTYStream.3cc
+man/man3/Thread.3cc
+man/man3/ThreadFile.3cc
+man/man3/ThreadKey.3cc
+man/man3/ThreadLock.3cc
+man/man3/TimerPort.3cc
+man/man3/TypeManager.3cc
+man/man3/TypeManager__Registration.3cc
+man/man3/UDPBroadcast.3cc
+man/man3/UDPDuplex.3cc
+man/man3/UDPReceive.3cc
+man/man3/UDPSocket.3cc
+man/man3/UDPTransmit.3cc
+man/man3/URLStream.3cc
+man/man3/Writer.3cc
+man/man3/XMLStream.3cc
+man/man3/fifostream.3cc
+man/man3/init_WSA.3cc
+man/man3/tcpstream.3cc
+man/man3/ttystream.3cc
+share/doc/commoncpp/annotated.html
+share/doc/commoncpp/class__fcb-members.html
+share/doc/commoncpp/class__fcb.html
+share/doc/commoncpp/class__keysym-members.html
+share/doc/commoncpp/class__keysym.html
+share/doc/commoncpp/class__keyval-members.html
+share/doc/commoncpp/class__keyval.html
+share/doc/commoncpp/class_atomiccounter-members.html
+share/doc/commoncpp/class_atomiccounter.html
+share/doc/commoncpp/class_baseobject-members.html
+share/doc/commoncpp/class_baseobject.gif
+share/doc/commoncpp/class_baseobject.html
+share/doc/commoncpp/class_body-members.html
+share/doc/commoncpp/class_body.gif
+share/doc/commoncpp/class_body.html
+share/doc/commoncpp/class_broadcastaddress-members.html
+share/doc/commoncpp/class_broadcastaddress.gif
+share/doc/commoncpp/class_broadcastaddress.html
+share/doc/commoncpp/class_buffer-members.html
+share/doc/commoncpp/class_buffer.gif
+share/doc/commoncpp/class_buffer.html
+share/doc/commoncpp/class_checksumdigest-members.html
+share/doc/commoncpp/class_checksumdigest.gif
+share/doc/commoncpp/class_checksumdigest.html
+share/doc/commoncpp/class_commandoption-members.html
+share/doc/commoncpp/class_commandoption.gif
+share/doc/commoncpp/class_commandoption.html
+share/doc/commoncpp/class_commandoptionarg-members.html
+share/doc/commoncpp/class_commandoptionarg.gif
+share/doc/commoncpp/class_commandoptionarg.html
+share/doc/commoncpp/class_commandoptioncollect-members.html
+share/doc/commoncpp/class_commandoptioncollect.gif
+share/doc/commoncpp/class_commandoptioncollect.html
+share/doc/commoncpp/class_commandoptionnoarg-members.html
+share/doc/commoncpp/class_commandoptionnoarg.gif
+share/doc/commoncpp/class_commandoptionnoarg.html
+share/doc/commoncpp/class_commandoptionparse-members.html
+share/doc/commoncpp/class_commandoptionparse.html
+share/doc/commoncpp/class_commandoptionrest-members.html
+share/doc/commoncpp/class_commandoptionrest.gif
+share/doc/commoncpp/class_commandoptionrest.html
+share/doc/commoncpp/class_commandoptionwitharg-members.html
+share/doc/commoncpp/class_commandoptionwitharg.gif
+share/doc/commoncpp/class_commandoptionwitharg.html
+share/doc/commoncpp/class_crc16digest-members.html
+share/doc/commoncpp/class_crc16digest.gif
+share/doc/commoncpp/class_crc16digest.html
+share/doc/commoncpp/class_digest-members.html
+share/doc/commoncpp/class_digest.gif
+share/doc/commoncpp/class_digest.html
+share/doc/commoncpp/class_dir-members.html
+share/doc/commoncpp/class_dir.html
+share/doc/commoncpp/class_dso-members.html
+share/doc/commoncpp/class_dso.html
+share/doc/commoncpp/class_engine-members.html
+share/doc/commoncpp/class_engine.html
+share/doc/commoncpp/class_engine__exception-members.html
+share/doc/commoncpp/class_engine__exception.gif
+share/doc/commoncpp/class_engine__exception.html
+share/doc/commoncpp/class_entity-members.html
+share/doc/commoncpp/class_entity.gif
+share/doc/commoncpp/class_entity.html
+share/doc/commoncpp/class_event-members.html
+share/doc/commoncpp/class_event.gif
+share/doc/commoncpp/class_event.html
+share/doc/commoncpp/class_fifosession-members.html
+share/doc/commoncpp/class_fifosession.gif
+share/doc/commoncpp/class_fifosession.html
+share/doc/commoncpp/class_fifostream-members.html
+share/doc/commoncpp/class_fifostream.gif
+share/doc/commoncpp/class_fifostream.html
+share/doc/commoncpp/class_fixedbuffer-members.html
+share/doc/commoncpp/class_fixedbuffer.gif
+share/doc/commoncpp/class_fixedbuffer.html
+share/doc/commoncpp/class_frameset-members.html
+share/doc/commoncpp/class_frameset.gif
+share/doc/commoncpp/class_frameset.html
+share/doc/commoncpp/class_fstream.gif
+share/doc/commoncpp/class_fstream.html
+share/doc/commoncpp/class_head-members.html
+share/doc/commoncpp/class_head.gif
+share/doc/commoncpp/class_head.html
+share/doc/commoncpp/class_htmldocument-members.html
+share/doc/commoncpp/class_htmldocument.gif
+share/doc/commoncpp/class_htmldocument.html
+share/doc/commoncpp/class_inetaddress-members.html
+share/doc/commoncpp/class_inetaddress.gif
+share/doc/commoncpp/class_inetaddress.html
+share/doc/commoncpp/class_inethostaddress-members.html
+share/doc/commoncpp/class_inethostaddress.gif
+share/doc/commoncpp/class_inethostaddress.html
+share/doc/commoncpp/class_inetmaskaddress-members.html
+share/doc/commoncpp/class_inetmaskaddress.gif
+share/doc/commoncpp/class_inetmaskaddress.html
+share/doc/commoncpp/class_init_wsa-members.html
+share/doc/commoncpp/class_init_wsa.html
+share/doc/commoncpp/class_iostream.gif
+share/doc/commoncpp/class_iostream.html
+share/doc/commoncpp/class_keydata-members.html
+share/doc/commoncpp/class_keydata.gif
+share/doc/commoncpp/class_keydata.html
+share/doc/commoncpp/class_keydef-members.html
+share/doc/commoncpp/class_keydef.html
+share/doc/commoncpp/class_mappedfile-members.html
+share/doc/commoncpp/class_mappedfile.gif
+share/doc/commoncpp/class_mappedfile.html
+share/doc/commoncpp/class_mempager-members.html
+share/doc/commoncpp/class_mempager.gif
+share/doc/commoncpp/class_mempager.html
+share/doc/commoncpp/class_mutex-members.html
+share/doc/commoncpp/class_mutex.gif
+share/doc/commoncpp/class_mutex.html
+share/doc/commoncpp/class_mutexcounter-members.html
+share/doc/commoncpp/class_mutexcounter.gif
+share/doc/commoncpp/class_mutexcounter.html
+share/doc/commoncpp/class_ostream.gif
+share/doc/commoncpp/class_ostream.html
+share/doc/commoncpp/class_persistexception-members.html
+share/doc/commoncpp/class_persistexception.gif
+share/doc/commoncpp/class_persistexception.html
+share/doc/commoncpp/class_pipe-members.html
+share/doc/commoncpp/class_pipe.html
+share/doc/commoncpp/class_poller-members.html
+share/doc/commoncpp/class_poller.html
+share/doc/commoncpp/class_randomfile-members.html
+share/doc/commoncpp/class_randomfile.gif
+share/doc/commoncpp/class_randomfile.html
+share/doc/commoncpp/class_semaphore-members.html
+share/doc/commoncpp/class_semaphore.html
+share/doc/commoncpp/class_serial-members.html
+share/doc/commoncpp/class_serial.gif
+share/doc/commoncpp/class_serial.html
+share/doc/commoncpp/class_serialport-members.html
+share/doc/commoncpp/class_serialport.gif
+share/doc/commoncpp/class_serialport.html
+share/doc/commoncpp/class_serialservice-members.html
+share/doc/commoncpp/class_serialservice.gif
+share/doc/commoncpp/class_serialservice.html
+share/doc/commoncpp/class_sharedfile-members.html
+share/doc/commoncpp/class_sharedfile.gif
+share/doc/commoncpp/class_sharedfile.html
+share/doc/commoncpp/class_sharedmempager-members.html
+share/doc/commoncpp/class_sharedmempager.gif
+share/doc/commoncpp/class_sharedmempager.html
+share/doc/commoncpp/class_slog-members.html
+share/doc/commoncpp/class_slog.gif
+share/doc/commoncpp/class_slog.html
+share/doc/commoncpp/class_socket-members.html
+share/doc/commoncpp/class_socket.gif
+share/doc/commoncpp/class_socket.html
+share/doc/commoncpp/class_socketport-members.html
+share/doc/commoncpp/class_socketport.gif
+share/doc/commoncpp/class_socketport.html
+share/doc/commoncpp/class_socketservice-members.html
+share/doc/commoncpp/class_socketservice.gif
+share/doc/commoncpp/class_socketservice.html
+share/doc/commoncpp/class_streambuf.gif
+share/doc/commoncpp/class_streambuf.html
+share/doc/commoncpp/class_stringtokenizer-members.html
+share/doc/commoncpp/class_stringtokenizer.html
+share/doc/commoncpp/class_stringtokenizer__iterator-members.html
+share/doc/commoncpp/class_stringtokenizer__iterator.html
+share/doc/commoncpp/class_stringtokenizer__nosuchelementexception.html
+share/doc/commoncpp/class_tcpsession-members.html
+share/doc/commoncpp/class_tcpsession.gif
+share/doc/commoncpp/class_tcpsession.html
+share/doc/commoncpp/class_tcpsocket-members.html
+share/doc/commoncpp/class_tcpsocket.gif
+share/doc/commoncpp/class_tcpsocket.html
+share/doc/commoncpp/class_tcpstream-members.html
+share/doc/commoncpp/class_tcpstream.gif
+share/doc/commoncpp/class_tcpstream.html
+share/doc/commoncpp/class_thread-members.html
+share/doc/commoncpp/class_thread.gif
+share/doc/commoncpp/class_thread.html
+share/doc/commoncpp/class_threadfile-members.html
+share/doc/commoncpp/class_threadfile.gif
+share/doc/commoncpp/class_threadfile.html
+share/doc/commoncpp/class_threadkey-members.html
+share/doc/commoncpp/class_threadkey.html
+share/doc/commoncpp/class_threadlock-members.html
+share/doc/commoncpp/class_threadlock.html
+share/doc/commoncpp/class_timerport-members.html
+share/doc/commoncpp/class_timerport.gif
+share/doc/commoncpp/class_timerport.html
+share/doc/commoncpp/class_ttysession-members.html
+share/doc/commoncpp/class_ttysession.gif
+share/doc/commoncpp/class_ttysession.html
+share/doc/commoncpp/class_ttystream-members.html
+share/doc/commoncpp/class_ttystream.gif
+share/doc/commoncpp/class_ttystream.html
+share/doc/commoncpp/class_typemanager-members.html
+share/doc/commoncpp/class_typemanager.html
+share/doc/commoncpp/class_typemanager__registration-members.html
+share/doc/commoncpp/class_typemanager__registration.html
+share/doc/commoncpp/class_udpbroadcast-members.html
+share/doc/commoncpp/class_udpbroadcast.gif
+share/doc/commoncpp/class_udpbroadcast.html
+share/doc/commoncpp/class_udpduplex-members.html
+share/doc/commoncpp/class_udpduplex.gif
+share/doc/commoncpp/class_udpduplex.html
+share/doc/commoncpp/class_udpreceive-members.html
+share/doc/commoncpp/class_udpreceive.gif
+share/doc/commoncpp/class_udpreceive.html
+share/doc/commoncpp/class_udpsocket-members.html
+share/doc/commoncpp/class_udpsocket.gif
+share/doc/commoncpp/class_udpsocket.html
+share/doc/commoncpp/class_udptransmit-members.html
+share/doc/commoncpp/class_udptransmit.gif
+share/doc/commoncpp/class_udptransmit.html
+share/doc/commoncpp/class_urlstream-members.html
+share/doc/commoncpp/class_urlstream.gif
+share/doc/commoncpp/class_urlstream.html
+share/doc/commoncpp/class_writer-members.html
+share/doc/commoncpp/class_writer.html
+share/doc/commoncpp/class_xmlstream-members.html
+share/doc/commoncpp/class_xmlstream.html
+share/doc/commoncpp/classes.html
+share/doc/commoncpp/cmdoptns_h-source.html
+share/doc/commoncpp/cmdoptns_h.html
+share/doc/commoncpp/config_h.html
+share/doc/commoncpp/digest_h-source.html
+share/doc/commoncpp/digest_h.html
+share/doc/commoncpp/doxygen.css
+share/doc/commoncpp/doxygen.gif
+share/doc/commoncpp/export_h.html
+share/doc/commoncpp/file_h-source.html
share/doc/commoncpp/file_h.html
-share/doc/commoncpp/full-list-AtomicCounter.html
-share/doc/commoncpp/full-list-BaseObject.html
-share/doc/commoncpp/full-list-Body.html
-share/doc/commoncpp/full-list-BroadcastAddress.html
-share/doc/commoncpp/full-list-Buffer.html
-share/doc/commoncpp/full-list-DSO.html
-share/doc/commoncpp/full-list-Dir.html
-share/doc/commoncpp/full-list-Engine.html
-share/doc/commoncpp/full-list-Engine::Exception.html
-share/doc/commoncpp/full-list-Entity.html
-share/doc/commoncpp/full-list-Event.html
-share/doc/commoncpp/full-list-FIFOSession.html
-share/doc/commoncpp/full-list-File.html
-share/doc/commoncpp/full-list-FixedBuffer.html
-share/doc/commoncpp/full-list-Frameset.html
-share/doc/commoncpp/full-list-HTMLDocument.html
-share/doc/commoncpp/full-list-Head.html
-share/doc/commoncpp/full-list-InetAddress.html
-share/doc/commoncpp/full-list-InetHostAddress.html
-share/doc/commoncpp/full-list-InetMaskAddress.html
-share/doc/commoncpp/full-list-Keydata.html
-share/doc/commoncpp/full-list-LockedFile.html
-share/doc/commoncpp/full-list-MappedFile.html
-share/doc/commoncpp/full-list-MemPager.html
-share/doc/commoncpp/full-list-Mutex.html
-share/doc/commoncpp/full-list-MutexCounter.html
-share/doc/commoncpp/full-list-NamedPipe.html
-share/doc/commoncpp/full-list-NewFile.html
-share/doc/commoncpp/full-list-PersistException.html
-share/doc/commoncpp/full-list-Pipe.html
-share/doc/commoncpp/full-list-Poller.html
-share/doc/commoncpp/full-list-RandomFile.html
-share/doc/commoncpp/full-list-ScriptCommand.html
-share/doc/commoncpp/full-list-ScriptImage.html
-share/doc/commoncpp/full-list-ScriptInterp.html
-share/doc/commoncpp/full-list-ScriptSymbol.html
-share/doc/commoncpp/full-list-Semaphore.html
-share/doc/commoncpp/full-list-Serial.html
-share/doc/commoncpp/full-list-SerialPort.html
-share/doc/commoncpp/full-list-SerialService.html
-share/doc/commoncpp/full-list-SharedFile.html
-share/doc/commoncpp/full-list-SharedMemPager.html
-share/doc/commoncpp/full-list-Slog.html
-share/doc/commoncpp/full-list-Socket.html
-share/doc/commoncpp/full-list-SocketPort.html
-share/doc/commoncpp/full-list-SocketService.html
-share/doc/commoncpp/full-list-StringTokenizer.html
-share/doc/commoncpp/full-list-StringTokenizer::NoSuchElementException.html
-share/doc/commoncpp/full-list-TCPSession.html
-share/doc/commoncpp/full-list-TCPSocket.html
-share/doc/commoncpp/full-list-TCPStream.html
-share/doc/commoncpp/full-list-TTYSession.html
-share/doc/commoncpp/full-list-TTYStream.html
-share/doc/commoncpp/full-list-Thread.html
-share/doc/commoncpp/full-list-ThreadFile.html
-share/doc/commoncpp/full-list-ThreadKey.html
-share/doc/commoncpp/full-list-ThreadLock.html
-share/doc/commoncpp/full-list-TimerPort.html
-share/doc/commoncpp/full-list-TypeManager.html
-share/doc/commoncpp/full-list-TypeManager::Registration.html
-share/doc/commoncpp/full-list-UDPBroadcast.html
-share/doc/commoncpp/full-list-UDPDuplex.html
-share/doc/commoncpp/full-list-UDPReceive.html
-share/doc/commoncpp/full-list-UDPSocket.html
-share/doc/commoncpp/full-list-UDPTransmit.html
-share/doc/commoncpp/full-list-Vector2D.html
-share/doc/commoncpp/full-list-Writer.html
-share/doc/commoncpp/full-list-__EXPORT.html
-share/doc/commoncpp/full-list-fifostream.html
-share/doc/commoncpp/full-list-tcpstream.html
-share/doc/commoncpp/full-list-ttystream.html
-share/doc/commoncpp/header-list.html
-share/doc/commoncpp/hier.html
-share/doc/commoncpp/index-long.html
+share/doc/commoncpp/files.html
+share/doc/commoncpp/functions.html
+share/doc/commoncpp/globals.html
+share/doc/commoncpp/hierarchy.html
+share/doc/commoncpp/html_h-source.html
+share/doc/commoncpp/html_h.html
share/doc/commoncpp/index.html
+share/doc/commoncpp/macros_h.html
+share/doc/commoncpp/misc_h-source.html
+share/doc/commoncpp/misc_h.html
+share/doc/commoncpp/namespace_h.html
+share/doc/commoncpp/null.gif
+share/doc/commoncpp/persist_h-source.html
+share/doc/commoncpp/persist_h.html
+share/doc/commoncpp/serial_h-source.html
share/doc/commoncpp/serial_h.html
+share/doc/commoncpp/slog_h-source.html
share/doc/commoncpp/slog_h.html
+share/doc/commoncpp/socket_h-source.html
share/doc/commoncpp/socket_h.html
-share/doc/commoncpp/tcpstream.html
+share/doc/commoncpp/thread_h-source.html
share/doc/commoncpp/thread_h.html
-share/doc/commoncpp/ttystream.html
+share/doc/commoncpp/url_h-source.html
+share/doc/commoncpp/url_h.html
+share/doc/commoncpp/xml_h-source.html
+share/doc/commoncpp/xml_h.html
@dirrm include/cc++
@dirrm share/doc/commoncpp
diff --git a/lang/ccscript/Makefile b/lang/ccscript/Makefile
index 05be7aaa5d4c..55dc432b8a1a 100644
--- a/lang/ccscript/Makefile
+++ b/lang/ccscript/Makefile
@@ -6,13 +6,13 @@
#
PORTNAME= ccscript
-PORTVERSION= 1.2.5
+PORTVERSION= 1.4.1
CATEGORIES= lang
-MASTER_SITES= ftp://www.voxilla.org/pub/ccscript/
+MASTER_SITES= ftp://www.voxilla.org/pub/freebsd/tarball/
MAINTAINER= dyfet@gnu.org
-LIB_DEPENDS= ccstd.0:${PORTSDIR}/devel/commoncpp
+LIB_DEPENDS= ccstd-1.4.0:${PORTSDIR}/devel/commoncpp
USE_GMAKE= yes
USE_LIBTOOL= yes
@@ -21,8 +21,15 @@ INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
-post-extract:
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|-release \$$\(LT_RELEASE\)||g'
+#post-extract:
+# @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+# 's|-release \$$\(LT_RELEASE\)||g'
+
+post-install:
+ (cd ${WRKSRC} ; make man)
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/ccscript
+ ${INSTALL_MAN} ${WRKSRC}/doc/html/* ${PREFIX}/share/doc/ccscript
+.endif
.include <bsd.port.mk>
diff --git a/lang/ccscript/distinfo b/lang/ccscript/distinfo
index 81103c02f316..b6361344ef51 100644
--- a/lang/ccscript/distinfo
+++ b/lang/ccscript/distinfo
@@ -1 +1 @@
-MD5 (ccscript-1.2.5.tar.gz) = 01b5fe502bbcc000a23f84012b6eb4d3
+MD5 (ccscript-1.4.1.tar.gz) = 77d57ea791b0002bc16a971056e75272
diff --git a/lang/ccscript/pkg-plist b/lang/ccscript/pkg-plist
index cb202f7b1bdb..59d105870c4c 100644
--- a/lang/ccscript/pkg-plist
+++ b/lang/ccscript/pkg-plist
@@ -2,5 +2,53 @@ bin/ccscript
include/cc++/script.h
lib/libccscript.a
lib/libccscript.so
-lib/libccscript.so.0
-@dirrm include/cc++
+lib/libccscript-1.4.so.0
+man/man3/ScriptCommand.3cc
+man/man3/ScriptImage.3cc
+man/man3/ScriptInterp.3cc
+man/man3/ScriptLocks.3cc
+man/man3/ScriptSymbol.3cc
+share/doc/ccscript/annotated.html
+share/doc/ccscript/class__line-members.html
+share/doc/ccscript/class__line.html
+share/doc/ccscript/class__script-members.html
+share/doc/ccscript/class__script.html
+share/doc/ccscript/class__symbol-members.html
+share/doc/ccscript/class__symbol.html
+share/doc/ccscript/class_keydata.gif
+share/doc/ccscript/class_keydata.html
+share/doc/ccscript/class_mempager.gif
+share/doc/ccscript/class_mempager.html
+share/doc/ccscript/class_mutex.gif
+share/doc/ccscript/class_mutex.html
+share/doc/ccscript/class_scriptcommand-members.html
+share/doc/ccscript/class_scriptcommand.gif
+share/doc/ccscript/class_scriptcommand.html
+share/doc/ccscript/class_scriptimage-members.html
+share/doc/ccscript/class_scriptimage.gif
+share/doc/ccscript/class_scriptimage.html
+share/doc/ccscript/class_scriptinterp-members.html
+share/doc/ccscript/class_scriptinterp.gif
+share/doc/ccscript/class_scriptinterp.html
+share/doc/ccscript/class_scriptlocks-members.html
+share/doc/ccscript/class_scriptlocks.gif
+share/doc/ccscript/class_scriptlocks.html
+share/doc/ccscript/class_scriptsymbol-members.html
+share/doc/ccscript/class_scriptsymbol.gif
+share/doc/ccscript/class_scriptsymbol.html
+share/doc/ccscript/class_scrkeywords-members.html
+share/doc/ccscript/class_scrkeywords.html
+share/doc/ccscript/class_sharedmempager.gif
+share/doc/ccscript/class_sharedmempager.html
+share/doc/ccscript/classes.html
+share/doc/ccscript/config_h.html
+share/doc/ccscript/doxygen.css
+share/doc/ccscript/doxygen.gif
+share/doc/ccscript/files.html
+share/doc/ccscript/functions.html
+share/doc/ccscript/globals.html
+share/doc/ccscript/hierarchy.html
+share/doc/ccscript/index.html
+share/doc/ccscript/null.gif
+share/doc/ccscript/script_h-source.html
+share/doc/ccscript/script_h.html