aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2011-09-20 16:46:07 +0800
committerbapt <bapt@FreeBSD.org>2011-09-20 16:46:07 +0800
commit86670dca56d7c796ade3a88db928423103d18d39 (patch)
tree6967d4f5140f407d90a7b83315dc1aac671a486f
parenta03d31a9b21c3f1d10ea7d704f0b48712138167d (diff)
downloadfreebsd-ports-gnome-86670dca56d7c796ade3a88db928423103d18d39.tar.gz
freebsd-ports-gnome-86670dca56d7c796ade3a88db928423103d18d39.tar.zst
freebsd-ports-gnome-86670dca56d7c796ade3a88db928423103d18d39.zip
Role::Identifiable::HasIdent is an incredibly simple role. It adds
a required ident attribute that stores a simple string, meant to identify exceptions. Role::Identifiable::HasTags adds the ability for your class and its composed parts (roles, superclasses) as well as instances of it to contribute to a pool of tags describing each instance. WWW: http://search.cpan.org/dist/Role-Identifiable/ Submitted by: Geraud CONTINSOUZAS <geraud@gcu.info> (by private mail)
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Role-Identifiable/Makefile29
-rw-r--r--devel/p5-Role-Identifiable/distinfo2
-rw-r--r--devel/p5-Role-Identifiable/pkg-descr8
-rw-r--r--devel/p5-Role-Identifiable/pkg-plist7
5 files changed, 47 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 0c4cb20ce73c..e65943e2f3a5 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2220,6 +2220,7 @@
SUBDIR += p5-ResourcePool
SUBDIR += p5-Resources
SUBDIR += p5-Return-Value
+ SUBDIR += p5-Role-Identifiable
SUBDIR += p5-Rose-DateTime
SUBDIR += p5-Rose-Object
SUBDIR += p5-RunApp
diff --git a/devel/p5-Role-Identifiable/Makefile b/devel/p5-Role-Identifiable/Makefile
new file mode 100644
index 000000000000..e0ccaec4bc2b
--- /dev/null
+++ b/devel/p5-Role-Identifiable/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: devel/p5-Role-Identifiable
+# Date created: 2011-09-19
+# Whom: Geraud CONTINSOUZAS <geraud@gcu.info>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Role-Identifiable
+PORTVERSION= 0.005
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:RJBS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= geraud@gcu.info
+COMMENT= A thing with a list of tags
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+RUN_DEPENDS= p5-Moose>=0:${PORTSDIR}/devel/p5-Moose
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Role::Identifiable::HasIdent.3 \
+ Role::Identifiable::HasTags.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Role-Identifiable/distinfo b/devel/p5-Role-Identifiable/distinfo
new file mode 100644
index 000000000000..0793dcc19d52
--- /dev/null
+++ b/devel/p5-Role-Identifiable/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Role-Identifiable-0.005.tar.gz) = 86910b6052d50bc64d1613bc1274f2ae17d553bfc3f0247a3fe3f7bb2cdd3aee
+SIZE (Role-Identifiable-0.005.tar.gz) = 10602
diff --git a/devel/p5-Role-Identifiable/pkg-descr b/devel/p5-Role-Identifiable/pkg-descr
new file mode 100644
index 000000000000..9f34302f9ba6
--- /dev/null
+++ b/devel/p5-Role-Identifiable/pkg-descr
@@ -0,0 +1,8 @@
+Role::Identifiable::HasIdent is an incredibly simple role. It adds
+a required ident attribute that stores a simple string, meant to
+identify exceptions.
+Role::Identifiable::HasTags adds the ability for your class and its
+composed parts (roles, superclasses) as well as instances of it to
+contribute to a pool of tags describing each instance.
+
+WWW: http://search.cpan.org/dist/Role-Identifiable/
diff --git a/devel/p5-Role-Identifiable/pkg-plist b/devel/p5-Role-Identifiable/pkg-plist
new file mode 100644
index 000000000000..5f25558632f4
--- /dev/null
+++ b/devel/p5-Role-Identifiable/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Role/Identifiable/HasIdent.pm
+%%SITE_PERL%%/Role/Identifiable/HasTags.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Role/Identifiable/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Role/Identifiable
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Role
+@dirrmtry %%SITE_PERL%%/Role/Identifiable
+@dirrmtry %%SITE_PERL%%/Role