aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2009-01-13 09:22:32 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2009-01-13 09:22:32 +0800
commit882b568865ee738ec845f85323663418d291c555 (patch)
tree054eaa1adafb0996396acb62631bf0b7777c3827
parent24e154c6c7d91db42b4c63addbdbbf8cba00e801 (diff)
downloadfreebsd-ports-gnome-882b568865ee738ec845f85323663418d291c555.tar.gz
freebsd-ports-gnome-882b568865ee738ec845f85323663418d291c555.tar.zst
freebsd-ports-gnome-882b568865ee738ec845f85323663418d291c555.zip
- Fix build in the following situations:
- On i386 with unset CPUTYPE - On i386 without MMX support PR: 130396 Submitted by: Daniel Roethlisberger <daniel at roe dot ch>
-rw-r--r--math/msieve/Makefile1
-rw-r--r--math/msieve/files/patch-include_util.h21
2 files changed, 22 insertions, 0 deletions
diff --git a/math/msieve/Makefile b/math/msieve/Makefile
index 31df50a19378..f7be3a1239ad 100644
--- a/math/msieve/Makefile
+++ b/math/msieve/Makefile
@@ -7,6 +7,7 @@
PORTNAME= msieve
PORTVERSION= 1.38
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= http://www.boo.net/~jasonp/ \
http://mirror.roe.ch/dist/msieve/
diff --git a/math/msieve/files/patch-include_util.h b/math/msieve/files/patch-include_util.h
new file mode 100644
index 000000000000..6a00a59a81c2
--- /dev/null
+++ b/math/msieve/files/patch-include_util.h
@@ -0,0 +1,21 @@
+--- include/util.h.orig 2008-09-24 15:59:32.000000000 +0200
++++ include/util.h 2009-01-11 23:46:55.000000000 +0100
+@@ -202,8 +202,18 @@
+ the only CPU that doesn't have these instructions is
+ the classic Pentium */
+
++#if defined(CPU_GENERIC) || \
++ defined(CPU_PENTIUM2) || \
++ defined(CPU_ATHLON) || \
++ defined(CPU_PENTIUM3) || \
++ defined(CPU_ATHLON_XP) || \
++ defined(CPU_PENTIUM4) || \
++ defined(CPU_PENTIUM_M) || \
++ defined(CPU_CORE) || \
++ defined(CPU_OPTERON)
+ #define HAS_CMOV
+ #define HAS_MMX
++#endif
+
+ #if defined(CPU_GENERIC)
+ #define MANUAL_PREFETCH