aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2005-10-01 00:45:47 +0800
committerskv <skv@FreeBSD.org>2005-10-01 00:45:47 +0800
commit8966e1ec9584cda48e5d1849aaeba444174a2222 (patch)
tree466a20c5dc83b2f064d046dd76766f0ca1c8a938
parent247b461151f71cc0f94b5b1b4d86e687ecb23e9c (diff)
downloadfreebsd-ports-gnome-8966e1ec9584cda48e5d1849aaeba444174a2222.tar.gz
freebsd-ports-gnome-8966e1ec9584cda48e5d1849aaeba444174a2222.tar.zst
freebsd-ports-gnome-8966e1ec9584cda48e5d1849aaeba444174a2222.zip
Add p5-Data-Lazy 0.5, "lazy" variables.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Data-Lazy/Makefile22
-rw-r--r--devel/p5-Data-Lazy/distinfo2
-rw-r--r--devel/p5-Data-Lazy/pkg-descr5
-rw-r--r--devel/p5-Data-Lazy/pkg-plist5
5 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 7ec412d92a2a..2b2c1b4eea6e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -783,6 +783,7 @@
SUBDIR += p5-Data-HexDump
SUBDIR += p5-Data-Hexdumper
SUBDIR += p5-Data-Hierarchy
+ SUBDIR += p5-Data-Lazy
SUBDIR += p5-Data-Properties
SUBDIR += p5-Data-Random
SUBDIR += p5-Data-Serializer
diff --git a/devel/p5-Data-Lazy/Makefile b/devel/p5-Data-Lazy/Makefile
new file mode 100644
index 000000000000..934102a5ecec
--- /dev/null
+++ b/devel/p5-Data-Lazy/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: Data-Lazy
+# Date created: 30 September 2005
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-Lazy
+PORTVERSION= 0.5
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Data
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= "lazy" variables
+
+PERL_CONFIGURE= yes
+
+MAN3= Data::Lazy.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Data-Lazy/distinfo b/devel/p5-Data-Lazy/distinfo
new file mode 100644
index 000000000000..47ba3145090c
--- /dev/null
+++ b/devel/p5-Data-Lazy/distinfo
@@ -0,0 +1,2 @@
+MD5 (Data-Lazy-0.5.tar.gz) = acd14fd1ba6898f4caf741765bff4c6e
+SIZE (Data-Lazy-0.5.tar.gz) = 4057
diff --git a/devel/p5-Data-Lazy/pkg-descr b/devel/p5-Data-Lazy/pkg-descr
new file mode 100644
index 000000000000..26a7e126e219
--- /dev/null
+++ b/devel/p5-Data-Lazy/pkg-descr
@@ -0,0 +1,5 @@
+A very little module for simulating lazines in perl. It provides
+scalars that are "lazy", that is their value is computed only if
+necessary and at most once.
+
+WWW: http://search.cpan.org/dist/Data-Lazy/
diff --git a/devel/p5-Data-Lazy/pkg-plist b/devel/p5-Data-Lazy/pkg-plist
new file mode 100644
index 000000000000..0c946d762d90
--- /dev/null
+++ b/devel/p5-Data-Lazy/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Lazy/.packlist
+%%SITE_PERL%%/Data/Lazy.pm
+@unexec rmdir %D/%%SITE_PERL%%/Data 2>/dev/null || true
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Lazy
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data 2>/dev/null || true