aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsumikawa <sumikawa@FreeBSD.org>2012-11-12 11:03:03 +0800
committersumikawa <sumikawa@FreeBSD.org>2012-11-12 11:03:03 +0800
commit898c54e07bc78fc9e8a230afd44a58c934980dfe (patch)
tree95fd7c4e09fcf29003eba916cad7fc6eb88502d0
parent043a2c255725fd044847fc1c2693bb7337e05e9f (diff)
downloadfreebsd-ports-gnome-898c54e07bc78fc9e8a230afd44a58c934980dfe.tar.gz
freebsd-ports-gnome-898c54e07bc78fc9e8a230afd44a58c934980dfe.tar.zst
freebsd-ports-gnome-898c54e07bc78fc9e8a230afd44a58c934980dfe.zip
- Use arguments for different zebra services. Default is "-d"
- Update to use OPTIONSNG - Rename LIBPAM to PAM (shared description) - Drop my maintainership PR: ports/170678 Submitted by: jgh Feature safe: yes
-rw-r--r--net/zebra/Makefile60
-rw-r--r--net/zebra/files/zebractl.in12
2 files changed, 44 insertions, 28 deletions
diff --git a/net/zebra/Makefile b/net/zebra/Makefile
index 29eae6750cdf..414c136f095d 100644
--- a/net/zebra/Makefile
+++ b/net/zebra/Makefile
@@ -21,67 +21,83 @@ COMMENT= Free RIPv1, RIPv2, OSPFv2, BGP4 route software (server/reflector)
CONFLICTS= openbgpd-[0-9]* quagga-[0-9]* quagga-re-[0-9]* openospfd-[0-9]*
SUB_FILES= pkg-message zebractl
+SUB_LIST= BGPDARGS=${BGPDARGS} \
+ OSPFDARGS=${OSPFDARGS} \
+ OSPF6DARGS=${OSPFDARGS} \
+ RIPDARGS=${RIPDARGS} \
+ RIPNGDARGS=${RIPNGDARGS} \
+ ZEBRAARGS=${ZEBRAARGS}
USE_SUBMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --sysconfdir=${PREFIX}/etc/zebra
SCRIPTS_ENV= WRKDIRPREFIX=${WRKDIRPREFIX}
-OPTIONS= IPV6 "enable IPv6 support" on \
- LIBPAM "enable PAM authentication for vtysh" off \
- OSPFNSSA "turn on undergoing NSSA feature" off \
- SNMP "enable SNMP support" off \
- TCPZEBRA "enable TCP/IP socket connection" off \
- BGPD "enable BGPD" on \
- OSPF6D "enable OSPF6D" on \
- OSPFD "enable OSPFD" on \
- RIPD "enable RIPD" on \
- RIPNGD "enable RIPNGD" on \
- VTYSH "enable VTYSH" on
+OPTIONS_DEFINE= IPV6 PAM OSPFNSSA SNMP TCPZEBRA BGPD OSPF6D OSPFD RIPD RIPNGD VTYSH
+
+PAM_DESC= PAM authentication for vtysh
+OSPFNSSA_DESC= undergoing NSSA feature
+TCPZEBRA_DESC= TCP/IP socket connection
+BGPD_DESC= BGPD support
+OSPF6D_DESC= OSPF6D support
+OSPFD_DESC= OSPFD support
+RIPD_DESC= RIPD support
+RIPNGD_DESC= RIPNGD support
+VTYSH_DESC= VTYSH support
+
+OPTIONS_DEFAULT= IPV6 BGPD OSPF6D OSPFD RIPD RIPNGD VTYSH
+NO_OPTIONS_SORT= yes
MAN1= vtysh.1
MAN8= bgpd.8 ospf6d.8 ospfd.8 ripd.8 ripngd.8 zebra.8
INFO= zebra
+BGPDARGS?= -d
+OSPFDARGS?= -d
+OSPF6DARGS?= -d
+RIPDARGS?= -d
+RIPNGDARGS?= -d
+ZEBRAARGS?= -d
+
.include <bsd.port.options.mk>
-.if defined (WITHOUT_IPV6)
+.if empty(PORT_OPTIONS:MIPV6)
CONFIGURE_ARGS+=--disable-ipv6
WITHOUT_OSPF6D= yes
WITHOUT_RIPNGD= yes
.endif
-.if defined (WITH_LIBPAM)
+.if ${PORT_OPTIONS:MPAM}
CONFIGURE_ARGS+=--with-libpam
.endif
-.if defined (WITH_OSPFNSSA)
+.if ${PORT_OPTIONS:MOSPFNSSA}
CONFIGURE_ARGS+=--enable-nssa
.endif
-.if defined (WITH_SNMP)
+.if ${PORT_OPTIONS:MSNMP}
CONFIGURE_ARGS+=--enable-snmp
LIB_DEPENDS+=snmp.4:${PORTSDIR}/net-mgmt/net-snmp4:install
.endif
-.if defined (WITH_TCPZEBRA)
+.if ${PORT_OPTIONS:MTCPZEBRA}
CONFIGURE_ARGS+=--enable-tcp-zebra
.endif
-.if !defined(WITHOUT_BGPD)
+.if ${PORT_OPTIONS:MBGPD}
PLIST_SUB+= BGPD=""
.else
CONFIGURE_ARGS+=--disable-bgpd
PLIST_SUB+= BGPD="@comment "
.endif
-.if !defined(WITHOUT_OSPF6D)
+.if ${PORT_OPTIONS:MOSPF6D}
PLIST_SUB+= OSPF6D=""
.else
CONFIGURE_ARGS+=--disable-ospf6d
PLIST_SUB+= OSPF6D="@comment "
.endif
-.if !defined(WITHOUT_OSPFD)
+.if ${PORT_OPTIONS:MOSPFD}
PLIST_SUB+= OSPF6D=""
PLIST_SUB+= OSPFD=""
.else
@@ -89,21 +105,21 @@ CONFIGURE_ARGS+=--disable-ospfd
PLIST_SUB+= OSPFD="@comment "
.endif
-.if !defined(WITHOUT_RIPD)
+.if ${PORT_OPTIONS:MRIPD}
PLIST_SUB+= RIPD=""
.else
CONFIGURE_ARGS+=--disable-ripd
PLIST_SUB+= RIPD="@comment "
.endif
-.if !defined(WITHOUT_RIPNGD)
+.if ${PORT_OPTIONS:MRIPNGD}
PLIST_SUB+= RIPNGD=""
.else
CONFIGURE_ARGS+=--disable-ripngd
PLIST_SUB+= RIPNGD="@comment "
.endif
-.if !defined(WITHOUT_VTYSH)
+.if ${PORT_OPTIONS:MVTYSH)
PLIST_SUB+= VTYSH=""
CONFIGURE_ARGS+=--enable-vtysh
.else
diff --git a/net/zebra/files/zebractl.in b/net/zebra/files/zebractl.in
index 46ba05882c60..b09ff558a3a9 100644
--- a/net/zebra/files/zebractl.in
+++ b/net/zebra/files/zebractl.in
@@ -24,17 +24,17 @@ case $1 in
exit 1
fi
[ -f %%ETCDIR%%/zebra.conf ] \
- && %%PREFIX%%/sbin/zebra -d && echo -n ' zebra'
+ && %%PREFIX%%/sbin/zebra %%ZEBRAARGS%% && echo -n ' zebra'
[ -f %%ETCDIR%%/ripd.conf ] \
- && %%PREFIX%%/sbin/ripd -d && echo -n ' ripd'
+ && %%PREFIX%%/sbin/ripd %%RIPDARGS%% && echo -n ' ripd'
[ -f %%ETCDIR%%/ripngd.conf ] \
- && %%PREFIX%%/sbin/ripngd -d && echo -n ' ripngd'
+ && %%PREFIX%%/sbin/ripngd %%RIPNGDARGS%% && echo -n ' ripngd'
[ -f %%ETCDIR%%/ospfd.conf ] \
- && %%PREFIX%%/sbin/ospfd -d && echo -n ' ospfd'
+ && %%PREFIX%%/sbin/ospfd %%OSPFDARGS%% && echo -n ' ospfd'
[ -f %%ETCDIR%%/ospf6d.conf ] \
- && %%PREFIX%%/sbin/ospf6d -d && echo -n ' ospf6d'
+ && %%PREFIX%%/sbin/ospf6d %%OSPF6DARGS%% && echo -n ' ospf6d'
[ -f %%ETCDIR%%/bgpd.conf ] \
- && %%PREFIX%%/sbin/bgpd -d && echo -n ' bgpd'
+ && %%PREFIX%%/sbin/bgpd %%BGPDARGS%% && echo -n ' bgpd'
;;
stop)