aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2008-07-25 17:05:00 +0800
committergahr <gahr@FreeBSD.org>2008-07-25 17:05:00 +0800
commit8a17b716528dac67a1152e2733af9c510fd93e1c (patch)
tree999da21bed7cfa17bc38e809be71d10cbd79b6bc
parent12cb9e4134ea9aa797640da52795f8580a9525b5 (diff)
downloadfreebsd-ports-gnome-8a17b716528dac67a1152e2733af9c510fd93e1c.tar.gz
freebsd-ports-gnome-8a17b716528dac67a1152e2733af9c510fd93e1c.tar.zst
freebsd-ports-gnome-8a17b716528dac67a1152e2733af9c510fd93e1c.zip
- New port: p5-Sys-MemInfo
Get information about memory and swap usage from perl PR: 125944 Submitted by: terry@sucked-in.com
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Sys-MemInfo/Makefile23
-rw-r--r--devel/p5-Sys-MemInfo/distinfo3
-rw-r--r--devel/p5-Sys-MemInfo/pkg-descr6
-rw-r--r--devel/p5-Sys-MemInfo/pkg-plist7
5 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4d3bf226729d..82672ecf4961 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1654,6 +1654,7 @@
SUBDIR += p5-Sub-Uplevel
SUBDIR += p5-Sub-WrapPackages
SUBDIR += p5-Sys-Cpu
+ SUBDIR += p5-Sys-MemInfo
SUBDIR += p5-Sys-Mmap
SUBDIR += p5-Sys-Sig
SUBDIR += p5-Sys-SigAction
diff --git a/devel/p5-Sys-MemInfo/Makefile b/devel/p5-Sys-MemInfo/Makefile
new file mode 100644
index 000000000000..77d57569b543
--- /dev/null
+++ b/devel/p5-Sys-MemInfo/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: Sys-MemInfo
+# Date created: 25 July 2008
+# Whom: Terry Sposato <terry@sucked-in.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Sys-MemInfo
+PORTVERSION= 0.91
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= terry@sucked-in.com
+COMMENT= Sys::MemInfo - Perl extension for getting Memory information
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+PERL_CONFIGURE= yes
+
+MAN3= Sys::MemInfo.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Sys-MemInfo/distinfo b/devel/p5-Sys-MemInfo/distinfo
new file mode 100644
index 000000000000..4ef5a7cdbe6d
--- /dev/null
+++ b/devel/p5-Sys-MemInfo/distinfo
@@ -0,0 +1,3 @@
+MD5 (Sys-MemInfo-0.91.tar.gz) = d2ddda32c58114352e04ecb866de7f17
+SHA256 (Sys-MemInfo-0.91.tar.gz) = c15af4b9db68f86b182504823e4c9a36ee977d9142a2306f089b4dc1cd26c143
+SIZE (Sys-MemInfo-0.91.tar.gz) = 6802
diff --git a/devel/p5-Sys-MemInfo/pkg-descr b/devel/p5-Sys-MemInfo/pkg-descr
new file mode 100644
index 000000000000..25930917723a
--- /dev/null
+++ b/devel/p5-Sys-MemInfo/pkg-descr
@@ -0,0 +1,6 @@
+Sys::MemInfo return the total amount of free and used
+physical memory in bytes in totalmem and freemem variables.
+Total amount of free and user swap memory are alse returned
+in totalswap and freeswap variables.
+
+WWW: http://search.cpan.org/dist/Sys-Cpu/
diff --git a/devel/p5-Sys-MemInfo/pkg-plist b/devel/p5-Sys-MemInfo/pkg-plist
new file mode 100644
index 000000000000..6d20d95abc11
--- /dev/null
+++ b/devel/p5-Sys-MemInfo/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Sys/MemInfo.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/MemInfo/MemInfo.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/MemInfo/MemInfo.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/MemInfo/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/MemInfo
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Sys
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys