aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>1998-10-05 11:06:04 +0800
committersteve <steve@FreeBSD.org>1998-10-05 11:06:04 +0800
commit8b50ac6087d17925203f324fb7a72be884528484 (patch)
treecb34c07003d3b151289060af332d6a37b7580930
parent8602429e298573a31545b6c8bec41dc8c9a4f9b3 (diff)
downloadfreebsd-ports-gnome-8b50ac6087d17925203f324fb7a72be884528484.tar.gz
freebsd-ports-gnome-8b50ac6087d17925203f324fb7a72be884528484.tar.zst
freebsd-ports-gnome-8b50ac6087d17925203f324fb7a72be884528484.zip
Convert to ELF.
-rw-r--r--graphics/pgplot/Makefile13
-rw-r--r--graphics/pgplot/files/Makefile2
-rw-r--r--graphics/pgplot/files/xf774
-rw-r--r--graphics/pgplot/pkg-plist9
-rw-r--r--graphics/plotutils/Makefile4
-rw-r--r--graphics/plotutils/pkg-plist8
-rw-r--r--graphics/urt/files/patch-aa2
-rw-r--r--graphics/urt/files/patch-ab91
-rw-r--r--graphics/urt/files/patch-ad101
-rw-r--r--graphics/urt/pkg-plist5
10 files changed, 133 insertions, 106 deletions
diff --git a/graphics/pgplot/Makefile b/graphics/pgplot/Makefile
index 81660913e855..0aedceae0523 100644
--- a/graphics/pgplot/Makefile
+++ b/graphics/pgplot/Makefile
@@ -3,7 +3,7 @@
# Date created: 21 December 1996
# Whom: jmz
#
-# $Id: Makefile,v 1.3 1997/07/17 15:12:44 max Exp $
+# $Id: Makefile,v 1.4 1997/08/15 13:36:01 jmz Exp $
#
DISTNAME= pgplot5.2
@@ -16,6 +16,15 @@ MAINTAINER= jmz@FreeBSD.org
WRKSRC= ${WRKDIR}/pgplot
post-install:
- ${LDCONFIG} -m ${PREFIX}/lib
+.for f in libcpgplot.so libpgplot.so
+ ${LN} -sf $f.${VERSION} ${PREFIX}/lib/$f
+.endfor
+ ${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
.include <bsd.port.mk>
+
+.if ${PORTOBJFORMAT} == "elf"
+VERSION= 5
+.else
+VERSION= 5.2
+.endif
diff --git a/graphics/pgplot/files/Makefile b/graphics/pgplot/files/Makefile
index 6060abb8c395..d2d5a3776722 100644
--- a/graphics/pgplot/files/Makefile
+++ b/graphics/pgplot/files/Makefile
@@ -6,7 +6,7 @@ all:
make -f Makefile.doc
install:
- install -c *.a *.so.5.2 ${PREFIX}/lib
+ install -c *.a *.so.5* ${PREFIX}/lib
mkdir -p ${PREFIX}/share/pgplot
install -c grfont.dat rgb.txt pgplot.doc pgplot.html pgplot-routines.tex cpg/cpgplot.doc ${PREFIX}/share/pgplot
install -c cpgplot.h ${PREFIX}/include
diff --git a/graphics/pgplot/files/xf77 b/graphics/pgplot/files/xf77
index cd8a80e475c9..554d36ecd08f 100644
--- a/graphics/pgplot/files/xf77
+++ b/graphics/pgplot/files/xf77
@@ -8,10 +8,10 @@ $myname = $0;
$count = 0;
while ($ARGV[0] =~ /^-/) {
- $opt . = " $ARGV[0]";
+ $opt .= " $ARGV[0]";
if ($ARGV[0] eq "-o") {
shift;
- $opt . = " $ARGV[0]";
+ $opt .= " $ARGV[0]";
}
shift;
}
diff --git a/graphics/pgplot/pkg-plist b/graphics/pgplot/pkg-plist
index 79efc5db7e28..c4ac9e295e47 100644
--- a/graphics/pgplot/pkg-plist
+++ b/graphics/pgplot/pkg-plist
@@ -2,11 +2,13 @@ bin/pgxwin_server
bin/pgdisp
include/cpgplot.h
lib/libcpgplot.a
+lib/libcpgplot.so
lib/libcpgplot.so.5.2
lib/libpgplot.a
-lib/libpgplot.so.5.2
-@exec /sbin/ldconfig -m %D/lib
-@unexec /sbin/ldconfig -R
+lib/libpgplot.so
+lib/libpgplot.so.5.2
+@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %D/lib
+@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
share/pgplot/Makefile.demo
share/pgplot/cpgdemo.c
share/pgplot/cpgplot.doc
@@ -33,3 +35,4 @@ share/pgplot/pgdemo14.f
share/pgplot/pgdemo15.f
share/pgplot/pgdemo16.f
share/pgplot/pgdemo17.f
+@dirrm share/pgplot
diff --git a/graphics/plotutils/Makefile b/graphics/plotutils/Makefile
index 747d8340e1be..d7e2ece68591 100644
--- a/graphics/plotutils/Makefile
+++ b/graphics/plotutils/Makefile
@@ -3,7 +3,7 @@
# Date created: 19 June 1998
# Whom: Chuck Robey (chuckr)
#
-# $Id: Makefile,v 1.1.1.1 1998/06/20 03:09:11 chuckr Exp $
+# $Id: Makefile,v 1.2 1998/06/26 04:53:29 asami Exp $
#
DISTNAME= plotutils-2.1.1
@@ -19,6 +19,6 @@ CONFIGURE_ARGS= --with-motif
.endif
post-install:
- $(LDCONFIG) -m $(PREFIX)/lib
+ ${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
.include <bsd.port.mk>
diff --git a/graphics/plotutils/pkg-plist b/graphics/plotutils/pkg-plist
index b7fdf251cce6..19b4fa89695c 100644
--- a/graphics/plotutils/pkg-plist
+++ b/graphics/plotutils/pkg-plist
@@ -41,10 +41,12 @@ share/tek2plot/ocpred.tek
share/tek2plot/scale.tek
share/tek2plot/skymap.tek
share/tek2plot/usmap.tek
-lib/libplot.so.1.0
+lib/libplot.so
+lib/libplot.so.1
lib/libplot.a
-@exec /sbin/ldconfig -m %B
-@unexec /sbin/ldconfig -R
+lib/libplot.la
+@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
+@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
include/plot.h
@unexec install-info --delete --info-dir=/usr/local/info /usr/local/info/plotutils.info
info/plotutils.info
diff --git a/graphics/urt/files/patch-aa b/graphics/urt/files/patch-aa
index f7014db08c8a..49bae83dca5f 100644
--- a/graphics/urt/files/patch-aa
+++ b/graphics/urt/files/patch-aa
@@ -153,7 +153,7 @@
-LIBTIFF = $(TIFFDIR)/libtiff.a
+##defpath TIFFDIR
+INCTIFF = -I${PREFIX}/include/tiff34
-+LIBTIFF = -L${PREFIX}/lib -ltiff34
++LIBTIFF = -L${PREFIX}/lib -ltiff34 -ljpeg
#endif
#ifdef X10
diff --git a/graphics/urt/files/patch-ab b/graphics/urt/files/patch-ab
index bdb7827cc980..bb0a51a01bf6 100644
--- a/graphics/urt/files/patch-ab
+++ b/graphics/urt/files/patch-ab
@@ -37,97 +37,6 @@ diff -ur ../urt-3.1b-orig/lib/buildmap.c ./lib/buildmap.c
#include "rle.h"
#include <math.h>
-diff -ur ../urt-3.1b-orig/lib/makefile.src ./lib/makefile.src
---- ../urt-3.1b-orig/lib/makefile.src Wed Mar 4 16:32:53 1992
-+++ ./lib/makefile.src Sat Sep 16 10:44:35 1995
-@@ -26,7 +26,10 @@
- vaxshort.o \
- $(OPT_OBJS)
-
--LIBNAME = librle.a
-+SOOBJS = $(OBJS:.o=.so)
-+
-+LIBANAME = librle.a
-+LIBSONAME = librle.so.1.0
-
- # Just rebuild the object files.
- objs: $(OBJS)
-@@ -37,23 +40,13 @@
- # Do nothing if $(DEST) is empty (or not defined)
- install: buildlib
- @sh -c "if test '$(DEST)x' != x ; then \
-- echo cp $(LIBNAME) $(DEST)/$(LIBNAME) ; \
-- cp $(LIBNAME) $(DEST)/$(LIBNAME) ; \
-+ echo cp $(LIBANAME) $(DEST)/$(LIBANAME) ; \
-+ cp $(LIBANAME) $(DEST)/$(LIBANAME) ; \
-+ echo cp $(LIBSONAME) $(DEST)/$(LIBSONAME) ; \
-+ cp $(LIBSONAME) $(DEST)/$(LIBSONAME) ; \
- if test x$(RANLIB) != x ; then \
-- echo ranlib $(DEST)/$(LIBNAME) ; \
-- ranlib $(DEST)/$(LIBNAME) ; \
-- else \
-- true ; \
-- fi ; \
-- if test -d $(DEST)/debug ; then \
-- echo cp $(LIBNAME) $(DEST)/debug/$(LIBNAME) ; \
-- if test x$(RANLIB) != x ; then \
-- cp $(LIBNAME) $(DEST)/debug/$(LIBNAME) ; \
-- echo ranlib $(DEST)/debug/$(LIBNAME) ; \
-- else \
-- true ; \
-- fi ; \
-- ranlib $(DEST)/debug/$(LIBNAME) ; \
-+ echo ranlib $(DEST)/$(LIBANAME) ; \
-+ ranlib $(DEST)/$(LIBANAME) ; \
- else \
- true ; \
- fi ; \
-@@ -63,14 +56,24 @@
- touch install
-
- # Rebuild the library from all the .o files.
--buildlib: $(OBJS)
-- -rm -f $(LIBNAME)
-- ar rc $(LIBNAME)
-- ar q $(LIBNAME) $(OBJS)
-+buildlib: $(LIBANAME) $(LIBSONAME)
-+
-+$(LIBANAME): $(OBJS)
-+ -rm -f $@
-+ ar rc $@ $?
- #ifndef NO_RANLIB
-- ranlib $(LIBNAME)
-+ ranlib $@
- #endif
-- touch buildlib
-+
-+.SUFFIXES: .so .o
-+
-+.c.so:
-+ $(CC) -fPIC -DPIC $(CFLAGS) -c $*.c -o $*.so
-+ $(LD) -X -r $*.so
-+
-+$(LIBSONAME): $(SOOBJS)
-+ -rm -f $@
-+ ld -Bshareable -o $@ $>
-
- # Clean up installed stuff and binaries
- pristine: clean
-@@ -86,9 +89,12 @@
- # Get rid of everything which must be recompiled on a different computer.
- clean:
- -rm -f *.o
-+ -rm -f *.so
- -@if test x$(DEST) != x ; then \
-- echo rm -f $(LIBNAME) ; \
-- rm -f $(LIBNAME) ; \
-+ echo rm -f $(LIBANAME) ; \
-+ rm -f $(LIBANAME) ; \
-+ echo rm -f $(LIBSONAME) ; \
-+ rm -f $(LIBSONAME) ; \
- else \
- true ; \
- fi
diff -ur ../urt-3.1b-orig/makefile.src ./makefile.src
--- ../urt-3.1b-orig/makefile.src Fri Jun 7 11:58:13 1991
+++ ./makefile.src Fri Sep 15 22:09:01 1995
diff --git a/graphics/urt/files/patch-ad b/graphics/urt/files/patch-ad
new file mode 100644
index 000000000000..4ca49d6b5d8e
--- /dev/null
+++ b/graphics/urt/files/patch-ad
@@ -0,0 +1,101 @@
+--- lib/makefile.src.orig Wed Mar 4 13:32:53 1992
++++ lib/makefile.src Sat Oct 3 23:57:51 1998
+@@ -26,7 +26,14 @@
+ vaxshort.o \
+ $(OPT_OBJS)
+
+-LIBNAME = librle.a
++SOOBJS = $(OBJS:.o=.so)
++
++LIBANAME = librle.a
++.if $(PORTOBJFORMAT) == "elf"
++LIBSONAME = librle.so.1
++.else
++LIBSONAME = librle.so.1.0
++.endif
+
+ # Just rebuild the object files.
+ objs: $(OBJS)
+@@ -37,23 +44,14 @@
+ # Do nothing if $(DEST) is empty (or not defined)
+ install: buildlib
+ @sh -c "if test '$(DEST)x' != x ; then \
+- echo cp $(LIBNAME) $(DEST)/$(LIBNAME) ; \
+- cp $(LIBNAME) $(DEST)/$(LIBNAME) ; \
++ echo cp $(LIBANAME) $(DEST)/$(LIBANAME) ; \
++ cp $(LIBANAME) $(DEST)/$(LIBANAME) ; \
++ echo cp $(LIBSONAME) $(DEST)/$(LIBSONAME) ; \
++ cp $(LIBSONAME) $(DEST)/$(LIBSONAME) ; \
++ ln -sf $(LIBSONAME) $(DEST)/librle.so ; \
+ if test x$(RANLIB) != x ; then \
+- echo ranlib $(DEST)/$(LIBNAME) ; \
+- ranlib $(DEST)/$(LIBNAME) ; \
+- else \
+- true ; \
+- fi ; \
+- if test -d $(DEST)/debug ; then \
+- echo cp $(LIBNAME) $(DEST)/debug/$(LIBNAME) ; \
+- if test x$(RANLIB) != x ; then \
+- cp $(LIBNAME) $(DEST)/debug/$(LIBNAME) ; \
+- echo ranlib $(DEST)/debug/$(LIBNAME) ; \
+- else \
+- true ; \
+- fi ; \
+- ranlib $(DEST)/debug/$(LIBNAME) ; \
++ echo ranlib $(DEST)/$(LIBANAME) ; \
++ ranlib $(DEST)/$(LIBANAME) ; \
+ else \
+ true ; \
+ fi ; \
+@@ -63,14 +61,30 @@
+ touch install
+
+ # Rebuild the library from all the .o files.
+-buildlib: $(OBJS)
+- -rm -f $(LIBNAME)
+- ar rc $(LIBNAME)
+- ar q $(LIBNAME) $(OBJS)
++buildlib: $(LIBANAME) $(LIBSONAME)
++
++$(LIBANAME): $(OBJS)
++ -rm -f $@
++ ar rc $@ $?
+ #ifndef NO_RANLIB
+- ranlib $(LIBNAME)
++ ranlib $@
+ #endif
+- touch buildlib
++
++.SUFFIXES: .so .o
++
++.c.so:
++ $(CC) -fPIC -DPIC $(CFLAGS) -c $*.c -o $*.so
++ $(LD) -X -r $*.so
++
++.if $(PORTOBJFORMAT) == "elf"
++$(LIBSONAME): $(SOOBJS)
++ -rm -f $@
++ ld -shared -soname $@ -o $@ $>
++.else
++$(LIBSONAME): $(SOOBJS)
++ -rm -f $@
++ ld -Bshareable -o $@ $>
++.endif
+
+ # Clean up installed stuff and binaries
+ pristine: clean
+@@ -86,9 +100,12 @@
+ # Get rid of everything which must be recompiled on a different computer.
+ clean:
+ -rm -f *.o
++ -rm -f *.so
+ -@if test x$(DEST) != x ; then \
+- echo rm -f $(LIBNAME) ; \
+- rm -f $(LIBNAME) ; \
++ echo rm -f $(LIBANAME) ; \
++ rm -f $(LIBANAME) ; \
++ echo rm -f $(LIBSONAME) ; \
++ rm -f $(LIBSONAME) ; \
+ else \
+ true ; \
+ fi
diff --git a/graphics/urt/pkg-plist b/graphics/urt/pkg-plist
index a27cce2be720..da47e8a78247 100644
--- a/graphics/urt/pkg-plist
+++ b/graphics/urt/pkg-plist
@@ -74,7 +74,10 @@ include/rle_config.h
include/rle_put.h
include/rle_raw.h
lib/librle.a
-lib/librle.so.1.0
+lib/librle.so
+lib/librle.so.1
+@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
+@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
@comment if compressed RLE.5 doesn't work.
man/man5/RLE.5
man/man5/rle.5