aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrezny <rezny@FreeBSD.org>2017-03-30 03:18:34 +0800
committerrezny <rezny@FreeBSD.org>2017-03-30 03:18:34 +0800
commit8bc968aa59a96aa47f71738ac65b120cff966e54 (patch)
tree68c76639db1bc56f886e412a293853b15795d031
parentd9eb1634ad68ccab646f38ba4ed4611f84f3c64d (diff)
downloadfreebsd-ports-gnome-8bc968aa59a96aa47f71738ac65b120cff966e54.tar.gz
freebsd-ports-gnome-8bc968aa59a96aa47f71738ac65b120cff966e54.tar.zst
freebsd-ports-gnome-8bc968aa59a96aa47f71738ac65b120cff966e54.zip
Update to 4.11.22, the last release from KDE.org
Drop obsolete patches, add one to fix build, and rename a few patches. Reviewed by: rakuco, tcberner, mat Approved by: swills (mentor) Differential Revision: https://reviews.freebsd.org/D10148
-rw-r--r--Mk/Uses/kde.mk2
-rw-r--r--sysutils/ksysguardd/Makefile8
-rw-r--r--sysutils/ksysguardd/files/patch-modules.h13
-rw-r--r--x11/kde4-workspace/Makefile19
-rw-r--r--x11/kde4-workspace/distinfo6
-rw-r--r--x11/kde4-workspace/files/patch-git_0f4349334
-rw-r--r--x11/kde4-workspace/files/patch-git_68a4d7628
-rw-r--r--x11/kde4-workspace/files/patch-kdm_backend_client.c (renamed from x11/kde4-workspace/files/patch-kdm__backend__client.c)0
-rw-r--r--x11/kde4-workspace/files/patch-kdm_kfrontend_CMakeLists.txt (renamed from x11/kde4-workspace/files/patch-kdm-kfrontend-CMakeLists.txt)0
-rw-r--r--x11/kde4-workspace/files/patch-powerdevil_daemon_backends_upower_xrandrbrightness.cpp (renamed from x11/kde4-workspace/files/patch-powerdevil__daemon__backends__upower__xrandrbrightness.cpp)0
-rw-r--r--x11/plasma-scriptengine-python/Makefile6
-rw-r--r--x11/plasma-scriptengine-ruby/Makefile6
12 files changed, 37 insertions, 85 deletions
diff --git a/Mk/Uses/kde.mk b/Mk/Uses/kde.mk
index 6b1b724b3d74..5ecf378c3a93 100644
--- a/Mk/Uses/kde.mk
+++ b/Mk/Uses/kde.mk
@@ -57,7 +57,7 @@ _KDE_RELNAME= KDE${_KDE_VERSION}
KDE4_VERSION?= 4.14.3
KDE4_KDELIBS_VERSION= 4.14.30
KDE4_ACTIVITIES_VERSION= 4.13.3
-KDE4_WORKSPACE_VERSION= 4.11.21
+KDE4_WORKSPACE_VERSION= 4.11.22
KDE4_KDEPIM_VERSION?= 4.14.10
# Applications version for the kde4-applications.
KDE4_APPLICATIONS_BRANCH?= Attic
diff --git a/sysutils/ksysguardd/Makefile b/sysutils/ksysguardd/Makefile
index a12203a6b984..d46d3ae1aaa9 100644
--- a/sysutils/ksysguardd/Makefile
+++ b/sysutils/ksysguardd/Makefile
@@ -2,10 +2,8 @@
PORTNAME= ksysguardd
PORTVERSION= ${KDE4_WORKSPACE_VERSION}
-CATEGORIES= sysutils kde
-MASTER_SITES= KDE/${KDE4_APPLICATIONS_BRANCH}/applications/${KDE4_APPLICATIONS_VERSION}/src
+CATEGORIES= sysutils kde kde-applications
DISTNAME= kde-workspace-${PORTVERSION}
-DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE System Guard Daemon
@@ -15,11 +13,13 @@ USES= cmake kde:4 tar:xz
CMAKE_ARGS+= -DBIN_INSTALL_DIR:STRING="${PREFIX}/bin" \
-DSYSCONF_INSTALL_DIR:STRING="${PREFIX}/etc"
+KDE_APPLICATIONS_VERSION= 15.08.0
+
EXTRACT_AFTER_ARGS= '${DISTNAME}/ksysguard/${PORTNAME}' \
'${DISTNAME}/ksysguard/example/${PORTNAME}rc' \
'${DISTNAME}/ksysguard/gui/SignalIDs.h'
-WRKSRC= ${WRKDIR}/${DISTNAME}/ksysguard/${PORTNAME}
+WRKSRC_SUBDIR= ksysguard/${PORTNAME}
PLIST_FILES= bin/${PORTNAME} \
etc/${PORTNAME}rc
diff --git a/sysutils/ksysguardd/files/patch-modules.h b/sysutils/ksysguardd/files/patch-modules.h
new file mode 100644
index 000000000000..c324abe657b5
--- /dev/null
+++ b/sysutils/ksysguardd/files/patch-modules.h
@@ -0,0 +1,13 @@
+* Silence a syntax warning
+
+--- modules.h.orig 2015-08-12 07:03:15 UTC
++++ modules.h
+@@ -144,7 +144,7 @@ struct SensorModul SensorModulList[] = {
+ { "Uptime", initUptime, exitUptime, NULLIVFUNC, NULLVVFUNC, 0, NULLTIME },
+ #endif /* OSTYPE_Linux */
+
+-#if defined OSTYPE_FreeBSD || defined OSTYPE_DragonFly
++#if defined(OSTYPE_FreeBSD) || defined(OSTYPE_DragonFly)
+ { "Acpi", initACPI, exitACPI, updateACPI, NULLVVFUNC, 0, NULLTIME },
+ #ifdef __i386__
+ { "Apm", initApm, exitApm, updateApm, NULLVVFUNC, 0, NULLTIME },
diff --git a/x11/kde4-workspace/Makefile b/x11/kde4-workspace/Makefile
index 615016b1324c..f4d803e299ca 100644
--- a/x11/kde4-workspace/Makefile
+++ b/x11/kde4-workspace/Makefile
@@ -2,10 +2,7 @@
PORTNAME= kde-workspace
PORTVERSION= ${KDE4_WORKSPACE_VERSION}
-PORTREVISION= 7
-CATEGORIES= x11 kde
-MASTER_SITES= KDE/${KDE4_APPLICATIONS_BRANCH}/applications/${KDE4_APPLICATIONS_VERSION}/src
-DIST_SUBDIR= KDE/${PORTVERSION}
+CATEGORIES= x11 kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE Plasma Desktop
@@ -14,6 +11,8 @@ LIB_DEPENDS= libdbus-1.so:devel/dbus \
libck-connector.so:sysutils/consolekit \
libpci.so:devel/libpci \
libhal.so:sysutils/hal \
+ libqjson.so:devel/qjson \
+ libcln.so:math/cln \
libqalculate.so:math/libqalculate \
libprison.so:graphics/prison \
libboost_thread.so:devel/boost-libs \
@@ -42,18 +41,20 @@ RUN_DEPENDS= ${KDE_PREFIX}/env/xdg-env.sh:misc/kde4-xdg-env \
USES= cmake:outsource compiler:c++11-lib gettext gmake jpeg kde:4 \
pkgconfig shebangfix tar:xz
-USE_GL= glu
-USE_GNOME= glib20
+USE_GL= gl glu
+USE_GNOME= glib20 libxml2
USE_KDE= kactivities kdelibs nepomuk-core oxygen-icons4 \
pimlibs akonadi automoc4 ontologies qimageblitz soprano strigi
USE_QT4= corelib dbus declarative designer_build gui network \
- opengl phonon qtestlib script sql webkit xml \
+ opengl phonon qtestlib script sql svg webkit xml \
moc_build qmake_build rcc_build uic_build
-USE_XORG= kbproto x11 xau xcomposite xcursor xdamage xdmcp xfixes \
- xft xi xinerama xkbfile xrandr xrender xres xscrnsaver xtst
+USE_XORG= ice sm kbproto x11 xau xcb xcomposite xcursor xdamage xdmcp xext xfixes \
+ xft xi xinerama xkbfile xpm xrandr xrender xres xscrnsaver xtst xxf86vm
SHEBANG_FILES= kwin/clients/oxygen/data/update_oxygen.pl
USE_LDCONFIG= yes
+KDE_APPLICATIONS_VERSION= 15.08.0
+
CMAKE_ARGS= -DCMAKE_REQUIRED_FLAGS:STRING="-L${LOCALBASE}/lib" \
-DBUILD_python:BOOL=OFF \
-DBUILD_ruby:BOOL=OFF \
diff --git a/x11/kde4-workspace/distinfo b/x11/kde4-workspace/distinfo
index 66f3c185ff58..613b6b1fa611 100644
--- a/x11/kde4-workspace/distinfo
+++ b/x11/kde4-workspace/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1466144753
-SHA256 (KDE/4.11.21/kde-workspace-4.11.21.tar.xz) = 7196c68802af335b15a3b8e14c55a15ed7c2c0e9145a047dc6d4a281fe7f7c8f
-SIZE (KDE/4.11.21/kde-workspace-4.11.21.tar.xz) = 13550508
+TIMESTAMP = 1490623839
+SHA256 (KDE/applications/15.08.0/kde-workspace-4.11.22.tar.xz) = f035334e843d67ee88551ae9e6c5f64bf7b1edfe311b12501575fe74be0b03b7
+SIZE (KDE/applications/15.08.0/kde-workspace-4.11.22.tar.xz) = 13553668
diff --git a/x11/kde4-workspace/files/patch-git_0f43493 b/x11/kde4-workspace/files/patch-git_0f43493
deleted file mode 100644
index 404a10771645..000000000000
--- a/x11/kde4-workspace/files/patch-git_0f43493
+++ /dev/null
@@ -1,34 +0,0 @@
-Fixes the build with kdelibs 4.14.30.
-
-commit 0f4349389875fa7452ec0a9d0a468be1e14cda33
-Author: Kevin Ottens <ervin@kde.org>
-Date: Mon Jul 20 19:56:53 2015 +0200
-
- Link to proper targets
-
-diff --git a/plasma/generic/dataengines/akonadi/CMakeLists.txt b/plasma/generic/dataengines/akonadi/CMakeLists.txt
-index 7f0dd346a4..091e76bd00 100644
---- plasma/generic/dataengines/akonadi/CMakeLists.txt
-+++ plasma/generic/dataengines/akonadi/CMakeLists.txt
-@@ -21,7 +21,7 @@ target_link_libraries(
- ${KDE4_AKONADI_KMIME_LIBS}
- ${KDE4_KABC_LIBS}
- ${QT_QTXML_LIBRARY}
-- microblog
-+ ${KDE4_MICROBLOG_LIBS}
- )
-
- install(TARGETS plasma_engine_akonadi DESTINATION ${PLUGIN_INSTALL_DIR})
-diff --git a/plasma/generic/dataengines/calendar/CMakeLists.txt b/plasma/generic/dataengines/calendar/CMakeLists.txt
-index 6ad3b61046..fb0893da0e 100644
---- plasma/generic/dataengines/calendar/CMakeLists.txt
-+++ plasma/generic/dataengines/calendar/CMakeLists.txt
-@@ -33,7 +33,7 @@ target_link_libraries(
- if(Akonadi_FOUND)
- target_link_libraries(
- plasma_engine_calendar
-- akonadi-calendar
-+ ${KDEPIMLIBS_AKONADI_CALENDAR_LIBS}
- ${KDE4_AKONADI_LIBS}
- ${KDEPIMLIBS_AKONADI_KCAL_LIBS}
- )
diff --git a/x11/kde4-workspace/files/patch-git_68a4d76 b/x11/kde4-workspace/files/patch-git_68a4d76
deleted file mode 100644
index e158a9cff4a1..000000000000
--- a/x11/kde4-workspace/files/patch-git_68a4d76
+++ /dev/null
@@ -1,28 +0,0 @@
-Fixes the build with x11/kdelibs4 4.14.30.
-
-commit 68a4d76ceb7e9b8aa9f15f2231f806e74c91ec6d
-Author: Kevin Ottens <ervin@kde.org>
-Date: Mon Jul 20 19:11:37 2015 +0200
-
- Avoid target name clash
-
-diff --git a/libs/ksysguard/tests/CMakeLists.txt b/libs/ksysguard/tests/CMakeLists.txt
-index d472fd7e0a..2269b18ee1 100644
---- libs/ksysguard/tests/CMakeLists.txt
-+++ libs/ksysguard/tests/CMakeLists.txt
-@@ -12,13 +12,13 @@ target_link_libraries(processtest processui ${KDE4_KDECORE_LIBS} ${QT_QTTEST_LIB
-
- # KSignalPlotter benchmark
- set( signalplotterbenchmark_SRCS signalplotterbenchmark.cpp ../signalplotter/ksignalplotter.cpp)
--kde4_add_unit_test( signalplotterbenchmark TESTNAME ksysguard-signalplottertest ${signalplotterbenchmark_SRCS} )
-+kde4_add_unit_test( signalplotterbenchmark TESTNAME ksysguard-signalplotterbenchmark ${signalplotterbenchmark_SRCS} )
- target_link_libraries( signalplotterbenchmark ${KDE4_KDEUI_LIBS} ${QT_QTTEST_LIBRARY} ${QT_QTBENCHMARK_LIBRARY} )
-
-
- # KGraphicsSignalPlotter benchmark
- set( graphicssignalplotterbenchmark_SRCS graphicssignalplotterbenchmark.cpp ../signalplotter/kgraphicssignalplotter.cpp)
--kde4_add_unit_test( graphicssignalplotterbenchmark TESTNAME ksysguard-signalplottertest ${graphicssignalplotterbenchmark_SRCS} )
-+kde4_add_unit_test( graphicssignalplotterbenchmark TESTNAME ksysguard-graphicssignalplotterbenchmark ${graphicssignalplotterbenchmark_SRCS} )
- target_link_libraries( graphicssignalplotterbenchmark ${KDE4_KDEUI_LIBS} ${QT_QTTEST_LIBRARY} ${QT_QTBENCHMARK_LIBRARY} )
-
-
diff --git a/x11/kde4-workspace/files/patch-kdm__backend__client.c b/x11/kde4-workspace/files/patch-kdm_backend_client.c
index cff83e810c9f..cff83e810c9f 100644
--- a/x11/kde4-workspace/files/patch-kdm__backend__client.c
+++ b/x11/kde4-workspace/files/patch-kdm_backend_client.c
diff --git a/x11/kde4-workspace/files/patch-kdm-kfrontend-CMakeLists.txt b/x11/kde4-workspace/files/patch-kdm_kfrontend_CMakeLists.txt
index 40bcb9a68ff4..40bcb9a68ff4 100644
--- a/x11/kde4-workspace/files/patch-kdm-kfrontend-CMakeLists.txt
+++ b/x11/kde4-workspace/files/patch-kdm_kfrontend_CMakeLists.txt
diff --git a/x11/kde4-workspace/files/patch-powerdevil__daemon__backends__upower__xrandrbrightness.cpp b/x11/kde4-workspace/files/patch-powerdevil_daemon_backends_upower_xrandrbrightness.cpp
index 53fa3cbebf8e..53fa3cbebf8e 100644
--- a/x11/kde4-workspace/files/patch-powerdevil__daemon__backends__upower__xrandrbrightness.cpp
+++ b/x11/kde4-workspace/files/patch-powerdevil_daemon_backends_upower_xrandrbrightness.cpp
diff --git a/x11/plasma-scriptengine-python/Makefile b/x11/plasma-scriptengine-python/Makefile
index 76215a8d51c0..04d9508dbc38 100644
--- a/x11/plasma-scriptengine-python/Makefile
+++ b/x11/plasma-scriptengine-python/Makefile
@@ -2,10 +2,8 @@
PORTNAME= plasma-scriptengine-python
PORTVERSION= ${KDE4_WORKSPACE_VERSION}
-CATEGORIES= x11 kde
-MASTER_SITES= KDE/${KDE4_APPLICATIONS_BRANCH}/applications/${KDE4_APPLICATIONS_VERSION}/src
+CATEGORIES= x11 kde kde-applications
DISTNAME= kde-workspace-${PORTVERSION}
-DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Plasma scriptengine for Python
@@ -16,6 +14,8 @@ USE_KDE= kdelibs pykde4 automoc4
USE_QT4= qmake_build moc_build uic_build rcc_build
DISTINFO_FILE= ${.CURDIR:H:H}/x11/kde4-workspace/distinfo
+KDE_APPLICATIONS_VERSION= 15.08.0
+
CMAKE_SOURCE_PATH= ${WRKSRC}/plasma/generic/scriptengines/python
pre-configure:
diff --git a/x11/plasma-scriptengine-ruby/Makefile b/x11/plasma-scriptengine-ruby/Makefile
index 856c5bda3841..6a3eba682b78 100644
--- a/x11/plasma-scriptengine-ruby/Makefile
+++ b/x11/plasma-scriptengine-ruby/Makefile
@@ -2,10 +2,8 @@
PORTNAME= plasma-scriptengine-ruby
PORTVERSION= ${KDE4_WORKSPACE_VERSION}
-CATEGORIES= x11 kde
-MASTER_SITES= KDE/${KDE4_APPLICATIONS_BRANCH}/applications/${KDE4_APPLICATIONS_VERSION}/src
+CATEGORIES= x11 kde kde-applications
DISTNAME= kde-workspace-${PORTVERSION}
-DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Plasma scriptengine for Ruby
@@ -17,6 +15,8 @@ USE_QT4= qmake_build moc_build uic_build rcc_build
USE_RUBY= yes
DISTINFO_FILE= ${.CURDIR:H:H}/x11/kde4-workspace/distinfo
+KDE_APPLICATIONS_VERSION= 15.08.0
+
CMAKE_SOURCE_PATH= ${WRKSRC}/plasma/generic/scriptengines/ruby
.include <bsd.port.mk>