aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorculot <culot@FreeBSD.org>2014-09-05 20:51:13 +0800
committerculot <culot@FreeBSD.org>2014-09-05 20:51:13 +0800
commit8c057c8768c5715bd6e4de67080950bd1b5149bb (patch)
treeb062a3012e8cb320894714f904b4ba758bd07e24
parent9afbd6557b721e4bcd932fb22874b6c52b5c6327 (diff)
downloadfreebsd-ports-gnome-8c057c8768c5715bd6e4de67080950bd1b5149bb.tar.gz
freebsd-ports-gnome-8c057c8768c5715bd6e4de67080950bd1b5149bb.tar.zst
freebsd-ports-gnome-8c057c8768c5715bd6e4de67080950bd1b5149bb.zip
Unicode::CaseFold allows to perform case-insensitive lookups using
case-folding. Case-folding is a part of the Unicode standard that allows any two strings that differ from one another only by case to map to the same "case-folded" form, even when those strings include characters with complex case-mappings. WWW: http://search.cpan.org/dist/Unicode-CaseFold/
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Unicode-CaseFold/Makefile32
-rw-r--r--textproc/p5-Unicode-CaseFold/distinfo2
-rw-r--r--textproc/p5-Unicode-CaseFold/pkg-descr6
4 files changed, 41 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 39232c269da7..af17f7ea7d76 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -880,6 +880,7 @@
SUBDIR += p5-UML-Sequence
SUBDIR += p5-UML-State
SUBDIR += p5-URI-Find
+ SUBDIR += p5-Unicode-CaseFold
SUBDIR += p5-Unicode-CheckUTF8
SUBDIR += p5-Unicode-Collate
SUBDIR += p5-Unicode-EastAsianWidth
diff --git a/textproc/p5-Unicode-CaseFold/Makefile b/textproc/p5-Unicode-CaseFold/Makefile
new file mode 100644
index 000000000000..1b9c7ba8b60c
--- /dev/null
+++ b/textproc/p5-Unicode-CaseFold/Makefile
@@ -0,0 +1,32 @@
+# Created by: Frederic Culot <culot@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Unicode-CaseFold
+PORTVERSION= 1.00
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:ARODLAND
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= culot@FreeBSD.org
+COMMENT= Unicode case-folding for case-insensitive lookups
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+USES= perl5
+USE_PERL5= modbuild
+
+PLIST_FILES= %%SITE_PERL%%/%%PERL_ARCH%%/Unicode/CaseFold.pm \
+ %%SITE_PERL%%/%%PERL_ARCH%%/Unicode/CaseFoldPP.pm \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/Unicode/CaseFold/CaseFold.so \
+ %%PERL5_MAN3%%/Unicode::CaseFold.3.gz
+
+PLIST_DIRS= %%SITE_PERL%%/%%PERL_ARCH%%/auto/Unicode/CaseFold
+PLIST_DIRSTRY= %%SITE_PERL%%/%%PERL_ARCH%%/auto/Unicode \
+ %%SITE_PERL%%/%%PERL_ARCH%%/Unicode
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto/Unicode/CaseFold/CaseFold.so
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Unicode-CaseFold/distinfo b/textproc/p5-Unicode-CaseFold/distinfo
new file mode 100644
index 000000000000..0849089adaaf
--- /dev/null
+++ b/textproc/p5-Unicode-CaseFold/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Unicode-CaseFold-1.00.tar.gz) = c489b5a440e84b0554e866d3fe4077fa1956eeed473e203588e0c24acce1f016
+SIZE (Unicode-CaseFold-1.00.tar.gz) = 65145
diff --git a/textproc/p5-Unicode-CaseFold/pkg-descr b/textproc/p5-Unicode-CaseFold/pkg-descr
new file mode 100644
index 000000000000..a85c2925cd44
--- /dev/null
+++ b/textproc/p5-Unicode-CaseFold/pkg-descr
@@ -0,0 +1,6 @@
+This module allows to perform case-insensitive lookups using case-folding.
+Case-folding is a part of the Unicode standard that allows any two strings
+that differ from one another only by case to map to the same "case-folded"
+form, even when those strings include characters with complex case-mappings.
+
+WWW: http://search.cpan.org/dist/Unicode-CaseFold/