aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-11-25 19:33:45 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-11-25 19:33:45 +0800
commit8d4c6b5d04f30d3d8edd905493387644d690b257 (patch)
treea30f893685a5ae03614128b8591ae3c572ba4fb9
parentfa5b14e50ce6e99a28bb24ee9343a2d66453ab59 (diff)
downloadfreebsd-ports-gnome-8d4c6b5d04f30d3d8edd905493387644d690b257.tar.gz
freebsd-ports-gnome-8d4c6b5d04f30d3d8edd905493387644d690b257.tar.zst
freebsd-ports-gnome-8d4c6b5d04f30d3d8edd905493387644d690b257.zip
- Support STAGEDIR
-rw-r--r--devel/libmaa/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/devel/libmaa/Makefile b/devel/libmaa/Makefile
index 48691c7645ae..f1008c7a222e 100644
--- a/devel/libmaa/Makefile
+++ b/devel/libmaa/Makefile
@@ -20,8 +20,8 @@ CPPFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
USE_AUTOTOOLS= libtool
-USES= gmake
USE_LDCONFIG= yes
+USES= gmake
DOCS= README doc/libmaa.600dpi.ps
PLIST_FILES= include/maa.h \
@@ -31,13 +31,12 @@ PLIST_FILES= include/maa.h \
lib/libmaa.so.3
PORTDOCS= ${DOCS:T}
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-install:
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}/
- cd ${WRKSRC}/ && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}/
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}/
+ cd ${WRKSRC}/ && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR}/
.endif
.include <bsd.port.mk>