aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2004-08-09 00:01:38 +0800
committerthierry <thierry@FreeBSD.org>2004-08-09 00:01:38 +0800
commit8ebb4e5d3ab5b98860edbda2088a240d9cfe1d8f (patch)
tree9b8493cb1185820bc4f92372b3732ed92fdea2ac
parent547bcb847110c60015770db7dea986aeebfab386 (diff)
downloadfreebsd-ports-gnome-8ebb4e5d3ab5b98860edbda2088a240d9cfe1d8f.tar.gz
freebsd-ports-gnome-8ebb4e5d3ab5b98860edbda2088a240d9cfe1d8f.tar.zst
freebsd-ports-gnome-8ebb4e5d3ab5b98860edbda2088a240d9cfe1d8f.zip
Upgrade to 1.1.4.
PR: ports/70149 Submitted by: maintainer.
-rw-r--r--security/rkhunter/Makefile10
-rw-r--r--security/rkhunter/distinfo4
-rw-r--r--security/rkhunter/files/patch-installer.sh36
-rw-r--r--security/rkhunter/files/patch-os.dat12
-rw-r--r--security/rkhunter/pkg-plist7
5 files changed, 21 insertions, 48 deletions
diff --git a/security/rkhunter/Makefile b/security/rkhunter/Makefile
index 1cfdc50e306b..c63a5c6734c8 100644
--- a/security/rkhunter/Makefile
+++ b/security/rkhunter/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= rkhunter
-PORTVERSION= 1.1.3
+PORTVERSION= 1.1.4
CATEGORIES= security
MASTER_SITES= http://downloads.rootkit.nl/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= bugghy@SAFe-mail.net
COMMENT= Rootkit detection tool
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
@@ -24,6 +24,8 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
MAN8= rkhunter.8
MANCOMPRESSED= no
+PORTDOCS= CHANGELOG README WISHLIST
+
post-patch:
@${SED} -e 's|PREFIX|${PREFIX}|g' ${FILESDIR}/pkg-message.in > ${PKGMESSAGE}
@@ -32,9 +34,7 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/files/development/rkhunter.8 ${MAN8PREFIX}/man/man8
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/files/CHANGELOG ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/files/README ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/files/WISHLIST ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/files/|} ${DOCSDIR}
.endif
@${CAT} ${PKGMESSAGE}
diff --git a/security/rkhunter/distinfo b/security/rkhunter/distinfo
index daa97e9fb771..c4c4871ed3c2 100644
--- a/security/rkhunter/distinfo
+++ b/security/rkhunter/distinfo
@@ -1,2 +1,2 @@
-MD5 (rkhunter-1.1.3.tar.gz) = 62271204de0fa0d2bf1b8489b1458dc7
-SIZE (rkhunter-1.1.3.tar.gz) = 98309
+MD5 (rkhunter-1.1.4.tar.gz) = 08938c110c8363c62c82dad0571517d0
+SIZE (rkhunter-1.1.4.tar.gz) = 102147
diff --git a/security/rkhunter/files/patch-installer.sh b/security/rkhunter/files/patch-installer.sh
index efbe57d1fe99..287a1f3249ae 100644
--- a/security/rkhunter/files/patch-installer.sh
+++ b/security/rkhunter/files/patch-installer.sh
@@ -1,22 +1,7 @@
---- installer.sh.orig Sun Jul 25 16:20:28 2004
-+++ installer.sh Sun Jul 25 17:19:48 2004
-@@ -69,6 +69,7 @@
- ;;
- *)
- echo "Wrong parameter"
-+ exit
- ;;
- esac
- shift
-@@ -111,21 +112,18 @@
- overwrite:check_port.pl:/scripts/check_port.pl:Portscanner
- overwrite:filehashmd5.pl:/scripts/filehashmd5.pl:MD5%%Digest%%generator
- overwrite:filehashsha1.pl:/scripts/filehashsha1.pl:SHA1%%Digest%%generator
--verwrite:showfiles.pl:/scripts/showfiles.pl:Directory%%viewer
-+overwrite:showfiles.pl:/scripts/showfiles.pl:Directory%%viewer
- overwrite:backdoorports.dat:/db/backdoorports.dat:Database%%Backdoor%%ports
- overwrite:mirrors.dat:/db/mirrors.dat:Database%%Update%%mirrors
- overwrite:os.dat:/db/os.dat:Database%%Operating%%Systems
+--- installer.sh.old Sun Aug 8 00:16:28 2004
++++ installer.sh Sun Aug 8 00:21:52 2004
+@@ -120,15 +120,12 @@
+ overwrite:programs_good.dat:/db/programs_good.dat:Database%%Program%%versions
overwrite:defaulthashes.dat:/db/defaulthashes.dat:Database%%Default%%file%%hashes
overwrite:md5blacklist.dat:/db/md5blacklist.dat:Database%%MD5%%blacklisted%%files
-overwrite:CHANGELOG:/docs/CHANGELOG:Changelog
@@ -33,7 +18,7 @@
"
# Create directories (only if they do not exist)
-@@ -134,10 +132,7 @@
+@@ -137,10 +134,7 @@
${INSTALLDIR}/etc
${INSTALLDIR}/bin
${INSTALLDIR}/lib/rkhunter/db
@@ -44,16 +29,17 @@
"
CHECKDIR="/usr/local"
-@@ -345,8 +340,6 @@
+@@ -347,9 +341,6 @@
+ #################################################################################
- # Clean active window
+-# Clean active window
-clear
-
echo "${INSTALLER_NAME} ${INSTALLER_VERSION} (${INSTALLER_COPYRIGHT})"
echo $ECHOOPT "---------------"
echo "Starting installation/update"
-@@ -467,7 +460,7 @@
+@@ -470,7 +461,7 @@
if [ -f ${INSTALLPREFIX}${CURFILE} ]
then
#error redirection in .rkhunter it's just for a clear display if user run not as root
@@ -62,7 +48,7 @@
if [ $? -eq 0 ]
then
echo $E "OK"
-@@ -482,10 +475,10 @@
+@@ -485,10 +476,10 @@
done
@@ -75,7 +61,7 @@
echo "Configuration updated with installation path (${INSTALLDIR})"
else
echo "Configuration already updated."
-@@ -495,7 +488,7 @@
+@@ -498,7 +489,7 @@
then
echo ""
echo $E "$t17"
diff --git a/security/rkhunter/files/patch-os.dat b/security/rkhunter/files/patch-os.dat
deleted file mode 100644
index 3dabadd24fb6..000000000000
--- a/security/rkhunter/files/patch-os.dat
+++ /dev/null
@@ -1,12 +0,0 @@
-$FreeBSD$
-
---- files/os.dat.orig Mon Jul 26 13:37:35 2004
-+++ files/os.dat Mon Jul 26 13:38:02 2004
-@@ -69,6 +69,7 @@
- 207:OpenBSD 3.4 (i386):/bin/md5:/usr/local/bin:
- 208:FreeBSD 4.9 (i386):/sbin/md5 -q:/usr/local/bin:
- 209:FreeBSD 5.2.1 (i386):/sbin/md5 -q:/usr/local/bin:
-+210:FreeBSD 4.10 (i386):/sbin/md5 -q:/usr/local/bin:
- 300:Sun Solaris 8 (sparc):/bin/ls:/bin:
- 400:IBM AIX 5.4:/bin/ls:/bin:
- 401:IBM AIX 5.3:/bin/ls:/bin:
diff --git a/security/rkhunter/pkg-plist b/security/rkhunter/pkg-plist
index 3fc144980390..df68dfff63fe 100644
--- a/security/rkhunter/pkg-plist
+++ b/security/rkhunter/pkg-plist
@@ -3,17 +3,16 @@ bin/rkhunter
lib/rkhunter/db/backdoorports.dat
lib/rkhunter/db/mirrors.dat
lib/rkhunter/db/os.dat
+lib/rkhunter/db/programs_bad.dat
+lib/rkhunter/db/programs_good.dat
lib/rkhunter/db/defaulthashes.dat
lib/rkhunter/db/md5blacklist.dat
lib/rkhunter/scripts/check_modules.pl
lib/rkhunter/scripts/check_port.pl
+lib/rkhunter/scripts/check_update.sh
lib/rkhunter/scripts/filehashmd5.pl
lib/rkhunter/scripts/filehashsha1.pl
lib/rkhunter/scripts/showfiles.pl
@dirrm lib/rkhunter/scripts
@dirrm lib/rkhunter/db
@dirrm lib/rkhunter
-%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/WISHLIST
-%%PORTDOCS%%@dirrm %%DOCSDIR%%