aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2007-07-03 16:20:49 +0800
committerdanfe <danfe@FreeBSD.org>2007-07-03 16:20:49 +0800
commit8f4aa25c8ed5f0c6202471f01076dbbedc430009 (patch)
treee62f4964dc5a62a2e5822618e6d3681932454cf7
parent7a432d325bcd4dc40ff494ca7d539f6ccc61b841 (diff)
downloadfreebsd-ports-gnome-8f4aa25c8ed5f0c6202471f01076dbbedc430009.tar.gz
freebsd-ports-gnome-8f4aa25c8ed5f0c6202471f01076dbbedc430009.tar.zst
freebsd-ports-gnome-8f4aa25c8ed5f0c6202471f01076dbbedc430009.zip
- Unbreak with recent GCC
- Consistencify sed(1) regexps
-rw-r--r--textproc/xmlwrapp/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/textproc/xmlwrapp/Makefile b/textproc/xmlwrapp/Makefile
index b8d678e88012..dd62f6632760 100644
--- a/textproc/xmlwrapp/Makefile
+++ b/textproc/xmlwrapp/Makefile
@@ -27,10 +27,6 @@ CFLAGS+= -fPIC
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
-.endif
-
.if ${HAVE_GNOME:Mlibxslt}!=""
USE_GNOME+= libxslt
.else
@@ -38,6 +34,10 @@ CONFIGURE_ARGS+= --disable-xslt
.endif
post-patch:
- @${REINPLACE_CMD} "s:/usr/bin/perl:${PERL}:" ${WRKSRC}/configure.pl
+ @${REINPLACE_CMD} -e 's,/usr/bin/perl,${PERL},' ${WRKSRC}/configure.pl
+# Fix for GCC 4.2
+ @${REINPLACE_CMD} -e 's,^std::ostream,namespace xml { &,' \
+ -e '/^namespace/s,xml::,,g' -e '$$s,^,} ,' \
+ ${WRKSRC}/src/libxml/node.cxx
.include <bsd.port.post.mk>