aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2004-03-02 07:48:34 +0800
committerclement <clement@FreeBSD.org>2004-03-02 07:48:34 +0800
commit8f814fe6700c931d70235d0484bdf0e9da7f1a2c (patch)
tree7b68764d2f5ab58646544695c54e2f3706dcfdbe
parentd3e19b40e8902965e22717a1339ac897d7bf8543 (diff)
downloadfreebsd-ports-gnome-8f814fe6700c931d70235d0484bdf0e9da7f1a2c.tar.gz
freebsd-ports-gnome-8f814fe6700c931d70235d0484bdf0e9da7f1a2c.tar.zst
freebsd-ports-gnome-8f814fe6700c931d70235d0484bdf0e9da7f1a2c.zip
- Fix build on -CURRENT
PR: 62721 Submitted by: Sergey Matveychuk <sem@ciam.ru>
-rw-r--r--www/mod_auth_kerb/Makefile10
-rw-r--r--www/mod_auth_kerb2/Makefile10
2 files changed, 8 insertions, 12 deletions
diff --git a/www/mod_auth_kerb/Makefile b/www/mod_auth_kerb/Makefile
index b9b806eb40f0..f82384b13cc9 100644
--- a/www/mod_auth_kerb/Makefile
+++ b/www/mod_auth_kerb/Makefile
@@ -29,12 +29,10 @@ USE_APACHE= yes
WRKSRC= ${WRKDIR}/src/modules/kerberos
KRB5_HOME?= ${LOCALBASE}
+USE_REINPLACE= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502000
-BROKEN= "Does not compile"
-.endif
+post-patch:
+ @${REINPLACE_CMD} '379N;s/\n/ /' ${WRKSRC}/mod_auth_kerb.c
do-build:
cd ${WRKSRC} && \
@@ -49,4 +47,4 @@ do-build:
do-install:
${APXS} -i -A -n ${PORTNAME:S/mod_//g} ${WRKSRC}/${PORTNAME}.so
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/mod_auth_kerb2/Makefile b/www/mod_auth_kerb2/Makefile
index b9b806eb40f0..f82384b13cc9 100644
--- a/www/mod_auth_kerb2/Makefile
+++ b/www/mod_auth_kerb2/Makefile
@@ -29,12 +29,10 @@ USE_APACHE= yes
WRKSRC= ${WRKDIR}/src/modules/kerberos
KRB5_HOME?= ${LOCALBASE}
+USE_REINPLACE= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502000
-BROKEN= "Does not compile"
-.endif
+post-patch:
+ @${REINPLACE_CMD} '379N;s/\n/ /' ${WRKSRC}/mod_auth_kerb.c
do-build:
cd ${WRKSRC} && \
@@ -49,4 +47,4 @@ do-build:
do-install:
${APXS} -i -A -n ${PORTNAME:S/mod_//g} ${WRKSRC}/${PORTNAME}.so
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>