aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-05-25 00:35:30 +0800
committerbapt <bapt@FreeBSD.org>2013-05-25 00:35:30 +0800
commit8fb596db30fc304c30072b44b4c7f855046822f1 (patch)
treefe4ce18513a9d787d533353cb3f6be9d8eacc957
parent32614f4f72427625e19e6ceb4bc533c0bd4f401a (diff)
downloadfreebsd-ports-gnome-8fb596db30fc304c30072b44b4c7f855046822f1.tar.gz
freebsd-ports-gnome-8fb596db30fc304c30072b44b4c7f855046822f1.tar.zst
freebsd-ports-gnome-8fb596db30fc304c30072b44b4c7f855046822f1.zip
Do not let system make.conf inpact the port's makefile
This fixes build on current
-rw-r--r--archivers/libcabinet/Makefile1
-rw-r--r--archivers/libcabinet/files/patch-Makefile2
-rw-r--r--devel/libpdel/Makefile7
-rw-r--r--devel/libxalloc/Makefile5
-rw-r--r--finance/libstocks/Makefile7
-rw-r--r--games/libshhcards/Makefile11
-rw-r--r--games/libshhcards/files/Makefile.lib2
-rw-r--r--japanese/ming/Makefile3
-rw-r--r--math/linpack/Makefile7
-rw-r--r--www/cgic/Makefile11
-rw-r--r--www/cgic/files/Makefile.lib2
11 files changed, 26 insertions, 32 deletions
diff --git a/archivers/libcabinet/Makefile b/archivers/libcabinet/Makefile
index f2b30eec0a76..b17efe078f87 100644
--- a/archivers/libcabinet/Makefile
+++ b/archivers/libcabinet/Makefile
@@ -13,6 +13,7 @@ USE_LDCONFIG= yes
SRCFILE= ${WRKSRC}/listcab.cpp
PROGFILE= ${SRCFILE:S/.cpp$//}
+MAKE_ENV= WITHOUT_PROFILE=yes __MAKE_CONF=/dev/null SRCCONF=/dev/null
post-build:
${CXX} ${CXXFLAGS} -o ${PROGFILE} ${SRCFILE} -L${WRKSRC} -lcabinet
diff --git a/archivers/libcabinet/files/patch-Makefile b/archivers/libcabinet/files/patch-Makefile
index c649df161467..01e67ad0e9fc 100644
--- a/archivers/libcabinet/files/patch-Makefile
+++ b/archivers/libcabinet/files/patch-Makefile
@@ -1,7 +1,7 @@
--- Makefile.orig Tue Aug 19 18:15:11 2003
+++ Makefile Tue Aug 19 18:33:06 2003
@@ -0,0 +1,16 @@
-+NOPROFILE= true
++NO_PROFILE= true
+CXXFLAGS+= -Wno-deprecated
+LIB= cabinet
+LIBDIR= ${PREFIX}/lib
diff --git a/devel/libpdel/Makefile b/devel/libpdel/Makefile
index 8f6f0278324f..66ad4dca3af1 100644
--- a/devel/libpdel/Makefile
+++ b/devel/libpdel/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libpdel
-# Date created: 22 Apr 2002
-# Whom: Archie Cobbs
-#
+# Created by: Archie Cobbs
# $FreeBSD$
-#
PORTNAME= libpdel
PORTVERSION= 0.5.3
@@ -15,6 +11,7 @@ MAINTAINER= mav@alkar.net
COMMENT= Packet Design multi-purpose C library for embedded applications
LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
+MAKE_ENV= WITHOUT_PROFILE=yes __MAKE_CONF=/dev/null SRCCONF=/dev/null
USE_LDCONFIG= yes
diff --git a/devel/libxalloc/Makefile b/devel/libxalloc/Makefile
index 95c3928648f8..6852d3dcd33a 100644
--- a/devel/libxalloc/Makefile
+++ b/devel/libxalloc/Makefile
@@ -12,9 +12,12 @@ COMMENT= A memory allocation library with error checking
MAKEFILE= ${FILESDIR}/Makefile.lib
USE_LDCONFIG= yes
+MAKE_ENV= WITHOUT_PROFILE=yes __MAKE_CONF=/dev/null SRCCONF=/dev/null
+
+.include <bsd.port.options.mk>
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/CREDITS ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
diff --git a/finance/libstocks/Makefile b/finance/libstocks/Makefile
index ed1160ed2b32..c4d5b1c78d65 100644
--- a/finance/libstocks/Makefile
+++ b/finance/libstocks/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libstocks
-# Date created: this 7th day of January, 2002
-# Whom: Mikhail Teterin
-#
+# Created by: Mikhail Teterin
# $FreeBSD$
-#
PORTNAME= libstocks
PORTVERSION= 0.5.0
@@ -15,6 +11,7 @@ COMMENT= A C library which can be used to fetch stocks quotes
USE_LDCONFIG= yes
REINPLACE_ARGS= -i ""
+MAKE_ENV= WITHOUT_PROFILE=yes __MAKE_CONF=/dev/null SRCCONF=/dev/null
post-patch:
${REINPLACE_CMD} -e 's/<malloc.h>/<stdlib.h>/' \
diff --git a/games/libshhcards/Makefile b/games/libshhcards/Makefile
index 0bf9b0111e92..5f237a13a343 100644
--- a/games/libshhcards/Makefile
+++ b/games/libshhcards/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libshhcards
-# Date created: 12 April 1998
-# Whom: Andrey Zakhvatov
-#
+# Created by: Andrey Zakhvatov
# $FreeBSD$
-#
PORTNAME= libshhcards
PORTVERSION= 1.0.5
@@ -18,9 +14,12 @@ COMMENT= Library for displaying game cards on X Window System
USE_XORG= xpm
MAKEFILE= ${FILESDIR}/Makefile.lib
USE_LDCONFIG= yes
+MAKE_ENV= WITHOUT_PROFILE=yes __MAKE_CONF=/dev/null SRCCONF=/dev/null
+
+.include <bsd.port.options.mk>
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/CREDITS ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
diff --git a/games/libshhcards/files/Makefile.lib b/games/libshhcards/files/Makefile.lib
index f5488978f8fe..5b2623438429 100644
--- a/games/libshhcards/files/Makefile.lib
+++ b/games/libshhcards/files/Makefile.lib
@@ -5,7 +5,7 @@ LIB= shhcards
LIBDIR= ${PREFIX}/lib
SHLIB_MAJOR= ${SHLIB_VER}
SHLIB_MINOR= 0
-NOPROFILE= yes
+NO_PROFILE= yes
NOOBJ= yes
INCS= shhcards.h
diff --git a/japanese/ming/Makefile b/japanese/ming/Makefile
index c93d1115f127..10ad583ddcb5 100644
--- a/japanese/ming/Makefile
+++ b/japanese/ming/Makefile
@@ -17,9 +17,10 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
CONFLICTS= ming-*
WRKSRC= ${WRKDIR}/jaming-${PORTVERSION}/src
-MAKE_ARGS= NOPROFILE=true
+MAKE_ARGS= NO_PROFILE=true
USE_LDCONFIG= yes
USES= bison
+MAKE_ENV= WITHOUT_PROFILE=yes __MAKE_CONF=/dev/null SRCCONF=/dev/null
UTILS= gif2dbl \
gif2mask \
diff --git a/math/linpack/Makefile b/math/linpack/Makefile
index 158955c89339..776c7664bb19 100644
--- a/math/linpack/Makefile
+++ b/math/linpack/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: linpack
-# Date created: 31 October 1994
-# Whom: ljo
-#
+# Created by: ljo
# $FreeBSD$
-#
PORTNAME= linpack
PORTVERSION= 1.0
@@ -16,6 +12,7 @@ MAINTAINER= bf@FreeBSD.org
COMMENT= Linear Algebra package
LIB_DEPENDS= blas.2:${PORTSDIR}/math/blas
+MAKE_ENV= WITHOUT_PROFILE=yes __MAKE_CONF=/dev/null SRCCONF=/dev/null
.include <bsd.port.pre.mk>
diff --git a/www/cgic/Makefile b/www/cgic/Makefile
index e00cf184d805..6f4781ca64e5 100644
--- a/www/cgic/Makefile
+++ b/www/cgic/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libcgic
-# Date created: 27 July 1999
-# Whom: Andrey Zakhvatov
-#
+# Created by: Andrey Zakhvatov
# $FreeBSD$
-#
PORTNAME= cgic
PORTVERSION= 2.05
@@ -18,11 +14,14 @@ MAKE_ENV= SHLIB_MAJOR="${SHLIB_MAJOR}"
MAKEFILE= ${FILESDIR}/Makefile.lib
PLIST_SUB= SHLIB_MAJOR="${SHLIB_MAJOR}"
USE_LDCONFIG= yes
+MAKE_ENV= WITHOUT_PROFILE=yes __MAKE_CONF=/dev/null SRCCONF=/dev/null
SHLIB_MAJOR= ${PORTVERSION:R}
+.include <bsd.port.options.mk>
+
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/*.html ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/*.txt ${DOCSDIR}
diff --git a/www/cgic/files/Makefile.lib b/www/cgic/files/Makefile.lib
index def67c9c8dff..f3f48d50614b 100644
--- a/www/cgic/files/Makefile.lib
+++ b/www/cgic/files/Makefile.lib
@@ -1,7 +1,7 @@
LIB= cgic
SHLIB_MAJOR?= 1
-NOPROFILE= yes
+NO_PROFILE= yes
LIBDIR= ${PREFIX}/lib
INCDIR= ${PREFIX}/include