aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-06-14 00:15:51 +0800
committermarino <marino@FreeBSD.org>2014-06-14 00:15:51 +0800
commit901a553056b2cb86929c1fd72edfcae348ac49ab (patch)
treed27861cd064b9c5ed382d2aa14eb5e3f73dde813
parent0f1326b3d3c2176dfdae6624c10a2ac71ef8b7a0 (diff)
downloadfreebsd-ports-gnome-901a553056b2cb86929c1fd72edfcae348ac49ab.tar.gz
freebsd-ports-gnome-901a553056b2cb86929c1fd72edfcae348ac49ab.tar.zst
freebsd-ports-gnome-901a553056b2cb86929c1fd72edfcae348ac49ab.zip
www/thundercache: Stage support, PGSQL option fix and more
The PR only provided changes needed to add stage support. However, the port needed some additional TLC: * DISTNAME reworked for single, ARCH-based definition (pets portlint) * LICENSE stuff moved, rearranged (pets portlint) * DOCS option removed (it wasn't implemented) * Typo for PGSQL option fixed so it's default again (bump portrevision) * Cosmestic alignment * PGSQL converted to USES+=pgsql and WANT_PGSQL= * php+pgsql RUN_DEPENDS refactored, and set to use USE_PHP * Convert to new LIB_DEPENDS style (PR) * Convert to USES+=tar (PR) * Remove WWW whitespace (PR) * Handle /var/run/thunder (PR) (also requires portrevision bump) PR: 190951 Submitted by: Joe Benden fixes by: marino Approved by: stage blanket + just fix it blanket verified by: Redports 8x pass
-rw-r--r--www/thundercache/Makefile60
-rw-r--r--www/thundercache/pkg-descr2
-rw-r--r--www/thundercache/pkg-plist2
3 files changed, 31 insertions, 33 deletions
diff --git a/www/thundercache/Makefile b/www/thundercache/Makefile
index d9646b34edf4..0d088f700193 100644
--- a/www/thundercache/Makefile
+++ b/www/thundercache/Makefile
@@ -2,46 +2,44 @@
PORTNAME= thundercache
PORTVERSION= 6.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= www
MASTER_SITES= http://www.thundercache.com.br/dist/ \
http://www.bmsoftware.org/packs/ \
http://www8.freebsdbrasil.com.br/~eksffa/thunder/ \
http://www6.freebsdbrasil.com.br/~eksffa/l/dev/thunder/ \
${MASTER_SITE_LOCAL}/jmelo
-DISTNAME= thundercache-6.1.201104260900-64bits-fbsd
+DISTNAME= thundercache-6.1.201104260900-${BITS}-fbsd
MAINTAINER= eksffa@freebsdbrasil.com.br
COMMENT= High-performance and high-efficiency caching proxy system
-OPTIONS_DEFINE= DEPENDACK APACHE PHP PGSQL DOCS
-OPTIONS_DEFAULT= DEPENDACK APACHE PHP PGSQK
-DEPENDACK_DESC= I have read and understood the depends needs
-APACHE_DESC= Install apache for reporting viewing
-PHP_DESC= Install PHP for reporting generating
-PGSQL_DESC= Install PostgreSQL (report data storing)
+LICENSE= commercial
+LICENSE_NAME= commercial
+LICENSE_TEXT= Commercial software with shareware license to 50 threads
+LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
+
+RESTRICTED= Commercial software with shareware license to 50 threads
+
+OPTIONS_DEFINE= DEPENDACK APACHE PHP PGSQL
+OPTIONS_DEFAULT=DEPENDACK APACHE PHP PGSQL
+DEPENDACK_DESC= I have read and understood the depends needs
+APACHE_DESC= Install apache for reporting viewing
+PHP_DESC= Install PHP for reporting generating
+PGSQL_DESC= Install PostgreSQL (report data storing)
USE_OPENSSL= yes
-USE_BZIP2= yes
+USES= tar:bzip2
ONLY_FOR_ARCHS= i386 amd64
USE_RC_SUBR= thundercache
NO_BUILD= yes
-LICENSE= commercial
-LICENSE_NAME= commercial
-LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
-LICENSE_TEXT= Commercial software with shareware license to 50 threads
-RESTRICTED= Commercial software with shareware license to 50 threads
-NO_STAGE= yes
.include <bsd.port.options.mk>
-.if ${ARCH} == "i386"
-DISTNAME= thundercache-6.1.201104260900-32bits-fbsd
-.endif
-
+BITS= ${ARCH:S/amd64/64/:S/x86_64/64/:S/i386/32/}bits
WRKSRC= ${WRKDIR}/thunder
.if ${PORT_OPTIONS:MAPACHE}
@@ -49,21 +47,20 @@ USE_APACHE_RUN= 22+
.endif
.if ${PORT_OPTIONS:MPGSQL}
-USE_PGSQL= yes
-WANT_PGSQL_VER= 84+
-RUN_DEPENDS+= postgresql-server>=0:${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
-.endif
-
-.if ${PORT_OPTIONS:MPHP} && ${PORT_OPTIONS:MPGSQL}
-RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/pdo_pgsql.so:${PORTSDIR}/databases/php5-pdo_pgsql
-RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/pgsql.so:${PORTSDIR}/databases/php5-pgsql
+USES+= pgsql
+WANT_PGSQL= server
.endif
.if ${PORT_OPTIONS:MPHP}
USE_PHP+= curl pcre bcmath pdo mcrypt mhash session
+. if ${PORT_OPTIONS:MPGSQL}
+USE_PHP+= pdo_pgsql pgsql
+. endif
.endif
-LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl \
+ libstdc++.so:${PORTSDIR}/lang/gcc \
+ libutil.so:${PORTSDIR}/misc/compat8x
SUB_FILES= pkg-message log.sh test-deps.sh
SUB_LIST= "GREP=${GREP}"
@@ -91,12 +88,11 @@ show-info:
pre-everything::show-info
do-install:
- @${CP} -r ${WRKSRC} ${PREFIX}/
- ${INSTALL_SCRIPT} ${WRKDIR}/log.sh ${PREFIX}/thunder/sbin/
- @${MKDIR} -m 755 /var/run/thunder
+ @${CP} -r ${WRKSRC} ${STAGEDIR}${PREFIX}/
+ @${INSTALL_SCRIPT} ${WRKDIR}/log.sh ${STAGEDIR}${PREFIX}/thunder/sbin/
+ @${MKDIR} -m 755 ${STAGEDIR}/var/run/thunder
post-install:
- @${CAT} ${PKGMESSAGE}
@(${CHMOD} +x ${WRKDIR}/test-deps.sh ; \
if ! ${WRKDIR}/test-deps.sh > /dev/null 2>&1 ; then \
${ECHO_MSG} "**** FATAL **** " ; \
diff --git a/www/thundercache/pkg-descr b/www/thundercache/pkg-descr
index 42c14309a485..5bfc5d7fb4ed 100644
--- a/www/thundercache/pkg-descr
+++ b/www/thundercache/pkg-descr
@@ -9,4 +9,4 @@ license to run more than 50 concurrent sessions. It's designed to run on
FreeBSD. Advanced features include TProxy support (IP_BINDANY), ToS/DiffService
marking.
-WWW: http://www.bmsoftware.org
+WWW: http://www.bmsoftware.org
diff --git a/www/thundercache/pkg-plist b/www/thundercache/pkg-plist
index 5f701986c7af..f63852acf53b 100644
--- a/www/thundercache/pkg-plist
+++ b/www/thundercache/pkg-plist
@@ -7,6 +7,8 @@ thunder/sbin/thunderlog.php
thunder/sbin/diskinfo
thunder/sbin/thunder
thunder/sbin/log.sh
+@exec mkdir -p /var/run/thunder
+@exec chmod 755 /var/run/thunder
@dirrm thunder/etc
@dirrm thunder/logs/tmp
@dirrm thunder/logs