aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-08-21 07:19:51 +0800
committerpav <pav@FreeBSD.org>2004-08-21 07:19:51 +0800
commit905609a46da4c05c967ba303a9d21230bd4f15d4 (patch)
tree97dd5d52fb6a0a1da582e186e63325b4839a72c4
parent787681dc75f68360e85f66584bb7431d0e2e5e7b (diff)
downloadfreebsd-ports-gnome-905609a46da4c05c967ba303a9d21230bd4f15d4.tar.gz
freebsd-ports-gnome-905609a46da4c05c967ba303a9d21230bd4f15d4.tar.zst
freebsd-ports-gnome-905609a46da4c05c967ba303a9d21230bd4f15d4.zip
- Convert to OPTIONS
PR: ports/70737, ports/70738 Submitted by: Ying-Chieh Chen <yinjieh@csie.nctu.edu.tw>
-rw-r--r--graphics/sane-backends/Makefile11
-rw-r--r--graphics/sane-frontends/Makefile15
2 files changed, 9 insertions, 17 deletions
diff --git a/graphics/sane-backends/Makefile b/graphics/sane-backends/Makefile
index 7b9cf2e1e2b7..77cabfebb109 100644
--- a/graphics/sane-backends/Makefile
+++ b/graphics/sane-backends/Makefile
@@ -25,6 +25,9 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAKE_ENV= NOPORTDOCS=${NOPORTDOCS}
INSTALLS_SHLIB= yes
+OPTIONS= NLS "NLS support" on \
+ GPHOTO2 "gPhoto2 support" off
+
.include <bsd.port.pre.mk>
.if defined(WITHOUT_NLS)
@@ -43,13 +46,5 @@ CONFIGURE_ARGS+= --with-gphoto2=no
PLIST_SUB+= GPHOTO2="@comment "
.endif
-pre-everything::
-.if !defined(WITH_GPHOTO2)
- @${ECHO_MSG}
- @${ECHO_MSG} "If you want to compile with gPhoto2 support,"
- @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_GPHOTO2=yes\""
- @${ECHO_MSG}
-.endif
-
.include "Makefile.man"
.include <bsd.port.post.mk>
diff --git a/graphics/sane-frontends/Makefile b/graphics/sane-frontends/Makefile
index 112ba9463924..0aa7ce9deda7 100644
--- a/graphics/sane-frontends/Makefile
+++ b/graphics/sane-frontends/Makefile
@@ -26,6 +26,11 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= scanadf.1 xcam.1 xscanimage.1
+OPTIONS= GTK1 "GTK1 support (Default is GTK2)" off \
+ GIMP "also build xscanimage as a GIMP plug-in" off
+
+.include <bsd.port.pre.mk>
+
.if defined(WITH_GTK1)
USE_GNOME+= gtk12
CONFIGURE_ARGS+= --disable-gtk2
@@ -45,15 +50,7 @@ CONFIGURE_ARGS+= --disable-gimp
.endif
.endif
-pre-everything::
-.if !defined(WITH_GIMP)
- @${ECHO_MSG} "*** Note: xscanimage can be built with a standalone"
- @${ECHO_MSG} "*** X scanner interface as well as a GIMP plug-in."
- @${ECHO_MSG} "*** If you wish to do this, hit Ctrl-C now and use"
- @${ECHO_MSG} "*** \"WITH_GIMP=yes\""
-.endif
-
post-install:
@${SED} 's:/usr/local:${PREFIX}:' ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>